
11.205 – Intro to Spatial Analysis – Fall 2019 
Week 2 – Spatial Data, Types, and Structures 
ArcMap Exercise  
 
[OCW Users: The following document refers to online resources (Stellar and CRON) that are not 
available to users outside MIT.] 

Week 2 Objectives – Metadata, Categorical Data, Land Use Mapping,  
and Queries 
 
Objectives 
 
I. Learn more about metadata 
II. Join tabular tax database to parcel file 
III. Make a map using categorical data 
IV. Query to extract a specific subset of land use 
V. Add a field and calculate some basic summary statistics 
VI. Perform grouping 
 
Lab Data 
 
Download the class files from Stellar and load them onto your external hard drive. 
 
The unzipped file consists of the following folders: 

1. DOCUMENTS: This folder includes Word documents for this week’s in-class and take-home 
exercise(s).  

2. DATA: This folder contains all the data needed for this week’s in-class and take-home 
exercise(s). 

  
In the first part of the in-class exercise, we are going to create a land use map of Cambridge. The Bronx 
River Alliance wants a similar map for the Bronx that you are going to make for your take-home exercise, 
but let’s see how we can do it in Cambridge first. 
 
OBJECTIVE 1: LEARN MORE ABOUT METADATA 
 
Information on housing, parcels, land use, assessed values, and other attributes have been maintained 
for centuries by tax assessors for the purpose of land appraisal and tax collection. Historically, these 
records have been referred to as a city’s cadaster. The tax assessor makes databases based on parcels 
that include a number of attributes, including land use type, so that they can appraise property. In the 
past few decades, much of this data has been digitized and made available, in some form, to the public. 
 
Most municipalities maintain large parcel datasets for the areas over which they have jurisdiction. Each 
parcel has a unique identifier that can be used to join Tax Assessor data to the geographic parcel data. 
This allows us to make maps of most anything in the assessor’s database by using the unique identifier 
of the Parcel ID to perform a join with the Assessors data to the geometry file of the parcels. 
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Assessor’s data is highly detailed and contains a very large amount of information. The attributes for 
each listing in the Assessor’s data are wide ranging and the field names are often simplified. For 
example, a field heading might be “LAND_CODE” and the data in the fields are numbers. Each number 
usually represents a Land use, such as 1= residential, 2 = commercial and so on. How than can one find 
the code values?  You use what is called metadata. Metadata can also be called a lookup table or a data 
dictionary. 
 
Metadata exists in two primary forms: 1) file metadata, and 2) separate lookup tables. File metadata can 
be used in GIS software and contains information on the file, ranging from author and date, to the 
meaning of each field. Lookup tables are usually separate documents that contain a list of attributes, 
their definitions, and the meanings of their values. In the first part of this exercise, we are going to make 
a land use map by joining spatial parcel datasets and tabular data containing a land use attribute. 
 
Assessor’s Data and Lookup Tables 
 
The data we are going to use is assessors’ data from Fiscal Year 2018 downloaded from the City of 
Cambridge GIS website (http://www.cambridgema.gov/GIS/). 
 
We have downloaded the data for you and modified it by adding a few notes and a generalized land use 
field for illustration purposes, but it is freely available data. Let’s explore the file. 
 

1. Open Microsoft Excel, go to File > Open, and navigate to the Cambridge folder within Data in 
this week’s materials. In the dropdown box at the bottom right, set the dialog to show All Files.  
 

 
 
Locate cam_assessor_fy18.dbf. (Note: if you try to open this file through Windows Explorer, the CRON 
computers need to have their default program specified. Make sure you open this in Excel. The best way 
to do this is to right click on the file, then choose Open With > Excel.) 
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Locate and open cam_assessor_fy18.dbf. 
 
Below is a screenshot of the Assessors dataset. Some of the field names are abbreviated so it might be 
hard to tell what data is held within them. When you download the data from the site, it comes with a 
Lookup table. This Lookup table will let us know what each field means.  
 
(Note: If your column widths are stretched out, you can Select All, go to the Home Tab, click Format in 
the Cells sub-palette, and click AutoFit Column Width.) 

 
cam_assessor_fy18.dbf 
 

2. Go to Windows Explorer and open the Lookup Table called cam_assessor_README.txt using any 
text editor. It is in our weekly materials in the Cambridge folder within Data.  
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Note: you want the file type to be Text Document (.txt). There is another file with the 
extension .txt that is actually an XML document) This file contains the information on what 
each field in the assessor’s database contains It will look like the following. 
 

 
 
 
 
This is a ‘metadata’ file, or in other words, data about data. In particular, it is a lookup table (or data 
dictionary). This file tells us what is in the Assessor’s database. 
 
Note that the field GISID can be used to link this data to the corresponding Parcel GIS file and display 
this information in the map. Also note the descriptions. We can find more detailed information on the 
State Land Use Code (state_use_code.xls) and Generalized Land Use Code (Use_gen_codes.xls) by 
looking in these supplement files. Open them now and take a look. 
 
 
 
Land Use Data and Lookup Tables 
 
Land Use Codes represent the type of land use that has been designated for each parcel in the municipal 
parcel database. They usually fall into a handful of common categories that represent the current usage 
of each parcel, such as residential, commercial, industrial, and institutional, among others. We saw, in 
the Lookup Table above, that our file contains Land Use Codes (PCC and USE_GEN). 
 
The Commonwealth of Massachusetts and City of Cambridge use very detailed land use codes, which 
can be found in the lookup file called State_Use_Codes.xls. There are also generalized land use codes, 
which are recorded in the USE_GEN field in the cam_assessor_fy18.dbf  file. The lookup table for 
USE_GEN is USE_GEN_Codes.xls is in your weekly materials. Let’s take a look. 
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1. Go ahead and open the 
/Data/Cambridge/State_Use_Codes.xls file if you 
haven’t opened it already. This contains the Data 
Dictionary that shows what each of the State Use 
Codes mean. It will look like the following. 
 
Note that the value of STATE USE CODE 
corresponds to the values found in the USECODE 

field in the Assessors database. 
Open State_Use_Codes.xls. 
 
2. The Lookup Table for USE_GEN in the Assessors data is called USE_GEN_Codes.xls. In 
…/Data/Cambridge open USE_GEN_Codes.xls. You can use this table to lookup what the values in 
USE_GEN correspond to. It looks like the following. 
 

 
Open USE_GEN_Codes.xls if you haven’t opened it already. 
 
Note the values. We can refer to these at any point during the exercise as needed. 
 
USE_GEN  Description 
0   Other 
1   Residential 
3   Commercial 
4   Industrial 
9   Institutional 
 
 

3. Close the two files. DO NOT SAVE! The process of opening the Lookup tables and Assessor’s 
data is meant to educate us on what the data contains and what the fields mean. 
 

4. Next, we will base a join between a parcel shape file on ArcGIS and the Tax Assessors data based 
on the GISID and ML fields.  

 
 
 
OBJECTIVE 2: JOIN TABULAR TAX DATABASE TO PARCEL FILE 
 
In lecture this week, we discussed spatial data, including what it is, its types, and how it is structured. In 
the second part of this exercise, we will utilize the concepts of the relational database model to join the 
tabular tax assessor dataset to the parcel shapefile, and then symbolize the tabular data on the map. 
Our goal will be to create a land use map of Cambridge. 
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1. Create a New Map and Add Data 
 
Your home folder is the location where your Map Document will be stored and is used by default to save 
results, store new datasets, and access information. ArcMap’s default behavior is to set your project’s 
home directory to the location of your ArcGIS project file, so save this to the folder where you will store 
your work (for example, your desktop). 
 

a. Open ArcMap, create a new Blank Map. Go to File >Map 
Document Properties and put a check mark next to “Store 
relative pathnames to data sources”. This make sure that as 
you move between computers ArcGIS can find your files. 
Name the project file anything you want – am going to call it 
“week2”. 
 
 

 
 

 
 
 
 
b. Add the following shapefiles: 
week2/data/cambridge/cam_parcels_fy18_VER3.shp 
week2/data/cambridge/BOUNDARY_POLY.shp 
week2/data/cambridge/HYDRO25K_POLY.shp 
 
c. Add the following tabular Assessors dataset: 
week2/data/cambridge/cam_assessors_fy18.dbf 
 
Add data to the new ArcMap file 
 
Note: This parcel and assessor data is from the City of Cambridge GIS Website 
(http://www.cambridgema.gov/GIS/). I added the USE_GEN field to the cam_assessors_fy18 database 
based on values of USECODE to simplify the complex Massachusetts Land Use system. 
 
d. In the Table of Contents (TOC), arrange your files so that the hydrology layer is on top, followed by 
the parcels and city boundaries. Make sure you have your TOC set to ‘List by Drawing Order’ by clicking 
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on the first icon, from left to right . When you bring in tabular data, ArcGIS automatically switches 
to ‘List by Source’, and you will be unable to reorder your layers. 
 
At this point, none of your data is symbolized. All you should see are the unclassed polygons and 
unsymbolized data. 
 
2. Symbolize the Base Data 
 
Your map should look something like the following. If you don’t see what is below, you can right-click on 
the cam_parcels_fy18_VER3.shp file in the Table of Contents and click Zoom to Layer. 
 

 
Zoom to layer cam_parcels_fy18.shp 
 
Layer colors are selected by ArcMap randomly. Purple water and pink land (your colors may vary) will be 
highly unintuitive to our readers. We have to change the symbolization. Using the symbolization skills 
you learned in week 1, symbolize your base layers. Make the water blue and the land 
(BOUNDARY_POLY) a neutral grey or white fill with a thin, simple outline in dark grey or black. 
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Symbolize your base layers  
 
Label your Map. At this point our map has no labels to give us greater context. Right click on the 
BOUNDARY_POLY layer, which contains our town boundaries. In the Layer Properties, select the Labels 
tab, and label the layer’s features based on the field TOWN. 
 

 
Label the town boundaries based on the field TOWN. 
 
Your map will appear something like the following. 
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3. Join the Files 
 
We have gained familiarity with the data by using the lookup tables and created a map document with 
the data. Now the next step is to join the tax assessor database table to our geographic parcel file. Our 
shapefile and tabular data file each need to have a unique field (primary key) that can be used to link 
the files together. In spatial data, this unique ID will represent the same geographic area. We are using 
parcel data from the City of Cambridge. Each parcel has a fully unique ID assigned to it. This is the 
primary key we will use to join the tax database to the parcel file. The primary key can be found in our 
tabular data, connecting the tabular data to a specific parcel; and in our shapefile, uniquely identifying 
each parcel. Let’s begin. 
 
1. Right click on the parcel file (cam_parcels_fy18_VER3.shp) and open the attribute table. As we 
learned above, there is a field in our attribute table called ‘ML’; this is the unique identifier for each 
parcel in the City of Cambridge and we will use this field to join our tabular Tax Assessor file 
(cam_assessor_fy18.dbf) to the parcel file. 
 
2. Open the attribute table of the Tax Assessor data and look at it alongside the Parcel data. You will 
have to switch your TOC to ‘List by Source’. As we saw in the DBF file’s metadata, this file contains a 
‘GISID’ field which can be joined to the spatial parcel data’s ‘ML’ field. 
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Locate the key field 
 
3. Now that we have identified the unique keys, close the attribute tables, so that we can join the two 
tables together.  
 
4. To join both tables, right-click on the Parcels layer in your table of contents and select Joins and 
Relates -> Join… (Note: We are right-clicking on the shapefile layer that we want to join the data TO.) 
This will open up a Join Data dialog that will allow you to set parameters and options for the table join. 
In this dialog, select “Join attributes from a table”. Choose ‘ML’ as the field in this layer to join the table 
on. Choose cam_assessor_fy18 as the table to join to this layer. Choose ‘GISID’ as the field in the table 
to base the join on to the layer. Under Join Options, leave “Keep all records” selected. 

 
To see if the parameters you set are valid, and to check how 
many matches you have in your join, you can click “Validate 
Join.” Note: you will get a notice indicating that only 12,863 
out of 12,963 observations have matched. This happens 
because some parcels in the shapefile are not present in the 
assessor’s database. It’s fine for the purpose of this exercise.  
 
To complete the join, click OK. A window may popup asking 
if you want to index your data. Say yes. Your tables should 
now be joined. 
 
 
5. Make sure the join worked. Open the Parcel layer 
attribute table and scroll to the right. If our data was joined 
correctly, you will see all of the Tax Assessors data appended 
to the Parcel file fields.  
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5. To preserve our join, we can export a copy of the data to 
create a new Parcel file that contains the appended tabular 
data. To export the data, right-click on the Parcel layer in the 
table of contents and navigate to Data -> Export Data. 
Exporting data that is joined will combine all the joined files so 
this is a great way to make database joins permanent. When 
data is not permanently joined it can cause problems for 
keeping files organized.   
 
 
 
 
 

 
 
Make sure you are exporting the layer’s source data, to ensure you 
get all features, and then select your Week2 materials working space 
as the location to save your file. Save your file as a Shapefile. Name 
your file cam_parcels_fy18_lu.shp. 
 
Click Save. Click OK. 
 
When the new data file is created, add it to your map document. 
Place the new layer above the old one on which you performed the join, and toggle off the old layer. To 
make sure everything worked properly, view the attribute table of the new layer. 
 

  
 
 
By now, you should have a map 
that resembles the one on the left. 
 
 
 
 
 
 

 
 
 
 

Export a shapefile with the joined data 

    

Set the parameters and save 
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OBJECTIVE 3: MAKE A MAP USING CATEGORICAL DATA 
 
With the data joined, we can begin to 
visualize the land use layers for the city. As 
we have discussed at length, the land use 
data is included in our Tax Assessor’s data. 
We found while looking at the Data 
Dictionaries, that there are two fields 
containing information on Land Use, a 
detailed land use field called USECODE 
(created by the City of Cambridge), and a 
generalized land use field called USE_GEN 
(created by us based on PCC to simplify the 
task). We are going to use USE_GEN, and 
classify our map into five basic categories: 
Residential, Commercial, Industrial, 
Institutional, and Other. You can refer to 
these data dictionaries at any point you 
need to.  
 
Color schemes for land use maps have become loosely standardized over time, with many municipalities 
using similar colors to represent the various land use types. A guide above can help assign your colors 
(Source: http://www.hrtpo.org/uploads/images/broad.png). 
 
1. Open the Layer Properties of our 
joined Parcel layer and navigate to 
the Symbology tab. (Remember 
that you find the layer Properties 
by right-clicking in the Table of 
Contents and selecting Properties) 
We are using Categorical data this 
time instead of Quantities as we 
did last time with the census data. 
Select Categories with Unique 
Values in the left window of the 
dialog. Choose USE_GEN as our 
value field for the classification, 
and Add All Values to the window. 
See below for the number and land 
use code lookup table. 
 
 
 
 
 

Use USE_GEN as value field and Add All Values 

Land use categories and standard colors 
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Symbolize each category according to the land use codes by double clicking on the swatch next to the 
label. The Cambridge Land Use Codes, taken from the lookup table for this exercise, are as follows. 
 
    1 – Residential – yellow 
    3 – Commercial – red 
    4 – Industrial – purple 
    9 – Institutional – light blue 
    0 – Other – grey 
 
Deselect the check mark in the <all other values> box, and click on the Symbol column header to change 
the outlines for all of the symbols (Properties for All Symbols…) Right now, it is set as a dark grey line at 
0.4 point stroke. Change this to a 0.2 point white stroke. Click OK and apply all of our settings. 
 
You should have started to create a Land use map that looks something like the one below.  
 

 
 Symbolized land use map 
 
 
3. Zoom in and Create a More Detailed Map 
 
Make a more detailed map of the zoning just in the Central Square area. Zoom into the area around 
Central Square, which is just to the upper left of the MIT campus area along Massachusetts Avenue. 
 
1. Add the Open Space layer (\week2\data\cambridge\Cambridge_OpenSpace.shp). Change the 
symbology to be green to represent parks.   
 
Note: Many times, in zoning datasets, land owned by the public domain is considered institutional. For 
that reason parks will appear blue, because they have the institutional land use code but they are really 
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parks and we want them to appear that way on the map. Cambridge has developed a separate open 
space GIS layer so it is clear which institutional parcels are parks.  
  
2. Add the Street Centerlines (\week2\data\cambridge\Cambridge_StreetCenterlines.shp) 
 
Roads and streets are not parcels so they are often classified as “other” in the land use code. This is the 
case in Cambridge – we made these grey so they appear as grey streets on the land use map. Adding the 
street centerlines allows us to label the map.  
 

 
Add street centerlines 
 
3. Use the ArcMap labeling tools to label the streets in our Central Square area map. To complete this, 
turn on the Label window by going to Customize -> Toolbars -> Labeling. 
 

The ArcMap Labeling toolbar will appear. ArcMap has 
a ton of options for labels. We are going to use what 
is called the Maplex Label Engine. Click on the 
Labeling dropdown in the Labeling toolbar, and make 
sure there is a check next to Use Maplex Label 
Engine. If not, click Use Maplex Label Engine to turn 
on the labeling features. The check will show if 
enabled. 
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Turn on the label window 
 
Navigate to the Layer Properties of the Cambridge_StreetCenterlines.shp file and click on the Labels tab. 
In the Labels tab, set the Label Field to be Label. Click on Placement properties and, under General, use 
‘Street Placement’. Select ‘position’ and choose ‘Centered Straight.’ 

Set the placement properties parameters and click OK 
 
Click OK to apply your label settings. Right click on the Layer and 
make sure Label Features is turned on. Your map should update 
to include road labels. 
 
We can still see the street centerline however, and at this scale it 
does not make sense. Change the symbology of the street to have 
no stroke width and no color. This way, the street line will still be 
there, but it will be invisible. Doing this, we can retain our labels 
without having the feature visible on the map. Click on the 
Symbology tab in the Layer properties. In the Symbology tab, click 
on the Edit Symbol button. Set the color to be No Color, and the 
Width to be zero. Click OK.  
 
 
Click OK again and return to your map. The land use map for Central Square should now look like the 
following. 
 
 

  

  

Click on Edit Symbol 
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Updated symbology for land use map 
 

Hint for the take-home exercise: once you have 
automatically labeled your map using the ArcMap 
labeling tools, you can move labels yourself by 
converting them to ‘Annotation’. Right-click on the 
layer you want to label, select ‘Convert Labels to 
Annotation’. 
 
Store Annotation in the map, and create Annotation for 
Features in the current extent. Click Convert. 
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4. Create a Map Layout 
 
In Week 1, we showed the two main map views in ArcMap, ‘Data View’ and ‘Layout View’. To create our 
map layout and add a legend, we need to move from ‘Data View’ to ‘Layout View’, and set up the layout 
for our output map. 
 
1. Toggle your Map to Layout View 
 
Below your main map window, you see two small icons. The one on the left represents ‘Data View’ the 
one on the right represents ‘Layout View’. Click to move to Layout View.  Your map document window 
will change to a page layout. 
 
 

 
Click on ‘Layout View’ 
  
Depending on your starting template, your default view may be landscape or portrait. Make it 
landscape, by going to File> Page and Print Set-up and select Landscape.  
 
2. Add the Map Elements 
 
In Layout View, you can add all the elements you need to complete your map layout. This includes a 
north arrow, scale bar, title, source information, author, and legend, along with any other text you 
might want to use to supplement your map. To add these elements, use the ‘Insert Menu’ from the bar 
at the top of your screen.  
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a. Click North Arrow… to add a north arrow to your map. 
b. Click Scale Bar… to add a scale bar. In the Scale Bar dialog, click Properties... And set the scale 
bar units to Feet. 
c. Click Text to add a title to your map and add it to the layout. Name it ‘Land Use in the Vicinity 
of Central Square’ 
d. Click Text to add supplemental text such data sources, author, and date. 
e. Click Legend to add a Legend to your map, this will open the legend dialog, detailed in the 
following step. 

 
3. Create a Categorical Legend 
 
Creating a legend for Categorical data is a bit different than what we did in Week 1 with normalized 
quantities. When you click on Insert -> Legend, the Legend Wizard will open that will allow you to place 
the legend on your map and step you through the initial settings. The wizard looks like the following. 
 

 
                                      Declare layers to include in the legend 
 

Figure 28. Use the ‘Insert Menu’ to add map elements 
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In the first window of the wizard, declare which layers you want to include in your legend. The layers in 
your map are on the left, and the layers to be included in your legend are on the right. Include the layers 
that will properly communicate the map to your reader, in this case, the ones containing land use 
information. We should show open space (parks) and the land use parcel. There is no water in our 
current extent, so we can remove it from the Legend Items. Click through the defaults on the next 
screens, and add your legend to the map. Place it in your layout. Your map will look something like the 
following: 
 

 
Preliminary map elements (title, legend, north arrow, scale bar, sources, and author/date). 
 
Right now, our legend is a bit confusing. To style our legend, right click on the legend and go to the 
Legend Properties. Here we have the ability to fully style our legend. Look at the legend to see what we 
need to change. Note that the parks layer is called Cambridge_OpenSpace – this is the layer name. Leave 
this as is in the properties, and change the name of the layer to Open Space in the TOC. Similarly, open 
the properties of cam_parcels_fy18_lu and edit the labels for each value (e.g., change ‘1’ to ‘Residential’ 
by clicking on it). 
 
It’s a bit more complicated to change the name of the LandUse layer because we have it symbolized. We 
want to remove the layer name and the field name, currently shown, from the design of our legend. 
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To complete this, use the Style feature 
in the Legend Properties. To access, 
click on the ‘Items’ tab in the Legend 
Properties, highlight 
cam_parcels_fy18_lu, and click Style… 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Select target layer and click on Style. 
 
 
 
The Legend Item Selector will appear. Select the 
option that is called “Horizontal Single Symbol 
Label Only’. This will remove the layer name and 
field name from the legend. 
 
 
 
 
 
 
 
 
 
 
Click OK to return to the Legend Properties screen. Click on the General Tab, and uncheck Show in the 
Title section. This will remove the large LEGEND text from our map. Click OK to return to the map and 
save your changes. You will see the legend update.  
 
Note: the legend shows layer symbolization like we have in the land use layer according to the settings 
in the Symbolization tab in the Layer Properties. If you want to change the order of your land use types 
in the legend, move them around in the Symbolization tab in the Layer Properties. Modify the properties 

Select ‘Horizontal Single Symbol Label Only’. 
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until you are satisfied and have created a clean, efficient legend. Your map should look something like 
the following: 
 

 
Draft legend with updated layer name for open space. 
 
4. Add an Inset (Locator) Map 
 

As we did last week, add an inset (locator) 
map to our layout. In the layout in the large 
open space below the legend, add an inset 
map to give our map some greater context. 
To do this, add a new data frame by 
navigating to Insert -> Data Frame. 
 
 
 
 

Insert a new Data Frame 
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A new data frame will appear on your layout. 
 

 
Locate the new data frame below the legend 
 
In the Table of Contents, rename the data frame ‘Inset’. 
 
To get data in the Inset, click on Add Data. From the Data/Cambridge folder, add Cambridge_CityLimit, 
HYDRO25K_POLY. From the Data/Boston folder, add EOTMAJROADS_RTE_MAJOR, and 
BOUNDARY_POLY. Organize and symbolize them. 
 

 
          Add layers to the new data frame 
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Your map should look like the following. 

 
Figure 38. Updated layout with locator map. 
 
There are two more steps to complete our locator map, add an extent box showing the extent of the 
main map, and a couple supplemental labels. 
 

To add the main map extent to the locator, right click on the Inset 
data frame to access data frame properties. Click on the Extent 
Indicators tab, and show the ‘Main’ tab. Click OK.  
 
 
 
 
 
 
 
 
 
 
 
 

Add the main extent through the Extent Indicators tab in locator map’s data frame properties 
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To add some supplemental text, go to Insert -> Text, like we did earlier, and drop in a label that says 
Cambridge. The map will look something like the following. 
 

 
Updated layout with locator map extent and label. 
 
For the first part of the take home exercise, The Bronx River Alliance wants a land use map of the Bronx 
to learn more about land uses near and in the river watershed. Use the techniques and principles of this 
in class exercise to work on a land use map of the Bronx. 
 
Save your map document as ‘week2_inclass_landuse.mxd’ to refer to moving forward. 
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OBJECTIVE 4: QUERY TO EXTRACT A SPECIFIC SUBSET OF DATA 
 
In lab so far, we have created a land use map of Cambridge. What if, for example, we wanted to dig 
further and only see the parcels that have one specific type of land use, such as Parking Lots. To 
complete this next objective, we are going to extract information from our parcel dataset using query 
tools to create a new dataset. Our map to this point is of all land use in Cambridge, specifically near 
Central Square, and we are going to make a map that shows all the parking lot parcels near Central 
Square. An important note, because we are using Assessors data, we are likely NOT going to get City-
Owned lots on the map as those aren’t taxed. Some supplemental work would need to be done to 
identify these. 
 
Make a Map of Privately-Owned Parking Lots near Central Square 
 
1. Create a copy of your map document. Open ‘week2_inclass_landuse.mxd’ (if not still open) and go to 
File -> Save As… Save the file as ‘week2_inclass_query.mxd’. 
 
2. Get ready to query in GIS. A query is a selection of a subset of data based on whether or not that data 
meets specific criteria. To run a query in ArcMap, we need to know two items: 1) what layer we 
perform the query on, and 2) what to query out of the attribute table. In this circumstance, we want to 
find parcels that contain privately owned parking lots (city owned lots are marked a city owned 
property), so we will query our parcel layer, and then we need to determine which value in the land use 
field is the value that represents privately owned parking lots. To do this, we are going to use the 
detailed land use code (PCC) instead of the generalized code. 
 
The lookup table for this is the State_Use_Codes.xls file. Open this file using Excel and locate ‘Parking 
Lot’. Note the value in the Use Code column that represents Parking Lots. 
 

 
Locate ‘Parking Lot’ and note its Use Code. 
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In the lookup table, we see that a value of 337 
represents a parcel occupied by a parking lot.  
 
3. Run the query in ArcMap, noting that 
the Use Code variable is called PCC. We are 
going to use the ‘Select by Attributes’ feature 
in ArcMap. At the top of our ArcMap screen, 
find the Selection menu, in the dropdown, 
choose ‘Select by Attributes’. A query dialog 
for Select by Attributes will appear.  

 
 
4. In the Select by Attributes dialog, set the Layer to be 
cam_parcels_fy18_lu, and make sure the Method is set to Create a 
New Selection. Below, you see all the names of the fields in our Parcel 
shapefile. Double click PCC in this dropdown. This will start to 
populate the bottom window of the dialog with the criteria for our 
selection. Remember, we want to select all parcels where “PCC” is 
equal to 337. 
 
Click on the bottom window, type an = (equal to) sign next to “PCC”, 
and type 337 after the equal sign. This is a basic SQL query. Once it 
looks good, hit apply. This will select all parcels where “PCC” is equal 
to 337, or in other words, where the parcel code corresponds with 
Parking Lot. 
 
 
 
 

 
 
Hint: In your homework, you will be working with strings (text) so you will need single quotes on your 
query criteria. For example, instead of “PCC” = 337 (numeric), you’ll need to set your query to “PCC” = 
‘337’ 
 
Click OK, your screen should now look like this, with privately-owned Parking Lots selected. 
 

From the Selection menu, click on ‘Select by Attributes’ 

Use the phrase “PCC” = 337 to set your query 
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5. Now that we have the parking lot parcels selected, we can create a new dataset that consists of only 
the parking lot parcels. Similar to how we joined data and then exported it previously, in the Table of 
Contents, right click on the cam_parcels_fy18 layer (from which we made the current selection), select 
Data -> Export Data. Make sure you have Selected Features as the export option, and are exporting the 
source data. Name the file cam_parkingLots_fy18.shp, and save it as a shapefile in your working 
directory. Your export window should look as follows. 
 

 
Set the parameters and export as a new shapefile (SHP). 

 

Query results are displayed graphically in light blue. 
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Click OK. Add the new layer to the map. 
 
6. Clear your selection by going to Selection -> Clear Selected Features. 
 
7. Change the Symbolization. We have a separate layer with privately owned parking lots now in our 
map. We want to highlight the parking lots. Change the symbolization so that parking lots are a bold 
color, and change the symbolization of the land use layer to a neutral color (white or no fill), still 
showing the parcel outlines for context. After changing symbolization, your map should look like the 
following: 
 

 
Parking lots symbolized in bold color. 

 
8. Change the map layout so that the title, legend, and other map components are correct. Give it a title 
‘Privately Owned Parking Lots in the Vicinity of Central Square’ and then change the legend labels to 
accurately represent what the map is showing. Your parking lot map should look like the following. Save 
your document. 
 

28



 
Updated parking lots title, legend, etc. 

 
Querying and selecting are powerful and commonly used tools in the GIS software. Try this again, and 
query a different variable. For example, you could select all parcels that have “PropertyCl” = “>8-UNIT-
APT’, which would get you all the parcels that hold apartment buildings with more than eight units, or 
you could do “LandValue” < 200000 AND “LandValue” > 0 to get you all parcels with land values less 
than $200,000 (an endangered species). You will do something similar to this in your homework. 
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OBJECTIVE 5: NEW FIELDS AND BASIC SUMMARY STATISTICS 

 
In the final objective for this exercise, we are going to create a derived field and calculate some basic 
summary statistics. In the cam_parcel_fy18_lu.shp file that we have been working with, we are going to 
add a field that will contain the value of the land in dollars per square foot. 
 
SUMMARY STATISTICS 
 
1. Open up the Attribute Table for cam_parcel_fy18_lu. This is the table to which we are going to add 
the new derived column. 
 
2. In the Table Options dropdown at 
the upper left of the Attribute Table, 
select Add Field…  This will add a 
field to our table.  In the dialog that 
appears, name the field VAL_SQFT, 
give it the type Double, and accept 
the defaults for Precision and Scale. 
Hit OK. 
 
You have just added a field to your 
table.  
 
Important Note: Perform these sorts of table modifications on copies of your data, or on derived 
datasets, such as our LandUse file we created. Never do this on original data or shared datasets that 
might compromise the integrity of the original data. Once you perform a field calculation it cannot be 
undone.  
 
3. Before calculating the values of the new field, we want to make sure that there are no land areas that 
have a value of zero. We are going to be dividing land value by land area, and if there is a value of zero in 
the denominator, our field calculation will stop and not fully complete filling out the field – because you 
cannot divide by zero.  Create a query (by choosing “Select By Attribute” in the above menu) that will 
select all rows where 
LandArea is greater than 0 
(“LandArea” > 0). You will 
see the selected rows 
highlighted in light blue.  
While in theory there 
should be no parcels with 
zero area, many cities code 
condominiums, 
apartments, and suites 
with this value as they are 
within a building and 
already counted 
elsewhere. Zeros might 
also exist in error.  

Add a field and give it the type Double. 

Select all parcels with LANDAREA > 0. 
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4. Right click on the header 
of your new column. We 
are going to use the Field 
Calculator to write a 
formula to populate our 
new VAL_SQFT field for the 
selected rows. Select Field 
Calculator. 
 
Click OK to perform the 
calculation outside of an 
editing session. 
 

 
 
 
 
4. In the field calculator, we write our formula. Divide LandValue 
by LandArea – we want to populate the field with the quotient. 
You can select the fields by double clicking on them in the Fields 
window of the dialog. 
 
 VAL_SQFT = [LandValue] / [LandArea] 
 
Click OK, our field will begin to populate with value of the 
formula we specified in our Field Calculator. 
 
 
5. Clear your selection using Table Options -> Clear Selection. 
 
 
6. Right click on our newly calculated VAL_SQFT field and select 
Statistics. This will give a quick look at the summary statistics 
for our field. You can view the count, minimum, maximum, and  
mean, among other statistics, for the field. 
 

 
 
 
 
 
 
 
 
 
 

    
      

 

Click on the header then on Field Calculator 
 

Use the formula VAL_SQFT = [LANDVALUE] / 
[LANDAREA] 
 

Right click to open the Statistics to review a quantitative summary of the data. 
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OBJECTIVE 6: GROUPING 
 
We have seen some basic summary stats, now we are going to try 
grouping. We want to take a look at our cam_parcels_fy18_lu.shp file 
and determine how many parcels are classified as each type. For 
example, how many parcels are classified as Residential? To do this, 
we use grouping. 
 
1. Open up the Attribute Table again for cam_parcels_fy18_lu. Right 
click on USE_GEN, which contains our generalized land use codes. 
Select Summarize.  
 
 

 
 
 
 
 
 
 
 

2. Summarize will group our data. We want to group based on the value in USE_GEN. In the Choose one 
or more summary statistics section of the dialog window, navigate to LandArea and check Sum. This will 
include the sum of land area in our output table. In the Output Table window, name the 
LandUse_Summary, and make sure you save it as type ‘dBase Table’. Save this file to your week’s 
workspace. 
 
 

 
 
 
 
 
 
 
 
 
 
 
Click OK to run. Add your results to your map 
document when complete. 
 
 

From the Attribute Table right 
click on the USE_GEN field and 
select Summarize. 
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4. Open up your resulting table we just named
LandUse_Summary. In here you will see a
summary of
the parcel land uses and their area for the City of

Cambridge.

What does this summary tell us? 

In this in-class exercise, we performed some joins, queries, and basic calculations. You will use these 
principles in your take home exercise. 

Review the result of the field calculations under Sum_LANDAREA. 
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