
11.205 – Intro to Spatial Analysis – Fall 2019 
QGIS Exercise 

Week 6 – Raster Data and Decision Support Analysis: Objectives 

OBJECTIVES 

1. Load Raster Toolbar and Raster Processing Menu
2. Conceptual Workflow Mapping
3. Introduce Decision Support Layers
4. Perform Decision Support Analysis

In lecture this week, we discussed raster data, including some of the methods to work with it, and 
suitability analysis. In lab this week, we are going to get some hands-on experience working with raster 
data and perform a site selection suitability analysis. 

The Bronx River Alliance is interested in creating an environmental education center near both a school 
and the Bronx River Greenway. They reason that such a location is appropriate because visitors would 
have easy access to the Greenway as a learning environment and would be able to work closely with the 
school. The Alliance wants to identify existing vacant lots on which to site the proposed center. The 
organization will then research each one to determine the possibility of purchase, acquisition, and site 
suitability. We will start by helping them narrow down the possible sites.  

Note: Some of the QGIS features in this exercise are unstable, make sure you save your file frequently. 

OBJECTIVE 1. LOAD RASTER TOOLBAR AND RASTER PROCESSING MENU 

In this lab, we will be using a combination of raster processing tools to complete our suitability analysis. 
Recall that ‘raster’ data are spatial data that store attributes in a regular grid of pixels, or cells.   

1. Open a blank QGIS project.

2. You can open the Raster toolbar on your computer by going to View > Toolbars > Raster Toolbar. It
has the following buttons. You can also explore these tools under the Raster dropdown menu.
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OBJECTIVE 2: CARTOGRAPHIC MODELING 
 
When running multistep GIS analysis, it is helpful to conceptually map out your workflow; in GIS, we call 
this ‘cartographic modeling’. Mapping the workflow step-by-step helps to determine which 
geoprocessing tools to use, to critically evaluate the steps involved, and to create robust documentation 
of our analysis. One method is to create a detailed workflow chart. We have already created the 
conceptual model that details the workflow for today’s lab (see image below). Our goal today is to 
follow this cartographic model of a site selection analysis.  
 

 
 
This cartographic model shows the following: 

• Blue ovals are the input layers. These are layers we start with that are the base components of 
our analysis. Input layers for this process will be vacant lots, the location of the greenway, and 
locations of educational facilities (schools). 
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• Yellow boxes are the tools and processes. As shown above, we will be calculating distances, 
converting files, reclassifying our data, and performing a range of geoprocessing tasks. These 
tasks are specifically detailed in the yellow boxes. 

• Green ovals represent our output files from each step. These output files contain temporary 
files that are intermediary to the process, and decision support files that contain the criteria on 
which we are basing our site selection analysis. Note, for example, the decision map created by 
overlaying the educational facilities buffers and the greenway buffers. This is an important file 
that contains raster cells with the values indicating suitability. 

 
Cartographic modeling is a form of concept mapping that is important when scoping out GIS work. You 
can reference this workflow map throughout the rest of the lab. 
 
 
OBJECTIVE 3: CREATE DECISION SUPPORT LAYERS 
 
To begin our analysis, we need to create layers that allow us to make decisions based on spatial criteria. 
These layers are referred to as decision support layers because they represent the criteria that will be 
used to make our decisions.  
 
1. Create the ‘Distance from Greenway’ Decision Support Layer 
 
An expert informed us that 0.5 kilometers is the maximum distance greenway visitors are likely to walk 
to visit an environmental education center. Given this information, we will only consider locations within 
0.5 kilometers of the greenway for our site. The expert also told us that the closer to the site the better. 
With this knowledge, we can create the decision support layer that represents this.  
 

 
 
 
 

a. Preliminary Work 
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To begin, we are going to define the geography for our analysis, set up some processing options, and 
create a bookmark. 
 
1. Add data. Add the bx_river_greenway.shp and the edu_facilities.shp layer to your map. Click the 
‘Zoom Full’ button in the top toolbar (a magnifying glass with three arrows), or use the Shift – Cmd – F 
hotkey (or Shift-Ctl-F on Windows). Like the image below, you should be able to see the full extent of 
both layers in your screen.  
 

 
 
2. Now, let’s create a bookmark that we can use as a placeholder to return to this map extent. Click on 
View > New Bookmark. The Spatial Bookmarks Panel will appear on the side of your screen. Name the 
bookmark ‘GreenwayEdu’.  
 
3. We will make sure we do all of our processing from this bookmark. In the bookmark panel, note the 
values of xMin, yMin, xMax, and yMax. Mine were  992040,  223542,  1060508, and  302340, 
respectively. Note that these values may vary slightly depending on your zoom extent. We’ll use these 
when we rasterize our vector layers. 
 
b. Processing 
 
Now we are ready to begin the processing of data that we want to perform in QGIS. 
 
1. We will use the Proximity (Raster Distance) tool in order to create gridded representations of distance 
from features of interest. Then, we will use the Raster Calculator to calculate the average distance from 
each criterion. However, we first need to convert our vector representations into gridded raster 
representations. 
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Navigate to Raster > Conversion > Rasterize 
(Vector to Raster).  
 
 
 
 
 
 
In the dialog, select the following: 
 

a) Input Layer: bx_river_greenway 
b) A fixed value to burn: 1 

a. This says, ‘where there is a feature, the value should be 1’. 
c) Output raster size units: Georeferenced units. 

a. This says that the raster layer’s grid resolution should be measured in the 
units of the map (in our case, feet). 

d) Width/horizontal resolution: 10 
e) Height/vertical resolution: 10 

a. Both the above say ‘make a grid in which each cell is 10 feet wide’. 
f) Output extent: Click the ‘…’ button and select ‘Use Canvas Extent’ 

a. Make sure you’ve zoomed to your bookmark! You can also manually input 
the xMin, yMin, etc values of your bookmark… but that sounds tedious. 

g) Rasterized: save the file as bx_river_greenway_raster.tif in your project folder. 
h) Uncheck the ‘Open output file after running algorithm’ 
i) Click ‘Run’ and then Close.  
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2. Add your newly created raster layer to the project. You should now have a raster file of the Bronx 
River in your layers that looks like the image below. 
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3. Now we will create a thematic map based on 
proximity between each pixel. Navigate to Raster > 
Analysis > Proximity (Raster Distance).  
 
This is a raster output tool that gives each raster cell 
a unique distance value based on the distance from 
a source feature. 
 
In the Proximity dialog, use the following 
parameters: 
 
a)   Input layer: The ‘bx_river_greenway_raster’ 
layer. (Note: it may be called ‘Rasterized’ if you automatically added it to your project file.) 
b) Band number: Band 1 (Gray) 
c) A list of pixel values…:  1 is the pixel value in the source image to be considered target pixels. 
d) Distance Units: Georeferenced Units 
e) The maximum distance…: 1640 in georeferenced coordinates (approximately 0.5 kilometers in feet). 

The unit of measurement is feet because our layer is in a State Plane projection that uses feet. 
f) Nodata value…:  Use -1 as the nodata value. We do this to replace values beyond 1640 with a 

recognizable value (-1) to excluded from layer symbolization in the following steps. 
g) Name the proximity map (output file) ‘greenway_raster_dist.tif’ and save it in your project folder. 
h) Uncheck the ‘Open output file after running algorithm’ 
i) Click ‘Run’ and then Close. 
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Your dialog box, when ready, should look like the following. 

 
 

 
4. Add the raster file greenway_raster_dist.tif to your map. Change the symbology color gradient from 
‘White to Black’ by right-clicking on your new distance layer and going to Properties > Symbology (see 
image below).  
 

8



 
 
You should see something like the image below. 
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This tool creates a raster file with each cell is given a value according to its distance from the greenway. 
Because we set a maximum distance, areas that are more than 1640 feet away from the greenway are 
not considered. 
 
5. We ultimately want to reclassify the data so that each 100 meters (or roughly 328 feet) is coded with 
a different suitability level. Areas that are closest to the greenway will have the highest suitability 
values, areas that are farthest away from the greenway will have the lowest suitability values.  
 
Let’s begin by visualizing this. Open the layer properties dialog for the ‘greenway_raster_dist’ layer 
(note that this layer might be called ‘Proximity map’ if you automatically added the result of the 
geoprocessing operation). Go to the Symbology tab and change the Render Type to ‘Singleband 
pseudocolor.’ Make sure the min and max values are 0 and 1640, respectively. Change the color 
interpolation to ‘Discrete’ in order to only show up to the max value of 1640. Choose the Spectral color 
ramp. 
 
Change the max value in the color range to 1640 and have 5 equal interval classes. This will give us 
intervals every 328 feet. (1640 feet/5 classes).  
 

 
 
 
When you click ‘OK’, your map should look like the following: 
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To see the value of each pixel, click on locations covered by the raster using the information tool . In 
the ‘Identify Results’ panel, change the ‘View’ to ‘Table’. The ‘Value’ field represents a unique distance 
value. If you zoom in closely you will notice the pixelated nature of the output.  
 
Note that both the center of the buffer and the area outside it have the same color (in my case, they are 
both red). Click on these two areas using the information tool. You will notice that the outside has a 
value of -1 (which is the value we assigned to areas located beyond our 1640 cut-off) and the center has 
a value of 0.  
 
Let’s visualize these differences in values further! Open the Symbology tab again, and manually add a 
color category using the ‘+’ button. Make the color transparent by adjusting the color opacity and 
replace the value with -1. Click Ok.  
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Your map should now look like the image below.  

 
 
 
6. Reclassify your data.  We want to reclassify our raster data to assign high values for the areas closer to 
the greenway, and low values for areas farther away from the greenway.  
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Go to View > Panels > Processing Toolbox. Then, search “Reclassify” and select the QGIS Reclassify by 
Table tool from the Raster Analysis toolset. 
 

 
 
Select the greenway_raster_dist as the Raster Layer. Create a new reclassification table. Add 5 rows, 
then enter these values: 
 

Minimum Maximum Value 
0 328 5 
328 656 4 
656 984 3 
984 1312 2 
1312 1641 1 

 
We use 1641, rather than 1640 to ensure that the top end of our distance range is included.  
 
Under “Advanced Parameters” … 
 

• Your Output no data value should be 0. 
• Your Range boundaries should be min <= value < max. 

Make sure that ‘Use no data when no range matches value’ is checked – this ensures that the -1 
values outside of our proximity analysis result are classified as 0. 

Save the file as greenway_raster_reclass.tif and uncheck the ‘open output file after running algorithm’. 
The window should look like the following: 
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7. Add the raster layer to your map. You will need to redo the symbology. To visualize the raster with a 
single color for each raster value, open layer properties and set your style as follows. Remember to 
symbolize 0 using a transparent symbol. 
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Your output should look similar to the following:  

 
 
To recap, we used the Proximity tool and the Reclassify by table tool to create a suitability layer for the 
proximity to the greenway. According solely to the criteria of distance, high values, those with value ‘5’, 
have high suitability, while low values, those with value ‘1’, have low suitability. This is our Decision 
Support Layer for the greenway. 
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2. Create the ‘Distance from Educational Facilities’ Decision Support Layer 
 
We now need to create the Decision Support Layer for proximity to Education Facilities. One of the 
criteria laid out by the Bronx River Alliance is proximity to schools, and we need to create another 
decision support layer containing this suitability information. We will follow a very similar workflow as 
we did for the greenway proximity layer. 

 
 

1. Navigate to Raster > Conversion > Rasterize. Remember that you need to make sure you’ve zoomed 
to the bookmark that you’ve created. This is exactly the same process we followed earlier!  In the 
rasterize dialog, select the following: 
 

a) Input Layer: edu_facilities 
b) A fixed value to burn: 1 

a. This says ‘where there is a feature, the value should be 1’. 
c) Output raster size units: Georeferenced units. 

a. This says that the raster layer’s grid resolution should be measured in the 
units of the map (in our case, feet). 

d) Width/horizontal resolution: 10 
e) Height/vertical resolution: 10 

a. Both the above say ‘make a grid in which each cell is 10 feet wide’. 
f) Output extent: Click the ‘…’ button and select ‘Use Canvas Extent’ 

a. Make sure you’ve zoomed to your bookmark!  
j) Rasterized: save the file as edu_facilities_raster.tif in your project folder. 
k) Uncheck the ‘Open output file after running algorithm’ 
l) Click ‘Run’ and then Close.  

 

16



 
 

 
2. Add the edu_facilities_raster layer to your project and move it on top of your Bronx Greenway layers 
– if you have not set your transparent colors in your layer symbology, you may not be able to see the 
educational facilities! You should see something like the image below: 
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3. Now we will create a thematic map based on proximity between each pixel. Navigate to Raster > 
Analysis > Proximity (Raster Distance). 
 

a) Input layer: The ‘edu_facilities_raster’ layer. 
b) Band number: Band 1 (Gray) 
c) A list of pixel values…:  1 is the pixel value in the source image to be considered target pixels.  
d) Distance Units: Georeferenced Units 
e) The maximum distance…: 1640 in georeferenced coordinates (approximately 0.5 kilometers in 

feet). The unit of measurement is feet because our layer is in a State Plane projection that uses 
feet. 

f) Nodata value...:  Use -1 as the nodata value. We do this to replace values beyond 1640 with a 
recognizable value to excluded from layer symbolization in the following steps. 

g) Name the proximity map (output file) ‘education_raster_dist.tif’’ and save it in your project 
folder. 

h) Uncheck the ‘Open output file after running algorithm’ 
i) Click ‘Run’ and then Close. 

4. Add the newly created raster layer to your project. Go into the layer properties and Style the layer to 
classify the output into 5 categories, plus a transparent category for -1 (as shown below). 
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Once you style the layer, the output for the Proximity tool should look like the following. 
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5. Again, we want to reclassify the data so that each 100 meters (or roughly 328 feet) has a different 
suitability value. Areas closer to educational facilities will have higher suitability values, and areas 
farther will have lower suitability values. We will use the Reclassify by table tool again. 
 
Select the education_raster_dist as the Raster Layer. 

 
Create a new reclassification table. Add 5 rows, then enter these values: 
 

Minimum Maximum Value 
0 328 5 
328 656 4 
656 984 3 
984 1312 2 
1312 1641 1 

 
We use 1641, rather than 1640 to ensure that the top end of our distance range is included.  
 
Under “Advanced Parameters” … 
 

• Your Output no data value should be 0. 
• Your Range boundaries should be min <= value < max. 

Make sure that ‘Use no data when no range matches value’ is checked – this ensures that the -1 
values outside of our proximity analysis result are classified as 0. 
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Save the file as education_raster_reclass.tif and uncheck the ‘open output file after running algorithm’. 
Add the newly created raster to your project. Your window should look like the following: 
 

 
 
This is our second decision layer, the one outlining suitability according to proximity to educational 
facilities. 
 
 
3. Use ‘Map Algebra’ to Combine our Decision Layers 
 
We have created two decision layers that hold the proximity criteria. We can now add these two layers 
together to locate the areas that best meet both of the proximity criteria. We do this by using ‘Map 
Algebra.’ The cells in the resulting output that have the highest values will represent the cells that had 
the highest combined values in each decision layer. These high value cells represent the areas that are 
close to both the greenway and to an educational facility, and therefore, by our criteria, the ‘most 
suitable’. 
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1. Use Map Algebra and provide weights for the decision layers 
 
We are going to use the Raster Calculator tool found in the Raster dropdown menu. One of the features 
of this tool is to give weights to each input layer. The Bronx River Alliance believes it is more important 
for the new environmental education center to be close to a school than it is for it to be close to the 
greenway. This position is supported by their belief that schools would be more likely to take ownership 
of an environmental education facility that is closer to its property. If the education center is too far 
away from any school, they are worried that no single school will take ownership and, therefore, that 
the education center will not be used regularly. Given this assumption, they would like you to give extra 
consideration to those areas that are proximate to schools. In the Raster -> Raster Calculator tool, we 
will grant a higher weight to proximity to schools. 
 
Navigate to Raster -> Raster Calculator. The Raster Calculator dialog will appear. In the dialog, specify that 
we want to perform the calculation below by double clicking the layers and typing in the expression.  
 

 
 
Note that the 0.6 represents that we want the educational facilities to be weighted more heavily than the 
greenway, which we gave a value of 0.4. The values add up to 100%.  
 
Name the output file ‘decision’ and ensure that your Output CRS is EPSG: 2263. 
The dialog should look like below. Click OK. This may take a while, so lean back and take a stretch break! 
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2. The ‘decision’ layer now in your map contains areas that are most desirable according to our 
proximity criteria. Use the information tool to click on the map to see the values of each pixel. High 
values have higher suitability.  
 
3. Go to the style tab to visualize the data. Your Decision layer should look like below: 
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4. Add the ‘vacant_land.shp’ to the map document. Place it on top of the ‘decision’ layer. Notice there 
are a number of areas where vacant land overlaps areas that have been given high decision criteria 
according to our ‘decision’ layer. 
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4. Use Zonal Statistics to Associate Decision Values with Each Vacant Land Parcel 
 
In our map document, we need to combine our ‘decision’ layer with the vacant land layer in order to 
determine which vacant land parcels should be pursued for the location of the new environmental 
education center. To do this, we will use a tool called Zonal Statistics. Zonal Statistics will calculate an 
average suitability score for each vacant parcel based on the cells that lie underneath each vacant 
parcel. 
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Let’s use Zonal Statistics to figure out which vacant parcels have the highest decision values.  
 
 

 
1. Zoom to the Spatial Extent bookmark. Open the Zonal Statistics tool: Processing > ToolBox > Search 
for Zonal Statistics > Zonal Statistics. If this doesn’t appear you may have to load or install the Zonal 
statistics plugin using the ‘Manage and Install Plugins…’ feature. In the dialog, select the following: 
 

a) Decision is your raster layer.  
b) vacant_land.shp Is your vector layer containing zones.  
c) In Statistics to calculate, select ‘mean’ and click OK.  
d) Click Run 
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The resulting output will be a column called ‘_mean’ in the attribute table for vacant_land. This column 
contains the mean value of the decision layer cells.  

 
2. Let’s explore this column further. Open up the attribute table for ‘vacant_land’ and scroll to the right 
to see the appended fields. _mean contains our suitability value. Note: Many parcels will have null 
values. This is because they do not intersect with the decision layer. 
 

 
 
5. Select all Vacant Parcels with a Mean Greater Than or Equal To 4.5 and Export a New 
Shapefile 
 
The next step of our process is to select only the most suitable vacant parcels and export a shapefile. 
This is performed by running a simple query and then exporting the selected parcels. 
 
1. Using ‘Select by Expression’ in the ‘vacant_land’ attribute table, select all parcels that have a mean 
value greater than or equal to 4.5 (see image below). Click the ‘Select Features’ button, and then close. 
The dialog will look like the following. 
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2. Right-click on the ‘vacant_land’ layer in the Layers Panel. In this layer, all the parcels with greater 
than 4.5 suitability are currently selected. Go to Export and Click ‘Save Selected Features As.’  Save the 
layer in your weekly workspace with the name ‘decision_above_45’. Add it to your map document. This 
layer contains the sites that best met the criteria according to this analysis. It will look something like the 
following. 
 

 
 
 

6. Add Aerial Imagery and Investigate Each Location 
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The final step in our process is to add aerial imagery and investigate each location. 

1. Add aerial imagery. To do this, go to “View” > “Panels” > “Browser”.  A panel will open in the left-hand
column. Right click on “XYZ Tiles” and then select “New Connection”. Name the connection “Google
Satellite” and then http://www.google.com/maps/vt?lyrs=s@189&gl=cn&x={x}&y={y}&z={z} for the
URL. Click OK. Right click the new connection in the browser panel and select “Add layer to project”

2. Zoom in and investigate each site. You may want to add the educational facilities layer to investigate
what is near the vacant sites.

Take Home Exercise 3 asks you to continue this site investigation process. You will need the products 
created in lab today to complete Exercise 3. 
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