
11.205 – Intro to Spatial Analysis – Fall 2019 
Week 1 – Map Composition and Design 

[OCW Users: The following document refers to various online resources (Stellar and Athena) that are not 
available to users outside MIT.] 

Week 1 Objectives 

I. Gain familiarity with the QGIS interface and add data to a map
II. Symbolize your Map

i. Explore Normalization
ii. Symbolize a Census Variable

III. Compose and layout a map

Lab Data 

Download the class files from Stellar. 

Please copy the files to your external hard drive. If you don’t have an external hard drive you should get 
one as soon as possible. In the meantime, you can download the files to your local machine.  

Specifically… 

On Windows… 

…your C:\temp directory, on the Windows side. Remember from last week that this directory gets 
erased quite frequently and you should not leave files on c:\temp when you leave class. Please save a 
copy to your external hard drive or other place were you can get it again.  

On Mac… 

…download files to your ~/Desktop or ~/Documents folder. While these are generally understood to be 
‘safe’ places (they’re not wiped!), using them as storage media in the long term will gradually eat into 
your rather limited 8GB of storage space on Athena. 

Unzip the materials you just downloaded from Stellar. The unzipped file consists of the following folders: 

1. DOCUMENTS:
This folder includes Word documents for this week’s in-class exercise(s) and take-home 
Exercise.  

2. PROJECTS:
This folder contains map document(s) for the in-class exercise, if any. 

3. DATA:
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This folder contains all the shape files needed for this week’s in-class exercise and the 
Exercise 1. 

 
 
 
 
OBJECTIVE 1: GAIN FAMILIARITY WITH THE QGIS INTERFACE AND ADD DATA 
 
QGIS, a free and open source Desktop GIS software, is a convenient tool for spatial analysis. However, 
just like ArcGIS, the interface at first can be intimidating. Comfort with the interface will come over time, 
but one key thing to remember is as a general rule of thumb, like items and tools are grouped together. 
Open up QGIS Desktop, start a new project, and explore the interface. QGIS works on both Mac and 
Windows. Use whichever you are working on. The interfaces are very similar. However you might 
encounter some small differences here and there. Don’t let this hinder you though, let’s get going! 
 
 
 
STEP 1. OPEN A MAP DOCUMENT 
 

1. Open QGIS by navigating to Finder>Applications>QGIS Desktop (Mac Users) or open QGIS by 
navigating to Start>Programs>QGIS>QGIS Desktop 3.4 (Windows Users) 

2. The QGIS interface will appear. Open the map that is located in our Week 1 Materials.  
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3. Navigate to \week1\projects\ and select the map document named week1.qgz Click open. The 
document will open and QGIS will draw a series of data layers from the data files the map 
document is referencing. Your screen should look something like the image below. 
 

 

  
 

4. Map documents (.qgz) hold basic information about a map’s 
composition. It is similar in nature to an Adobe InDesign project file, 
where the map is essentially a saved view of data files stored 
separately. The map document contains information about the 
various data files used in the map, manages files, allows for analysis 
through Processing Toolbox, and symbolizes and lays out maps. The 
interface may be overwhelming at first, but like items and tools are 
grouped together. The interface is also highly customizable - you can 
move around and organize your toolbars to your personal preference 
and to optimize your workflows. 
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STEP 2. LAYERS 
 
To the left side of the QGIS Project screen, you should see the Layers Panel. The Layers Panel is where 
you can see what data is linked to your QGIS project, how they are symbolized, and the order the layers 
appear in your composition. Through the Layer Panels, you can turn layers on and off, adjust 
transparency, symbolize features, and modify datasets. You can also use the Layers Panel to examine 
the source of layers in your map and set up selectable layers. Let’s turn layers on and off by selecting the 
check box next to the layers in your Layers Panel. Notice what happens when you toggle the layers. 
Notice at the top of the Layers Panel there are eight buttons. Each one of these buttons lets you view 
the content of your map through different information. The buttons are: 
 

 
 

• Layer Styling  
• Add Group 
• Manage Map Themes 
• Filter Legend by map Content 
• Edit Filter Expression 
• Expand all 
• Collapse all 
• Remove Layer/group 

 
The Layer Styling Button allows you to access the symbology for a layer. 
 
The Add Group button allows creating folders to group a set of layers. 
 
The Manage Layer Visibility button allows you to turn on an off all the layers at the same time. It also 
allows you the same only to the selected layer.  
 
The Filter Legend by map Content button allows you to filter the legends. 
 
The Edit Filter Expression allows you to filter features on the selected layer. 
 
The Expand and Collapse buttons allow you to see all the details of a layer or to hide them.   

 
The Remove Layer/group button allows you to delete the selected layer or the selected group of layers. 
 
STEP 3. ADD DATA TO YOUR PROJECT 
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Next, we want to add data to our project. Adding data will create a new layer in our Layers Panel. This 
layer references a data file we specify. In our week’s materials, there is another shapefile that contains 
data on the employment level of residents over the age of 16 by block group. This data was also taken 
from the American Community Survey 2012-2016. 
Adding Data 
 
QGIS give you a few options for adding data. 

1. Open the Data Source Manager. You can do this by clicking the “Open Data Source Manager” 
button -  - or by using the cmd-L hotkey. You can also use the Layer dropdown menu, and 
select Add Layer > Add Vector Layer.   
Either way, navigate to your Week 1 materials. Select ./data/Boston_employment_2016.shp and 
click Open.  

2. Another method to add data is use the QGIS Browser. This is probably more efficient over the 
course of a project. You can add a favorite that you return to frequently – last week, you were 
instructed in how to add folders to your favorites!  If you don’t see the browser panel, go to 
View>Panels>click on Browser. Drag your data into the project. 

 

 
 

2. The data will be added to your project as a layer in the Layers Panel. It will contain no symbolization, 
but will include the geometry for the block groups. Each of these block groups contains various 
information on education levels for that geographic area.  
 
Note: A block group is a census geography that is based on somewhat arbitrary areas of similar 
population size.  
 
Notice where the layer appears in the Layer Panel. The order of these layers corresponds to their draw 
order – layers lower in the list will appear as though the geometry of other layers is stacked above them. 
Move this layer so it is below the water layer, boundary layer, and the roads layer in week1.qgz. Your 
document should now look something like this. 
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Note: You’ll note that the towns are already labeled. To see how this was done, right click on the layer 
BOUNDARY_POLY go to properties>Label. On the upper dropdown menu go to Single labels. Now go to 
the dropdown menu called Label with and select the option TOWN. Click ok. 
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OBJECTIVE 2. SYMBOLIZE THE DATA ON THE MAP 
 
We just added a layer that contains data on employment for persons over the age of 16 at a block group 
level in the Boston area. However, the visualization is not yet very useful – it displays the geometries, 
but tells us nothing about their characteristics. We can change the layer symbology so that color 
gradients represent quantities. 
 
1. To change a layer’s symbology, first highlight the layer in the Layers Panel. To do this, right-click the 
highlighted layer and select Properties at the bottom of the dropdown. The Layer Properties dialog 
window will appear. You can also double click the selected layer. 
 
2. Select the Symbology tab in the dialog. 
 

 
 

3. In this tab, you are given many options to classify and symbolize the data in your map 
document. At the top of the dialog select Graduated. Then, select a column on which to base 
the classification and click ‘classify’ – try “UNEMPLOY” at first, which represents the total 
number of unemployed people. 
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Click OK – you should now have a map in which unemployment is visualized! But this is not a super-
useful map… it just represents population density, more than anything else. When making this type of 
map, the concept of normalization is very important. Administrative areas and other enumeration units 
usually vary widely in size and population. In order to minimize the effect of differences in these areas, 
we need to normalize our data. To normalize in QGIS, you have to write a data expression that divides 
the values in one field by another. To illustrate normalization, let’s work with the total population 
numbers provided in the boston_employment_2016.shp shapefile. 
 
1. In the Symbology tab, the estimated total population in 2012-2016 is contained in a column called 
“TOT_POP”. You can find this in the metadata for the dataset, which we will discuss later in the exercise. 
Symbolize the layer by this dataset, setting it at the Value in the Column dropdown menu. Classify your 
data by clicking ‘Classify’. Your Styling dialog will look like the following: 
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Click OK. Your map will symbolize according to the total population number in each block group. It will 
look something like the following. What does it tell us? It is fairly difficult to see a true population profile 
of Boston. 
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This population data is Unnormalized, this means it simply shows a total number. When comparing units 
of vastly different size, comparisons can be misleading, if not incorrect. Larger areas logically have larger 
numbers, and larger populations logically have larger numbers of persons that can possess a specific 
characteristic. 
 
The way to address this is to Normalize the data. Data is normalized to account for differences that 
might impact a total number by looking at population as a percentage of area. A block group in 
suburban Boston might have more people than a block group in downtown Boston, but the block group 
in downtown Boston might be much smaller, and in an unnormalized map, the true comparison of the 
two block groups might be misleading. 
 
When we normalize, we look at the percentage of people that live in an area per square mile, rather 
than the total number of people. This allows for a more even ‘apples to apples’ comparison. Now, let’s 
normalize our population map to reveal the density of persons in each block group. 
 
2. Navigate to Properties -> Symbology. 
 
3. In the Graduated menu, you will see a drop down button called Column Expression. Here you can 
select the field that contains the value you want to normalize. right to that menu there is a button called 

Expression . Here you can select the expression that will calculate the value you want to 
normalize the data against. In our circumstance, we want to normalize people by square mile. This will 
create a density map of persons per square mile. To do this, we have to calculate the density by writing 
the following expression on the expression box TOT_POP / AREA_SQMI. You can also do it following 
these steps: 
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1. Click on the “(“ to start the function. 
2. On the Functions box go to Fields and Values drop down menu and double click on the field 

“TOT_POP” 
3. Then click on the “/” button above the expression box 
4. Go again to the Fields and Values>double click on the “AREA_SQMI” 
5. Close the expression by clicking on “)” button 
6. Click ok 

 

 
 

Once you are back in the Symbology tab, click on Classify to get the new classified dataset. Also, 
experiment with the Classification Mode. Use “Natural Breaks” instead of Equal Interval. We’ll look at 
this more in a bit. 
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Click OK. Your normalized map showing persons per square mile will look like the following. What does 
this show? Are the comparisons between block groups more relevant? You will see that block groups 
near the Charles, in downtown, and in other densely populated areas are distinguished from the lesser 
dense, larger, more suburban block groups. 
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The images below showcase the difference that normalization makes in your dataset. 
 
 

                         
Unnormalized Data (Total Persons) Normalized Data (Total Persons per Square 

Mile) 
OBJECTIVE 2B: SYMBOLIZE A CENSUS VARIABLE 
 
Having demonstrated the importance of normalization, the next task we want to accomplish is to make 
a map showing how people commute to work. The commuter data is from the U.S. Census Bureau 
American Community Survey. We are using the 2012-2016 Five Year Estimates. 
 
1. Returning to Properties -> Symbology, set the Column value as Bicycle – this is the number of people 
who bicycle to work. 
 
2. Just as above, we need to normalize this data. When we normalize, we look at the percentage of 
individuals that can commute to work, and those would be the people in the labor force. This field is 
called WORK_16Y. 
 
We want to normalize the map by our sample population. The U.S. Census collects this commuter data 
for people in the Labor force 16 years and older. Set Normalization to Work_16Y. Put in simpler terms, 
we will be looking at the percentage of persons in the labor force who commute to work using their 
bike.  
 

4. Go the Expression Dialog as you did previously and pick (“BICYCLE” / “WORK_16Y”) see below. 
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3. Select a color ramp. As we are showing sequential data, it is important to pick a sequential color 
scheme that goes from light (indicated less) to dark (indicating more). Pick a color ramp similar to the 
sequential one shown. Why do we pick a sequential color ramp over a divergent or categorical color 
ramp? Don’t forget to hit Classify or your data will not apply the classification.  
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4. Your map composition should look something like the image below (perhaps with different colors). 
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5. Next, we are going to adjust the classification scheme for our map. Return to the properties 
dialog by right-clicking on the boston_employment_2016 layer. In the Properties > Symbology 
tab, click the Mode drop down menu. 

 

 
 

6. Notice that there are a number of different options. We read about the various classification 
methods in this week’s assigned readings. Try a few of them and observe how the methods vary 
and the appearance of the map changes.  
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7.  Each of the block groups that we have symbolized with our classification scheme has a dark 

outline. If we want to change the color of this outline, we can adjust it universally for all the 
block groups in our map. To change the properties of the symbols for all map features, click the 
on the “Change…” button at the Symbol Box. 

 
 
 

 
 

 
 
The dialog pictured below will appear. Click on the simple fill button and select the outline color you 
want, or no color, and click OK. I picked Transparent stroke.  
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After making these changes to your map symbolization, your map should look something like the 
following. 
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OBJECTIVE 3: COMPOSE, DESIGN, AND LAYOUT YOUR MAP 

STEP 1.   
When working in QGIS, there are two main methods in which you view your data, edit it, and create a 
map. We have been working in data mode. In our following steps, we are going to layout our map. To do 
this, we use Layout Mode. This mode will allow us to arrange our map items in relation to one another 
with respect to the appearance of our final layout. 
 

1. Go to Project>New Print Layout on the QGIS menu bar. Create a name for your Layout, such as 
‘week 1 map’ and click OK. A new window will appear. 
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2. We now can see our map as it is laid out on the page. Right now, we are using a standard 8.5 x 11 
page layout set in landscape orientation. If you want to change the format go to the left option panel 
and click on Layout>Page Setup dropdown menu and set the page layout. 
 

  
 

3. The Add Item menu allows you to add our map elements, including the viewports and the legend that 
will inform our reader what the colors and classifications mean on our map. To create a viewport, go to 
Add Item and click on the Add Map button. 
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Once the Add Map button is active, hold the left mouse button and drag a rectangle where you want to insert 
the map. You will see that the rectangle window will be rendered with the map from the main QGIS canvas. 
The rendered map may not be covering the full extent of our interest area. Click Edit>Move Content or 
the button below. To move content around on the map.  

 
 
 Your map should look something like the following. 
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To create a legend, go to Add Item and click on the Add legend button. Just like when you added the 
map you will need to click on the left mouse button and drag to make the size of the legend.  
 
If you want to change the text and content of the legend first select the legend, right-click and say Item 
properties and the items will appear on the right. Make sure AUTO UPDATE is NOT CHECKED. You can 
remove legend items by selecting them and then clicking on the red ‘minus’ button.  
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Next, notice that our legend actually represents percentages, but the values shown are currently 
decimals that might not make much intuitive sense to the map reader. Let’s reformat the legend text to 
show our results as percentages. 
 
Reopen your layer properties in the main map document, not the layout document and go to 
Symbology. 

Click on Expression button  multiply the expression that you wrote before by 100.  
 
Now your formula should look like this: 
( "BICYCLE"  /  "WORK_16Y")  * 100. Below the expression box is the Legend Format box add the symbol 
%. Click on the button Classify to add the changes. Finally go to precision box and set the number of 
decimal places shown to 2. This will get rid of extra decimal places on our map that may confuse 
readers. Also, don’t forget to hit classify to make sure your changes are made.  
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10. Let’s make our map easier to understand for our readers. Currently, our symbolization categories, or 
classes, have breaks at unusual numbers. Modify the breaks in the classification scheme to show more 
logical, ‘common sense’ numbers. Double-click on each of the row entries under Values, and in the 
Break values window, change the numbers.  
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For this classification, use 2.5, 5, 10, and 15. Leave the highest value as is, this represents the maximum 
value in the data. You now have a manual classification scheme, based off of the Jenks classification 
scheme. (The image below is an example of what your window should look like.) Click OK.  
 
  
 
11. Your map is now laid out with a legend. It should look like the following: 
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STEP 2. ADD A NORTH ARROW AND SCALE BAR 
 
There are a certain number of elements that are standard to include on a map. These items are standard 
because they provide the map reader with information that they need to properly interpret the map. 
The two most important items are a scale bar that tells the map reader the translation between the map 
and ground distance, and a north arrow to orient the map reader on how to properly know which 
direction is which on the map. Let’s add these two items to our map. 
 

1. To add a scale bar, make sure you are in the Layout Manager window. Go to Add Item> Add 
Scale bar and click to place it on the map. Select the scale bar and go to the right-hand side 
menu and click on Item Properties. Play with the options to modify the features of the scale bar 
such as units, style, font, etc. Go to Main Properties dropdown and pick Double box. Now go to 
Units>Scalebar units> Mile. Change the rest of the properties to match what is below.  
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2. To add a north arrow, go to Add Item > Add Arrow. Draw the north arrow by clicking a straight line 
from bottom to top (since the arrow should be north-facing). Right-click to release the drawing.  Select 
the Arrow and go to the right-hand menu and click on Item Properties. Play with the options to modify 
the features of the Arrow. 
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STEP 3. ADD AN INSET (LOCATOR) MAP USING A SECOND MAP FRAME 
 
Now we will add a map inset that shows a zoomed out view for the Boston area. Before we make any 
changes to the layers in the main QGIS window, check the Lock layers for Map 1 item and Lock layer 
styles for map item boxes. This will ensure that if we turn off some layers or change their styles, this 
view will not change. 
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Switch to the main QGIS window. Use the Zoom out button to zoom to the level of the state of 
Massachusetts. Turn off all the layers from the previous map and turn on the layer 
detailed_state_bound_MA. 
 
 

 
 
We are now ready to add the map inset. Switch the Map Layout window. Go to Add Item  ‣ Add Map 
 
Drag a rectangle at the place where you want to add the map inset. You will now notice that we have 2 
map objects in the Layout Manager. When making changes, make sure you have the correct map 
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selected. Select the Map 2 object that we just added from the Items panel. Select the Item 
properties tab. Scroll down to the Frame panel and check the box next to it. You can change the color 
and thickness of the frame border so it is easy to distinguish against the map background.  

 

 
 

One neat feature of the Map Layout is that it can automatically highlight the area from the main map, 
which is represented in our inset. Select the Map 2 object from the Items panel. In the Item 

properties tab, scroll down to the Overviews section. Click the Add a new overview button . 
What this is telling the Layout is that it must highlight our current object Map 1 within the Map 2 object, 
which is the zoomed-out map of Massachusetts. Make the properties look like the dialog below.  
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Your locator will now look similar to the following.  
 

 
 
 
STEP 4. ADD TEXT AND LABELS TO YOUR MAP 
 
There are two main ways to add text to your map, automatically, using the labeling tools, and manually, 
using the Drawing toolbar.  
 
1. You earlier labelled the cities on your map (pg. 6). These labels, including Boston, Cambridge, 
Somerville, etc., are added using the QGIS labeling features. These labels are based off attributes for 
that layer. Settings can be changed in the Labels tab of the Layer Properties. As these are already set, we 
don’t need to change them right now, but if we wanted to base our labels off of a different field in our 
attributes, we would change on the label tab. You can easily toggle these on and off, and change the 
properties of the labels. We will expand on this as the semester goes on. 
 
3. To manually add text go to Add Item >Add Label> click on the area which you want to add the text. 
Select the text you added and go the right feature box on the screen. Go to Item properties>Main 
properties. On the Box that appears write MASSACHUSETTS. Now go to Appearance to modify the fonts, 
color, etc. of the text.  
 
 
STEP 5. CHANGE THE TITLE, ADD SOURCE, AUTHOR, AND DATE CREATED TO LAYOUT 
 
1. Our map now needs an informative title. We need a title that states the map is showing Boston 
Bicycle Commuters.  Go to layout>Add Label. Type “Boston Bicycle Commuters” 
 
2. One of the most important components of a map is the source information. Our data is from the 
American Community Survey, 2012-2016. We need to include this on the map. Add another text box 
below the title using the Draw toolbar and write the text “American Community Survey Estimates 2012-
2016” 
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2. The final component is to add author and date information. Put this information in the lower-right-
hand corner of the map, underneath the locator map. Here add a text box that includes your name and 
the date you created the map. 
 
After these steps, your map should now look like the following. 
 

 
 
 
STEP 6: EXPORT YOUR MAP TO PDF FORMAT 
 
Now that our map layout is complete, we are ready to export the file to a PDF format so it can be 
printed or viewed online. To do this, go to Layout > Export as PDF. Save the file to your workspace. It is 
best practice to keep your files well organized and create a folder called ‘Exports’ or ‘Graphics’ for all 
your exports and final exported maps. Open the file in Adobe Acrobat to make sure that your export 
worked. 
 

 
 
 

OBJECTIVE 4. VIEW METADATA IN JSON FORMATTER 
 
Each GIS file you use contains Metadata. Metadata is where you find information about the data you are 
using, such as what each field represents and other attributes. While metadata is important and 
valuable in understanding a dataset, you will often find it is incomplete. The datasets for this week have 
completed metadata that we can view in ArcCatalog. 
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Metadata is often stored in a file format called extensible Markup language (XML). These are long files 
that store structured information, in this case about our data. To make these readable, it’s common to 
use a parser, or viewer. 
 
Navigate to jsonformatter.org/xml-viewer. Select ‘load data’ and add 
data/boston_commute_2016.shp.xml, and select ‘Format / Beautify’. Your screen should look like the 
screen below: 
 

 
 
Whoa, what a mess… but actually, we can parse this fairly easily! Search for ‘eainfo’ (command-f) within 
the XML. Within the <eainfo> tag, you should see a series of attributes (<attr>). Each of these 
corresponds to a field, and each contains a <attrdef> field. This is the metadata description of the field! 
For example, the FID field (highlighted below) is the ‘Internal Feature Number’… 
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You can make modifications to the file in the Formatted/Beautified interface and re-download it as an 
XML. You will need to examine metadata to complete Take-home Exercise 1. 
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THE 11.205/520 MAP DESIGN CHECKLIST 

We encourage you to explore various cartographic methods and be creative with your deliverables 
during the course of this class. That said, each map you submit must contain the following qualities and 
features. We will check each map to make sure it includes the following. Run through this checklist as 
you complete maps in this course. 

All maps should contain: 

1. Informative Title – The titles to your maps should allow the reader to quickly understand the map.

2. Legend – A legend that clearly describes the thematic layers on the maps.

3. Data Source – The source of your data is also important in validating your map results, interpreting
the map, and allowing the reader to explore your data further.

4. Scale Bar – The scale bar is the translation between the map and the real life features.

5. Date – The date you create your map is important, especially if multiple versions are being made.

6. North Arrow – A north arrow is necessary to properly orient the reader to the map.

7. Author – Your name is important to include on all maps you author. You should also include
organization information (i.e. MITDUSP) to help the reader.

Other items, such as locator maps and data analysis methods, are often helpful to readers, but not 
required in this course. 
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