
11.205 – Intro to Spatial Analysis – Fall 2019 
ArcMap Exercise 

Week 4 – An Introduction to Geoprocessing: Objectives 

I. Prepare Data for Geoprocessing
II. Learn to use the Buffer Tool to run a proximity analysis
III. Use the Clip Tool to Extract Features
IV. Use the Dissolve Tool to Calculate Areas
V. Create a Pie Chart in Excel
VI. Use the Update Tool to change data
VII. Combine Data using the Intersect Tool
VIII. Use the Proportional Split estimation method for population
IX. Use the Proportional Split estimation method for commuter data

INTRODUCING GEOPROCESSING 

This week in lecture, we introduced geoprocessing: performing analytical operations on data layers. 
Geoprocessing involves combining layers in different ways to yield new information that can allow for 
insight or further analysis. In lab this week, we are going to explore some basic geoprocessing functions. 

The MBTA, in collaboration with the City of Somerville and City of Medford, is planning an extension of 
the Green Line light rail transit line into the two cities. Somerville is investigating the impact of the 
proposed station locations. Specifically, they are interested in how the proposed Union Square station 
might affect land use and transit use. The city is seeking information on the area of each type of land 
use, the population, and the number of individuals that commute to work on transit within half a mile of 
the proposed Union Square Green Line station. 

The following is a map of the proposed line, for reference, from the Boston Globe:

http://archive.boston.com/news/local/massachusetts/articles/2009/07/21/green_line_pop/

To conduct our analysis, we are going to use some basic geoprocessing techniques. Let’s get started! 
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OBJECTIVE 1. PREPARE OUR DATA FOR ANALYSIS/SELECT STATIONS/VISUALIZE LAND USE 
DATA 

The first task is to load our data layers to prepare for analysis. In the class materials, you will find the 
two main shapefiles we need for our geoprocessing analysis, 
taxParcels_CambridgeSomerville_2017.shp and MBTA_stations.shp. These files, respectively, contain a 
parcel file merged to contain both Cambridge and Somerville, and a point file containing locations of all 
MBTA stations. The Union Square area is close to the Cambridge/Somerville city line, so your analysis 
will include parcels from both cities. 

1. Open a new map document and add the two layers. Your map will look like the following.

2. Our analysis is going to focus on the proposed Union Square station. Open the attribute table of the
MBTA data to see the fields and look at the data. You will see the MBTA stations layer contains all of the
stations in the system, including the proposed ones. We are only concerned with the proposed Union
Square station on the Green Line extension.

Navigate to the ‘Select by Attribute’ tool in the table options to query our ‘MBTA_stations’ dataset. 
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When the ‘Select by Attributes’ window appears, set the 
query method to ‘Create a new selection.’  

Then, construct the query using the dialog window options. 
First, double click on the “STATION” field in the top window. 

Type ‘=’ and then click the ‘Get Unique Values’ button above 
the query field. This will show all the unique values in the 
“STATION” field.  

The station we are looking for is ‘Union Square (Proposed).’ 
Double click it. 

Your query will look like the following: 

“STATION”=‘Union Square (Proposed)’ 

Click apply to run the query. 

3. Return to the map. You will see one station highlighted,
the proposed Union Square station.

4. Create a new shapefile from our selection by exporting
the data. To do so, right-click on MBTA_stations and go to
Data -> Export Data. In the Export Data dialog, make sure
you are only exporting the features we have selected, not
all features in the layer. Name the shapefile
union_square_station.shp. Save it to your week’s working
space.

Add union_square_station.shp to your map document when the file is created. 
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Clear selections by going to the top of the page and using the “Selection” 
drop down menu. Select “Clear Selected Features.” You can also click on 

the button. 
 
 
 
 
 
 
 

 
 
 
4. Next, you will visualize land use. The Massachusetts parcel datasets contain highly detailed land use 
codes. If you want to dig into them, you can find the official code book for the parcel dataset in your 
weekly materials as “classificationcodebook_massachusetts.pdf.” For this exercise, we have simplified 
the land use codes for you. You can find the simplified codes in the ‘LU’ field. The fields will correspond 
to the following: 
 
   

LU Description 
01 Single Family Residential 
02 Multi-family Residential 
03 Mixed Residential/Commercial 
04 Commercial/Office 
05 Industrial/Manufacturing 
06 Transportation/Utility 
07 Public Facilities/Public or Private Institutional 
08 Open Space and Outdoor Recreation 
09 Parking Facilities 
10 Vacant Land 
11 Other 

 

Symbolize the land use data using traditional land use map colors (recall Week 2’s exercise). Represent 
various categories within uses with several shades of the color. (i.e. single family residential is light 
yellow; multi-family residential is dark yellow -- or light blue is public facility; and dark blue is public or 
private institutional). 
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Color Land Use 
Yellow Residential 
Orange Mixed Use (Residential/Commercial) 
Red Commercial/Office 
Purple Industrial/Manufacturing 
Pink Transportation/Utility 
Gray Vacant Land/Other 
Blue Public Facilities/ Public or Private Institutional 
Green Open Space and Outdoor Recreation 
Black Parking Facilities 

When symbolized, your map should look something like the following. Save it as geoprocessing.mxd to 
your weekly working folder. 
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OBJECTIVE 2: LEARN TO USE THE BUFFER TOOL 

With our map document setup and the data visualized, we can begin our analytical process. In ArcGIS, 
most geoprocessing tools are accessed through ArcToolbox, an integrated feature that catalogs tools. To 
complete our tasks, we are going to begin by using a ‘buffer’ to create a 
polygon shapefile that contains all area within ½ mile of the proposed 
Union Square station. 

1. Open ArcToolbox by clicking
the small red box at the top of
the ArcGIS map document
window, or by clicking on the
Geoprocessing menu
dropdown and selecting
ArcToolbox.

You can dock the ArcToolbox window to your map document by clicking 
and holding the title bar and dragging it to the arrows on the side of the 
window. A small pushpin button at the top right will keep it as a tab on the 
right side of your map window so that it can be easily expanded/collapsed. 

Explore this window and the many geoprocessing options available in the ArcGIS software. There are 
other options for accessing tools, such as writing Python scripts and creating model builder models, but 
for this exercise, we are going to use ArcToolbox. 

2. The Buffer tool is a Proximity Analysis tool. This means it can be found
in the ‘Analysis Tools’ under a submenu called ‘Proximity’. In ArcToolbox,
navigate to the Buffer tool. Double click on it.
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The Buffer dialog window will open. In it, we will set all 
the parameters of our buffer process. Use the Union 
Square station layer as the input, save the output in the 
weekly workspace as UnionSquareBuffer.shp. Set our 
buffer distance to be ½ mile. There are many other 
options you can use to fine tune your buffers. For now, 
leave the rest of the options as default. Once set, click OK 
to run the buffer tool. 

Your buffer will now look something like the following. 
You have created a new shapefile that contains a circular 
area with a radius of ½ mile around the proposed Union 
Square station. 

OBJECTIVE 3: USE THE CLIP TOOL TO EXTRACT LAND USE POLYGONS NEAR UNION SQUARE 

We now have a polygon shapefile that contains a polygon of the area within ½ mile of the proposed 
Union Square station. We can use this polygon layer to extract information from our land use layer. We 
only want to look at the land uses in within ½ mile of the proposed Union Square station, so, we will 
create a new shapefile that contains only the parcels within the area of the buffer. 
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1. To create our new layer, we will use the Clip tool. The Clip tool is in
the Analysis toolbox, under the Extract submenu. But to find it, we
are going to use the Search feature. There are many tools in
ArcToolbox and navigating the folder structure can be tedious. If you
are unsure where to find the tool you are looking for, this is the best
way to do so.

Under the Geoprocessing dropdown menu at the top of 
the ArcGIS interface, select Search for Tools. Type in 
“Clip”. A couple of options will appear. Select the Clip 
(Analysis) option from the search window.  

The Clip dialog will appear. Here we will set the 
parameters for our clip function. We want to clip 
the land use layer. Set 
taxparcels_CambridgeSomerville_2017 to be the 
input features and UnionSquareBuffer to be the 
clip features. Name the output 
taxParcels_UnionSquare.shp and save it to your 
weekly workspace. The dialog will look like the 
following. Click OK and add the new layer to your 
map document.  
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2. Turn off visibility on 
taxParcels_CambridgeSomerville_2017 and zoom to 
the taxparcels _UnionSquare layer. You do this by right 
clicking on the taxparcels_UnionSquare and selecting 
the “Zoom to Layer” option.  
 
 
 
 
 
 

 
At this stage in the process, your map document should look similar to the following. Note that our 
Parcels layer has been ‘clipped’ to the buffer layer, and that only intersecting features are included. 
 

 
 
Taking a look at the attribute table for taxParcels_UnionSquare, you will only see the tax parcels within 
the clipped extent in our output clipped shapefile. 
 
When looking at the geometry of taxParcels_UnionSquare, you will notice some of the parcels get cut in 
half by the edge of the ½ mile buffer and the geometry has changed. When you perform a Clip, you are 
creating a new shapefile that has new geometry. This geometric change is not represented in the 
attribute table, and no fields are updated along with the geometry. In other words, if you have an 
Area field in your attribute table and you run a clip, the Area is not automatically updated. This 
matters because some of the parcels were cut during the clip process.  
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3. We need to add a new field and populate it with the new area of
each polygon. Open the taxparcels_UnionSquare attribute table. In the
attribute table, navigate to table options, and select Add Field. Name
the field ‘AREA_CLIP’ and give it the type of ‘Double’. It is important to
keep field names short (either less than 8 or 13 characters) as long
names can sometimes cause problems down the road.

4. Right-click on the Area field you just created in the
attribute table. Select Calculate Geometry from the
dropdown that appears. (Click Yes to the warning box,
we will address this at a later date.) In the dialog box
that appears, indicate that you want to calculate
Area, and select Square Feet as the unit of
measurement. Ignore the coordinate system radio
buttons for now.

Click OK once you have your options selected (and 
“yes” to the warning if it appears). The Area field will 
now populate with the area of each polygon measured in Square Feet. 

Looking at your table you will see something like the following: 

Save early and save often! Save your map document (geoprocessing.mxd). 
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OBJECTIVE 4. USING THE DISSOLVE TOOL 

We can now sum the area for each land use type. There is a shortcut to 
calculating the area for each parcel rather than adding it up one by one. 
Dissolve takes multiple features and combines them into one continuous 
feature based on common attributes. In our case, it will be polygons based 
on each land use type.  

1. The Dissolve tool, like the Buffer tool, is located in ArcToolbox. Dissolve is
a Generalization tool, meaning it ‘generalizes’ or simplifies data. It can be
found in Data Management Tools -> Generalization -> Dissolve. Navigate
to the Dissolve tool and double click. The Dissolve dialog window will open.
In the Dissolve dialog, set our input features as

taxParcels_UnionSquare.shp to dissolve our multiple polygons into one. 

a. Call the output taxParcel_Dissolve.shp, and save
it to your weekly workspace.

b. Set the Dissolve Field to be LU. This will create a
shapefile with one feature for each value of LU.
There are 11 values for LU, so the new shapefile will
have 11 rows. The output will be multipart polygon,
meaning that each single feature can have multiple
parts.

c. The last part of the dialog is the statistics field.
This will run basic statistics on our file when we
dissolve it. We just calculated the area in the
AREA_CLIP field. Select this from the dropdown,
and then set the statistic type to SUM. This will add the areas for each feature and give us a total sum
for each land use type.

Click OK to run the tool. 

Add your new layer to the map. Right-click on the layer in the Table of Contents and open the attribute 
table. Notice you have fewer features. This is because we dissolved each land use type into one feature. 
Also notice the field called SUM_AREA_C. This is the total area for each type of land use. The 
SUM_AREA_C field is in Square Feet. 

To illustrate what Dissolve is doing, your old buffers should look like those on the left, your new 
dissolved buffers should look like those on the right. 
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Your attribute table should look like the following. In the attribute table, 
you will see one feature for each LU value. Select the first row by clicking 
to the left of the row to highlight that row in the table and on the map.  

You will see the feature, which represents all of the parcels that share a 
particular land use type selected. Deselect the feature to move forward 
by going to Selection -> Clear Selected Feature. 

OBJECTIVE 5: EXPORT THE TABLE TO EXCEL AND CREATE A PIE CHART 

We can now export this table to Excel and create a pie chart showing the total area of each land use 
type within ½ mile of the Union Square station. 

1. Export the table. To export the attribute table, go to Table Options and choose Export. Save the table
as type ‘dBASE table’, not a File or Personal Geodatabase Table, and name it
UnionSquare_LandUses.dbf. Save it in your weekly working directory. When you click OK, ArcMap will
ask you if you want to add the table to the map. Select No. If we add the table, ArcGIS will place a lock
on the table that will not allow us to edit it in another software until we remove it from our map or close
ArcGIS.

2. Open Excel. Go to File -> Open. You may not see the DBF file in your directory, so tell Excel to see All
Files in the folder.
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3. Add a new column called DESCRIPTIONS with the textual description of the Land Uses (LU) for our 
chart. Again, here are the land use code descriptions. 
    

LU Description 
01 Single Family Residential 

02 Multi-family Residential 

03 Mixed Residential/Commercial 

04 Commercial/Office 

05 Industrial/Manufacturing 

06 Transportation/Utility 

07 Public Facilities/Public or Private Institutional 

08 Open Space and Outdoor Recreation 

09 Parking Facilities 

10 Vacant Land 

11 Other 

 
 
4. In Excel, use the =SUM( ) function in cell E2 to sum the areas of each land use. Your Excel function 
should look like the following: 

=SUM(C2:C12) 
 
5. In Excel, add a column to hold the percentage of each land use. Call it PERCENTAGE. We will show this 
on our chart to help the reader make better sense of the data. Populate PERCENTAGE with the sum of 
each area divided by the total sum. Use the ‘$’ in Excel to hold the sum field. The function will look like 
the following: 

=C2/$E$2 
Fill out the field. 
 
6. Change the field format to percentage. Your table will look like the following: 
 

 

 
 

13



7. You can now make a pie chart that will include percentages. Use the same colors for the pie chart
categories as for your land use map. This will allow you to use the same legend as you use for the map
and create consistency for your reader. To create the pie chart, use the Insert -> Charts -> Pie or Donut
Chart feature in Excel. Your final pie chart should look something like the following.

(Mind you, Excel can make some fantastically bad graphs. Feel free to edit them or bring them into your graphics editor of
choice (ie Adobe Illustrator or Inkscape)) 

Creating charts and graphs using Excel and ArcGIS in conjunction with one another is a very powerful 
workflow and can be used to create very compelling data driven arguments. 

OBJECTIVE 6: USE THE UPDATE TOOL TO CHANGE A DATASET 

The City of Somerville, in preparation for the construction of the station, has been updating most recent 
land use data near the proposed Union Square station. They have a shapefile of 11 parcels that contain 
new land use codes near the proposed station. Using the Update Tool, we can modify the tax parcel 
shapefile to reflect the changes in Land Use Codes. The Update Tool will update a feature class based on 
common attributes from another feature class. 

1. Returning to ArcMap, reopen the geoprocessing.mxd we have been working with. In the Data
folder>boston, you will see a shapefile named updated_UnionSquareLandUse.shp. Add it your map
document.
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2. Open the attribute table of updated_UnionSquareLandUse. You will see it contains 11 parcels. The
attributes follow the exact same schema, but the only difference is the lands use information (i.e.
LUCode, LUDesc and LU) has been changed. We can use Update to apply these changes to our tax parcel
file and create a new updated file.

The attribute table for updated_UnionSquareLandUse looks like the following, with the LU field 
highlighted. 

The taxParcels_UnionSquare layer attribute table, for the same parcels, looks like the following. 
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3. Before updating the file, we want to make sure we are using the whole
file.  Go to Selection -> Clear Selected Features in your map document to
make sure nothing is selected in our document.

4. Updating the file creates a new output that contains a geometric
intersection of the Input Features and Update Features. It will update both
the geometry and the attributes, with the features from the update layer
taking precedence over features from the input layer. Search or navigate to
Analysis Tools -> Overlay -> Update. Double click on it and the Update
dialog will open.

 In the Update dialog, set the Input Features to 
taxParcels_UnionSquare, the update features to 
updated_UnionSquareLandUse, and name the 
output updatedTaxParcels_UnionSquare, saving 
it to your weekly working space. Once the dialog 
is set, click OK.  

5. Once the Update Tool has completed running,
add the updatedTaxParcels_UnionSquare layer to
your map. Click on one of the parcels we updated to select it and open the attribute table. You will see
that the land use information for all of the parcels was brought into our new file. For example, the
selected parcels, which previously had different LUDesc codes among them, now all have LUDesc values
of CONDO-BLDG. The attribute table, map, and document will look like the following.
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Using the update tool is one method of overlay analysis that allows you to combine a file with multiple 
differences to an original file in order to modify and update it. 
 

OBJECTIVE 7: COMBINE DATA USING THE INTERSECT TOOL 

 
Our next task is to find an estimate of population within ½ mile of the proposed Union Square station. 
To complete this task, we are going to use the Intersect tool and the block group level data that contains 
the 2013-2017 ACS population estimate (in the block group shapefile as POP15). The Intersect tool takes 
two layers, and creates a new shapefile that contains areas that are included in both shapefiles. When 
the Intersect tool is run, each individual feature that is in this congruent area will be brought to the new 
file, and the attributes will transfer with it. 
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We are going create a new polygon shapefile that contains all of the areas that are both within a 
Cambridge or Somerville block group and within ½ mile of the proposed station site. 

First, save your geoprocessing.mxd map document to preserve it, then go to File -> Save as… and save 
the file as geoprocessing_part2.mxd in your weekly workspace. We will now do some census data work. 
From your weekly materials, add CambridgeSomerville_blkgrps_2017.shp to your map document. 

We will start by adding an Area column to our block group shapefile. 

1. Add a field to the attribute table of the
CambridgeSomerville_blkgrps_2017 file.  We will call this
field AREA_SQMI. Make the field’s data type Double.

2. Calculate the area of each block group by right-clicking
the field and choosing Calculate Geometry.  In the dialog
box that appears, select that you want to calculate the
area in square miles.

3. With the area now populated in our block group table, we are
now ready to perform the intersection. In ArcToolbox, navigate to
the Intersect tool. It is in the Analysis toolbox nested within the
Overlay tools. Double-click Intersect.
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4. The Intersect dialog will appear. Add the 
two layers we want to intersect. Name the 
file UnionSquare_BlkGrp_Intersect.shp and 
save it to your weekly working space. 
JoinAttributes represents the attributes 
from each layer, make sure it is marked as 
ALL and leave the defaults for the rest. 

 
Click OK to run the Intersect. 
 
5. Your output should look like the following. Notice that only the areas that were overlapping in the 
two shapefiles are in our output shapefile. 
 

 
At first, this looks a lot like a clip, but open the attribute table. You will see that, unlike doing a clip, 
taking the intersect also applied the attributes of each layer to our output intersected file.  
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As with many tasks in ArcGIS, there are many ways to get to the same result. Think of what other 
methods you could use to get only the areas of the block groups that are within ½ mile of the proposed 
Union Square station location. 
 
OBJECTIVE 8: USE THE PROPORTIONAL SPLIT ESTIMATION METHOD TO GET POPULATION 
 
As we covered in class, there are a number of methods that can be employed to estimate values over 
geographic areas. In this case, we are going to use the Proportional Split method. When we intersected 
the block group and buffer files in the last step, we ended up with a file that contains a ‘portion’ of the 
block groups. The proportional split method involves taking a value, such as population, and multiplying 
it by the proportion of area that falls within our criteria, for example, within ½ mile of the proposed 
Union Square Green Line station. In the following steps, let’s calculate the population within ½ mile. Our 
file contains a 2013-2017 five year ACS estimate for population. 
 
1. Open the attribute table for UnionSquare_BlkGrp_Intersect. You will see the AREA_SQMI field we 
created in the last step. This represents the entire area of the block group. We need to add a new field 
that holds the area of the current intersected or clipped polygon. Add a new field, name it PROP_SQMI, 
and give it type Double. It will add on to the end of the fields in your attribute table. 
 
2. Calculate the values for PROP_SQMI using the Calculate Geometry tool. This will populate the field 
with the new size of each polygon. Remember to change the units to square miles. 
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3. Add another field to hold our proportional population value. We will use the field calculator to
populate this field with the estimated population within ½ mile of the proposed station site. To do this,
we will take the total population for the block group, and multiply it by the percentage product of
PROP_SQMI divided AREA_SQMI.  Add a new field, call it PROP_POP, and give it data type Double.

Right-click on the header of PROP_POP and go to the Field Calculator. Our field calculation will look like 
the following: 

PROP_POP = [POP17] * ( [PROP_SQMI] / [AREA_SQMI] ) 

Your field calculator window will look like the following. Once filled, click OK. 

PROP_POP will fill with the value of our proportional split estimation. Our table will look like the 
following: 
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PROP_POP now contains an estimation of the proportion of population that lives within ½ mile of the 
proposed station site. 
 
To get the total, right click the PROP_POP field and click Statistics. A dialog will appear that will give us 
Summary Statistics of the PROP_POP field. The Sum value, 16,306 persons, represents the count of 
persons in the area based on our proportional split method and based on the 2013-2017 ACS population 
estimate counts.  

 
 

To get a percentage of the total population, go to the original Cambridge and Somerville block group 
layer and summarize the population field. 
 
OBJECTIVE 9: USE THE PROPORTIONAL SPLIT ESTIMATION METHOD TO GET COMMUTER %  
 
In objective 8, we calculated an estimate of population based on the Proportional Split disaggregation 
method. The next objective is similar, except we are going to look at the percentage of commuters 16 
years old and over that commute to work by car within ½ mile of the proposed Union Square stop. The 
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American Community Survey collects commuter data. You can download it at Social Explorer—it is Table 
128: Means of Transportation to Work for Workers 16 Years and Over. But for this exercise we have 
downloaded it and placed it in the Data folder for the week in a CSV called 
CambridgeSomerville_Commuters_2017.csv. The file is based on an extract of the most current 
American Community Survey available from 2013-2017. Use this data to find the number of car 
commuters near Union Square. 

1. Add the commute_mode.xls file to your document, the
sheet is also called commute_mode.

2. Click on the UnionSquare_BlkGrp_Intersect file that
contains the block groups intersected with our Union
Square buffer, and the area calculations we have
completed in the previous steps. Join the commute_mode
spreadsheet to this dataset based on the GEOID primary
key. Your join window should look like the dialog to the left.
Once set, click OK.

3. Your attribute table for UnionSquare_BlkGrp_Intersect
will now have the commute data joined to the block
groups. Export the joined layer as a new SHP called
UnionSq_Block_Commute.shp and add it to your map.

We will now calculate the proportional split to determine 
the number of car and truck commuters in each block 
group within ½ mile of the proposed station. 

Add three fields to the attribute table, make them all type DOUBLE – and name them PROP_WORK (for 
the proportion of the total number of workers 16 years and over), PROP_CAR (for the proportion of the 
total number of car and truck commuters 16 years and over), and PERC_CAR (for the percentage of 
workers that commute by car or truck in each block group). Your table should look like the following. 
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4. Right click on the PROP_WORK field and go to field calculator. Here find the proportional split
estimate of workers aged 16 years and over. Use the following fields and equation.

Click OK to calculate. Right click and get statistics on the field, the total number of workers 16 and over 
is approximately 10,207 persons. 

5. Right click on the PROP_CAR field and go the field calculator. Here find the proportional split estimate
of workers 16 years and over that commute by car or truck to work. Use the following fields and
equation.

Click OK to calculate. Right click and get statistics on the field, the total number of workers 16 and over 
that commute by car is approximately 4,233 persons. 

6. Finally, lets calculate the percentage. Right click on PERC_CAR and go to the field calculator. Here find
the percentage of workers who commute by car or truck compared to the total percentage of
commuting workers aged 16 years and over. Use the following equation.

Note: Total numbers will not affect percentage, so we can use either our proportional populations or 
total populations.  Click OK to calculate. Your final table should look like the following. 
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7. Symbolize the map based on the percentage of workers who commute by car. My map document,
when complete, appears the like the following. Save your map document.
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