
11.205 – Intro to Spatial Analysis – Fall 2019 
Week 3 – Quantitative Mapping: U.S. Census Data, Geography, and Other Data Sources 
 
[OCW Users: The following document refers to the course website (Stellar) which is not available to 
users outside MIT.] 

 
ArcMap Exercise 
 
Week 3 Objectives – Part 1 – Social Explorer and Using Excel 
 
I. Acquire American Community Survey Data from Social Explorer 
II. Use Excel with GIS 
III. Make a Map with downloaded Data 
IV. Make a Chart using GIS data in Excel 
V. Create a Layout with Multiple Maps 
 
Lab Data 
 
Download the class files from Stellar and load them onto your external hard drive. 
The unzipped file consists of the following folders: 

1. DOCUMENTS: This folder includes Word documents for this week’s in-class exercise(s).  
2. DATA: This folder contains all the data needed for this week’s in-class exercise. 
3. PROBLEM SET 1: This folder contains all of the instructions, data required to complete the take 

home problem set, and three reference materials: 
a. Working with Excel: Why can’t I change my ‘Geo_FIPS’ field from numeric to text?! 
b. How to Make a Nice Bar Chart 
c. Writing Effective Policy Memos 

 
 

ACQUIRING AND MAPPING U.S. CENSUS BUREAU DATA 
 
This week in lecture, we discussed various sources of spatial data and how they can and should be used 
in a GIS setting. In lab today, we are going to look at the spatial patterns of educational attainment using 
American Community Survey data for 2012-2016.  You will see similarities with the dataset we worked 
with in Week 1, but instead we are going to work at the Tract level and not the Block Group level 
(remember the various Census Geographies from lecture). The Charles River Watershed Association is 
seeking to build an educational center, and would like information on the various education levels in the 
Watershed. The most recent American Community Survey (2012-2016) files contain this data, so we are 
going to acquire tract level data for three counties in the Boston metro area, then create a map that 
focuses only on the census tracts that are contained in the Charles River Watershed. 
 
OBJECTIVE 1: ACQUIRE ACS DATA FROM SOCIAL EXPLORER 
 
As mentioned in class, there are many ways to download American Community Survey data. The MIT 
Libraries has a subscription to a tool called Social Explorer that contains much Census and ACS data. We 
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are going to use this for the exercise, because it is the easiest way to download the data we need in 
spreadsheet format. If you are on the MIT campus, Social Explorer should automatically recognize the 
MIT subscription. Otherwise, if you are working from home, for example, you will need to connect to the 
MIT network first via Cisco’s AnyConnect VPN software.  

1. Begin our Data Mining on Social Explorer

Navigate to https://www.socialexplorer.com/explore-tables. The website looks like the following image. 
A. Click on ‘Tables’ on the top bar of the page.

After Social Explorer loads, you will see a list of the various datasets available on Social Explorer. There 
are two ways to access data, either by table, or by selecting on a map. We are going to use the Table 
method, where we can obtain data on the level of various census geographies.  

B. Click on American Community Survey (5-Year Estimates).
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C. We will be using the most recent, “2013-2017 (5-year Estimates).” Select the corresponding 

“Begin Report” link.   
 

 
 

 
 
 
 
2. Select the Desired Geography 
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For this exercise, we are going to work at the Census Tract level. When you begin your report, you are 
prompted to list the geographies for which you would like to download data. We are going to select 
Census Tracts for Middlesex, Suffolk, and Norfolk counties. The geography listing operates in a drill-
down type manner. First, set the geographic type to be Census Tract. Second, select a state, and third, 
select each county. Fill out your selection to match the following. 
 

 
Select a Geographic Type: State -> 
County -> Census Tract 
(Important: make sure you select 
the Census Tracts at level 140, 
not level 080. This will simplify 
the unique ID.) 
 
Select a State: Massachusetts 
 
Select a County: We are working 
with three counties (Middlesex, 
Suffolk, and Norfolk). You are 

going to have to select each county one by one in order to get our three counties. Every time you select 
a county, then select “All census tracts in” that county. Add it to the Current Geography Selections by 
double clicking on it or by clicking on the “ Add” button. Your final window should look like the 
screenshot shown below.  
 

Select Census Tract 

Sample Selection pictured for Norfolk County. Do this for all three counties: Norfolk, Middlesex, Suffolk 

4



 
 

 
 
Click “Proceed to Tables” to begin the selection of datasets available for download. 
 
In the datasets window, select the table we are seeking on Educational Attainment For Population 25 
Years And Over. It should be table A12001 in the Social Explorer Tables: ACS 2017 (5-year Estimates). 
Note all of the data layers, datasets, and tables available in the American Community Survey. There is a 
huge amount of information collected that can be analyzed and mapped! Select your dataset by 
scrolling through the List Tables, or click on Search by Keyword and enter some keywords for the 
variables you are looking for (for example, search Education to find Educational Attainment). Your 
selection window should look like the following. Click on ‘add’ and then ‘show results’ once you have 
selected your datasets. Make sure you highlight the data table in the window before you click on “Show 
Results” button.  
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Click the ‘Show results’ button. The next page should show you a report view of the data we selected. 
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3. Download the Data 
 
In the Report window, click on the Data Download tab. Here you are presented with a number of 
different options for downloading the dataset. Put a check next to “Output column labels in the first 
row”, and click to download “Census Tract data (CSV)”. This will download a comma-separated variable 
file that we can open in Microsoft Excel. 
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This will download a file that will be given a temporary name. Save it to your weekly workspace. Open 
up the CSV file in Microsoft Excel. CSV files are readable and editable in Microsoft Excel, but you will 
need to select ‘All Files’ from the dropdown menu to see the .csv file.  
 
OBJECTIVE 2: USING EXCEL WITH GIS 
 
1. Clean up the Data/Prepare it for GIS 
 
Open the new .csv file from where you saved it. The first thing we need to do is prepare the file to be 
read into GIS software without any errors. We can also get rid of fields that we will not be using. There 
are several fields in this table that we do not need, remove them by selecting them, right clicking on the 
selection, and deleting them. In our case, most of these fields are empty, making them useless to us. In 
some circumstances however, there is data in the field, we just will not be using it for our purposes. 
 
We can get rid of many of the fields, as they either contain no data or are filled with redundant data. 
This will vary based on census variables, but it is much easier to work with a small file.  
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Delete all columns for fields that are NOT listed below by right-clicking on the column, then clicking 
‘Delete.’ The fields we need to KEEP include: 
 
1. FIPS - (Geo_FIPS) – THIS WILL BE OUR PRIMARY KEY 
2. Name of Area - (Geo_NAME) 
3. Population 25 Years and over - (SE_A12001_001) 
4. Population 25 Years and over: Less Than High School - (SE_A12001_002) 
5. Population 25 Years and over: High School Graduate (includes equivalency) - (SE_A12001_003) 
6. Population 25 Years and over: Some college - (SE_A12001_004) 
7. Population 25 Years and over: Bachelor's degree - (SE_A12001_005) 
8. Population 25 Years and over: Master's degree - (SE_A12001_006) 
9. Population 25 Years and over: Professional school degree - (SE_A12001_007)  
10. Population 25 Years and over: Doctorate degree - (SE_A12001_008) 
 
With our spreadsheet now much more lightweight, we must rename fields so that ArcGIS can read them 
properly. We downloaded the first row in the table to make it easier to figure out what the fields’ names 
are, but GIS will not like the length of the names, or the fact that they contain spaces. Use the second 
field name where the names are eight characters or less. These names would be fine to use, however, as 
they are hard to understand, let’s make them a little clearer by changing the names of the fields to the 
ones specified in the following table. 
 
Rename the following fields (by typing the new names in the second row):  
 
Population 25 Years and over - SE_A12001_001_=> POP_EDU 
Population 25 Years and over: Less Than High School - SE_A12001_002 => LESS_HS 
Population 25 Years and over: High School Graduate (includes equivalency) - SE_A12001_003 => 
MORE_HS 
Population 25 Years and over: Some college - SE_A12001_004 => SOME_COL 
Population 25 Years and over: Bachelor's degree - SE_A12001_005 => HAS_BA 
Population 25 Years and over: Master's degree - SE_A12001_006 => HAS_MAST 
Population 25 Years and over: Professional school degree - SE_A12001_007 => HAS_PROF 
Population 25 Years and over: Doctorate degree - SE_A12001_008 => HAS_PHD 
 
IMPORTANT: Delete the row that contains the first heading of the file, the long one with spaces. Right 
click on the row and select delete. Your cleaned file should look like the following. 
 
 
 
 
Now, this table is in a manageable size and format.  
 
But wait! There are four more things we can do to prepare this file: set the field data types, set up the 
unique field for joining to GIS, add and calculate any new fields, and properly name the Excel sheet we 
are working in. 
 
a. Change and Set Field Data Types 
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In Excel, field data types are called ‘formats’. Change the format of the cells to make sure that GIS will 
read it correctly. Select the columns for each field, right click them, and select ‘Format cells.’ Change the 
format to the correct one if it’s not correct. Below is a list of the correct field type.   
 

 
 
Make sure your field types are the same as 
the below list.   
1. Geo_FIPS = Text 
2. Geo_NAME = Text 
11. POP_EDU= Number (no decimals) 
12. LESS_HS= Number (no decimals) 
13. MORE_HS= Number (no decimals) 
14. SOME_COL= Number (no decimals) 
15. HAS_BA= Number (no decimals) 
16. HAS_MAST= Number (no decimals) 
17. HAS_PROF = Number (no decimals) 
18. HAS_PHD = Number (no decimals) 
 
 
 
You can also do this by using the drop-
down menu in the Home tab of Excel: 
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Save your current version as a ‘Microsoft Excel 97-2003’ Worksheet. Backsave it to xls. Name it 
Education_ACS2017.xls 
 
IT IS VERY IMPORTANT THAT YOU SAVE AS AN EXCEL FILE.  
 
THE .CSV FILE WILL NOT SAVE THE FORMATTING YOU HAVE DONE AND MIGHT CAUSE PROBLEMS 
WHEN YOU JOIN.  
 
IMPORTANT: Save as xls file (Excel 97-2003) … NOT as an xlsx file. 
 
b. Locate the Unique Key to Join to GIS 
 
The Unique Key in our downloaded Social Explorer data is called GEO_FIPS. This will be the field we join 
to our GIS file.  
 
In the GIS shapefile we’ll be working with later, you’ll notice a GEOID10 field that contains matching 
rows. GEOID10 is type Text, so that’s why we made sure that the GEO_FIPS field is formatted to be Text 
data type too. As noted above, make sure you save as an Excel file to preserve the formatting.  
 
c. Use Excel Formulas to Add Fields and Derive Variables 
 
When joining data from Excel to a GIS file, you can normalize and add derived data either in GIS 
software, or you can calculate numbers in Excel before you perform the join. We will do both today to 
show the methods and introduce you to Excel formulas. In this exercise, we are going to create two 
maps of educational data in the Charles River watershed. One of the maps will show the percentage of 
individuals that possess a Master’s Degree by Census Tract, and the other will show individuals that have 
Less than a High School Education by Census Tract. 
 

11



We will look at them side by side at the end of the lab exercise. Using a formula in Excel, let’s create a 
new field and calculate the percentage of population age 25 and over that have a Master’s Degree for 
each Census Tract. 
 
1. Click on the column at the end of your Excel sheet to the right of HAS_PHD. In the top row with the 
other headers and type PERC_MAST in the column header. 
 

 
 
 
2. In this column, we are going to use what is called an Excel formula. Formulas allow us to fill in 
spreadsheet cells based on criteria, logical tests, and values from other cells. In simple terms, we 
wantthis field to hold the percentage of the population age 25 years and older that has a Master’s 
Degree, and we can create this by combining other fields. In this circumstance, we need to take 
HAS_MAST and divide it by POP_EDU to get the percentage of individuals that possess a Master’s 
Degree. 
 

PERC_MAST = HAS_MAST/POP_EDU 
 
There is a problem with this statement, however. There are a handful of census tracts that have zero 
population. (POP_EDU = 0) You cannot divide by zero, so we need to tell Excel what to do with these 
tracts. We can accomplish this using an IF statement. An IF statement will look at each cell we are 
calculating and if POP_EDU is equal to zero, it will place a zero in the cell instead of throwing an 
undefined error. 
 
In Excel, an IF statement looks like the following: 
 

=IF( <logical_test> , <value_if_true> , <value_if_false> ) 
 
In this circumstance, our <logical test> is POP_EDU=0, our <value if true> should be 0, and our <value if 
false> is HAS_MAST/POP_EDU. Your IF statement should be the following. Place it in the first row 
beneath our PERC_MAST header. 
 

=IF(C2=0,0,(H2/C2)*100) 
 

If you wrote your statement properly, you will see the following: 

 
 
 
Double click the little green box in the lower right corner to fill the rest of the field with the correct 
values for each row.  
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4.  The cells in Excel do not contain values at this point, but rather 

contain the IF statement we just wrote.  to make the calculations 
permanent , copy and paste values in the newly calculated field. To do 
this, select all the values in the column, right-click and copy them, 
then right-click on the selected area and click Paste Values. This will 
change the value of each cell to be the proper numeric value. 

 
When complete, your Excel file will contain a new field that has the 
percentage of individuals that possess Masters Degrees called PERC_MAST 
and will look like the following:  
 

 
 
 
 
d. Change your Sheet Name 
 
The final step is to change the sheet name in Excel to something that makes sense. When you import an 
Excel spreadsheet to ArcGIS, you do not import the entire workbook, rather you import individual sheets 
of data. We only have one sheet in this dataset. Find the name of it at the bottom of the Excel interface.  
Change the name to Education_2017. Save your file.  
 
 
 

 
 
 
For some pointers on table formatting from ESRI, check out the following link. 
http://desktop.arcgis.com/en/arcmap/10.3/manage-data/tables/formatting-a-table-in-microsoft-excel-
for-use-in-arcgis.htm 
 
Now let’s make a map! Close Microsoft Excel so that ArcGIS can read our new file.  
 
OBJECTIVE 3: MAKE A MAP FROM AN EXCEL SPREADSHEET 

Double-click here to 
fill the field 
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After the Excel file preparation, the spreadsheet is now ready to join to a Census Tract file and be 
mapped. To complete Objective 3, we are going to make a map. Our final output for this map is going to 
show Educational Attainment by Census Tract for all tracts that fall within the Lower Charles River 
Watershed in the metropolitan Boston area.  
 
In the next steps, we will add our data, join the spreadsheet to the geometry file, extract only the tracts 
in the geometry file that fall within the Lower Charles River Watershed, and symbolize our data. 
 
1. Add Data and Join Tables 
 
1. Open ArcMap and create a new Blank Map.  Then add the following files. 
 

• ACS_boston_2019_tracts_final.shp – These represent ACS Census Tract boundaries in Norfolk, 
Suffolk, and Middlesex Counties.  

 
• The sheet “Education_2017” from the Excel file Education_ACS2017.xls – This is the Excel file 

with the educational attainment data that we downloaded from Social Explorer. Add the 
Education_2017 sheet that contains the data. 

 
 

2. In order to join two tables, the columns we are joining on must be the same data type. For 
example, we can’t join a text column to a number column, so we have to make sure that both 
are NUMBER columns. We are going to perform our table join based on two fields, Geo_FIPS 
and GEOID, so we need to ensure that the column data type is the same for both. Check the 
properties of each column to see this.  
 

3. Open the Attribute Tables for both Education_2017_converted.dbf and  
ACS_boston_2019_tracts_final.shp files. Right click the header of the respective fields (GEOID 
and Geo_FIPS) to view Properties. If they match, we can skip this…but they don’t! Geo_FIPS is 
numeric (double) and GEOID is a text (string). So, what we need to do is create a new field in the 
ACS_boston_2019_tracts_final.shp with Double data type, call it a new name (GEOID_NUM) 
and populate it with the data in GEOID.  

 
 
a.   To create a new filed in the shapefile, open the attribute table for ACS_boston_2019_tracts_final.shp. 

Click on the Table Options button in the upper left corner of the table. Select Add Field. 
 
Select Add Field  from Table Options 
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b. Create a new field, call it GEOID_NUM, and give it type 

Double.  
 

c. Use the Field Calculator to populate our new field. Set the 
GEOID_NUM field to be equal to the GEOID field, and click 
OK. Our field will populate. Close the attribute. We will 
perform our join next on the Education_2017_converted 
layer. 

 

 

 
 
 
 
 
 
 
 
 
 

15



 
 

 
4. Using the methods we learned to join tables in the 
exercises from last week, join the 
Education_2017_converted data to 
ACS_boston_2019_tracts_final.shp. (That means you 
right click on ACS_boston_2019_tracts_final.shp 
to perform the join.) Perform the join on GEOID_NUM 
from the Tracts shapefile, choose the 
Education_2017_converted table as the table to join to 
the layer, and base the join on the Geo_FIPS field. Click 
validate join to see if there are any errors. Click OK to 
complete the join. 
 
NOTE: You can only join fields of the same data type. 
(i.e. Number to Number, Text to Text). This is a 
common cause of errors when joining Census data to 
geometry (i.e. attempting to join a Number field to a 
Text field). If this does not work, see the previous step 
once more.  
 
 
Open the attribute table to see if the join worked. You 
should see your spreadsheet appended to the 
shapefile now. 
 
 
3. Export a copy of the tracts file with the joined data. 
Right click on the ACS_boston_2019_tracts_final.shp layer and navigate to Data -> Export Data. Save this 
as Tracts_Education_2017.shp in your working space for the week. 
 
 
 
 
 
 
 
 
Add the Tracts_Education_2016.shp file that you just created to your map document.  Your file should 
look something like this. 

 
 
 

Set the parameters and join 
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2. Extract Data for the Lower Charles River Watershed 
 
The data currently shows all tracts in all of Middlesex, Norfolk, and Suffolk Counties. These counties 
make up a large portion of the Boston Metropolitan Area, and we don’t need to show all of the tracts, 
only the ones that are in the Lower Charles River Watershed. To do this, we are going to extract the 
tracts that fall within the Lower Charles River Watershed using a shapefile for the Watershed. There are 
a couple of methods to complete this. 
 
1. Add the Watershed shapefile 
 
 
The first step is to add the Charles River Watershed shapefile provided in our weekly materials. Go to 
Add Data and navigate to your workspace. Click and add CharlesRiverWatershed_PRJ.shp to your map 
document. 
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2. Extract Tracts that Fall within the Watershed 
 
Extracting the tracts that are within the watershed can 
be accomplished in a number of ways. We are going to 
use the Select by Location tool and extract all the 
tracts that intersect (are contained by or touch the 
boundary of) the Lower Charles River Watershed. The 
Select by Location tool is in the Selection dropdown 
menu at the top of your screen. 

 
 
The Select by Location dialog allows you to select 
features in a layer according to a spatial relationship 
with another layer. Following through the dialog, set 
the Selection method to ‘select features from’ and 
then the target layer to be Tracts_Education_2017. 
 
The source layer is the basis of selection. Set this to be 
the Lower Charles River Watershed layer. 
 
The selection method offers many options, we 
encourage you to explore them. For this, set the 
selection method to ‘intersect the source layer 
feature’. Do not enter a search distance. 

 
In simple terms, this tells the software to select all tracts from the tracts layer that intersect the 
watershed layer. 
 
Your selection should look like the 
following.  
 
 
Export this as its own shapefile. 
With the Tracts selected, right click 
on the Tracts_Education_2017 layer 
and export your data. Make sure you 
export the Selected features. Save it 
as Watershed_Tracts_Edu_2017.shp 
in your workspace.  
 
Add it to your map when the export 
is completed. Turn off your other 
layers and make sure all selections 
are cleared. 
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Turn off all layers except for 
Watershed_Tracts_Edu_2017.shp. Your map 
should currently look like this. Colors may vary.  
 
Hint: Right click on Watershed_Tracts_Edu_2017 
and select Zoom to Layer. Toggle off the visibility 
of the other layers. 
 
 
 
 

 
 
 
 3. Symbolize your Data   
 
Using the methods we have learned in previous weeks, symbolize 
the map to make a choropleth map showing some attributes. 
Let’s explore the data to make sure everything looks okay. First, 
we can check if tracts with zero population actually make sense. 
 
1. Find tracts with zero population 
 
One good way to check the accuracy of the data is see where zero 
values are found. Zero values can expose where parks or other 
non-residential features are located. Open the attribute table for 
Watershed_Tracts_Edu_2017 and Select by Attributes from the 
Table Options menu.  Set our Selection query to read “POP_EDU” 
= 0. 
 
 
Your data should now look like the following. Tracts with zero 
population are highlighted. Notice that this appears to be correct. 
Tracts with zero population include the Boston Common, Arnold 
Arboretum, parks in South Boston, and the Esplanade along the 
Charles River.  
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2. Normalize on the Fly 
 
Clear our selection by going to Selection -> Clear Selected Features. Use the button to do so. Now 
let’s make a Population map showing percentage of individuals that have less than a High School degree.  
 
Right-click the layer and go to Properties -> Symbology to make a map that shows the percentage of 
the population 25 years and older (POP_EDU) that have less than a high school degree (LESS_HS). Give 
it five classes, and use a natural breaks classification.  
 
The Value field ought to have LESS_HS and you ought to normalize your data using the POP_EDU field.  
 

 
 
 
Notice that there are certain locations that are not filled in. These are the same tracts that have zero 
population. These are often parks or non-residential areas. When you normalize, you are really taking 
the number of individuals with no high school diploma (LESS_HS) and dividing it by the total population 
of persons 25 and over (POP_EDU). GIS is doing the division on the fly and removing those parcels 
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where there are zeros in the denominator. GIS automatically will remove those from the visualization. 
To make this a permanent change, we have to make a new field in our database that contains our 
normalized data. 
 
3. Create a new field to hold a normalized value 
 
Earlier in this exercise, we added a field in Excel to hold the 
normalized value of Master’s Degree holders. Then we added a 
field to our DBF. Let’s do this again in GIS with a Shapefile, but this 
time, find the percentage of individuals who have not received a 
high school diploma, as opposed to those individuals who possess a 
Master’s level degree.  
 
First make sure nothing is selected by going to Selection > Clear 
Selected Features. Then open the attribute table and click on the 
Options tab. Navigate to Add Field. 
 

Call the field P_LESSHS and make it data type Double. Double allows 
the field to contain decimal points. Leave Precision and Scale as the 
defaults. Click OK. 
 
Scroll over in the attribute table to see the new blank field. 
Next we want to calculate the values in the field. We are going to fill 
the field with the value of LESS_HS/POP_EDU. In order to ensure we 
don’t divide where the denominator is 0, we need to perform the 
calculation where POP_EDU is not equal to 0. Recall we addressed this 
issue in Excel by using an IF statement. 
 

 
 

In the Attribute Table, go to Table Options -> Select by Attributes, 
and enter “POP_EDU” <> 0 (the <> sign means NOT EQUAL TO). Click 
Apply. When you use Field Calculator, it will only run the calculation 
on features you have selected, meaning our calculator will only run 
on census tracts that have POP_EDU not equal to zero. 
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Highlight the P_LESSHS field, right click, and select Field Calculator. A dialog will appear asking if you 
want to calculate outside of an edit session. Click OK. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

The Field Calculator dialog will open. In the calculation window, type ([LESS_HS]/[POP_EDU]) * 100. This 
will populate the P_LESSHS field with a value representing the percentage of people 25 years and older 
with less than a high school degree. Click OK. 
 

 
Be sure to clear selected features. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
4. Symbolize using the Normalized Value 
 
Now we can symbolize our map based on P_LESSHS. Taking a look at the field will show the percentage 
of people 25 years and older with less than a high school degree for each census tract. Right-click the 
layer and go to Properties > Symbology to make a map that shows the percent of people that have less 
then a high school degree. I am going to make mine by giving myself five categories and use the Jenks 
Natural Breaks classification scheme. Using this scheme gives unrounded number breaks for each class, 
so adjust your classification breaks to be 5, 10, 20, 30, and leave the last value as is. Your symbolized 
map should look like the following.  
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Alternative Classification Strategy: You will notice if you 
do the above classification and symbolization, you lose 
the zero values into a class. These are often important 
to call out in our datasets, as they represent parks, 
cemeteries, ponds, or another anomalous areas. First, 
change our classification to six classes. Because we set 
the map to have five classifications above, we can keep 
the breaks the same (5, 10, 20, and 30), but lets change 
our symbology to have six classifications. Make the 
break for the first class zero. This will add a zero 
classification to our dataset that will specifically call out 
all tracts with percentage value zero. 
 
 

With regards to color, give the 0 value a white, and adjust your ramp. Your map, with the alternative 
classification scheme, will look like the following: 
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5. Add Context and Supplemental Data 
 
We have a symbolized map of the tracts in the Lower Charles River Watershed, but as we all know, the 
Boston area does not float in a vacuum. Add some additional data like the watershed boundary, water 
features, town boundaries, and major highways to add context to your map. 
 
a. Add Data 
 
Add the following files to your map: 
 BOUNDARY_POLY_PRJ – City Boundaries 
 EOTMAJROADS_RTE_MAJOR_PRJ – Major Roads and Highways 
 MassHydro_PRJ – Waterbodies 
 boston_openspace_prj - Parks 
 
b. Organize your Table of Contents and Symbolize 
 
Just as we have done in previous maps, organize the layers in the Table of Contents so that the tracts 
layer is on the bottom, and the boundaries and roads are on the top. For the watershed boundary and 
town boundaries, set the polygon fill to be none. This will allow the tract data to be visible. Your map 
should look like the following. Don’t worry about the legend yet, we will add it later. Save your map as 
Boston_Education_ACS2017.mxd to your weekly workspace. 

 
 

 

24



 
 
 
OBJECTIVE 4: MAKE A CHART FROM GIS DATA IN EXCEL 
 
We have been working with the Charles River Watershed Association on some statistics for an 
environmental education center. The reports would like them to include a spread of the education 
levels throughout the watershed. Now that we have selected all the data for the watershed we can use 
graphics (such as bar charts) for them to insert into their report. It is a lot easier to make these in Excel – 
so we will export our data and open it in Excel.  
 
a. Export the Attribute Data of ‘Watershed_Tracts_Edu_2017.shp’ to DBF 
 
Open the Attribute table for Watershed_Tracts_Edu_2017. Go to Table Options > Export.  Save the 
attribute table with the name ‘education_charlesRiver.dbf’ and save it as type ‘dBASE Table’. Do not add 
the table to your map. If you do, ArcGIS will lock it and it will not open elsewhere. We are going to 
open it in Excel. 
 
 
 
 
 
 
 
b. To open the DBF file in Excel, you must open Excel first. Remember when opening a DBF file in Excel 
you need to Go to File >Open. Then navigate to the folder where you saved your DBF. In order to see 
your DBF as a possible file to open you need to choose “All Files” next to the file name.  
 

d. We will make a bar chart that displays educational attainment in the Lower Charles River 
Watershed. Scroll to the right in the spreadsheet to find the educational attainment data.  
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HINT: Freeze the top row so you can always see your column headers. You can do this by going 
to View > Freeze Panes > “Freeze Top Row” 

 
1. First, sum each column to find the total population, total population with less than a high school 

diploma, total population with a high school diploma, etc.  To do this, at the bottom of the data, 
in the POP_EDU column, enter “=SUM(…)” and then highlight all of the data in the column. Close 
the parenthesis, and hit enter. This will give you a total for the column, and the total number of 
persons age 25 or over in tracts that intersect the Lower Charles River Watershed. Repeat this 
for each column. 

 

 
 
2. Create a new sheet in your workbook and copy these totals into the new sheet. Highlight the cells you 
want, (the top row, and our calculations), right-click and copy, then click on the new sheet. Right-click 
and Paste Values. Do the same with your heading names. The new sheet should look like this (the 
numbers might be different). Delete P_LESSHS and PERC_MAST, we do not need it for this chart, nor 
do the values make sense. 
 

 

  
 
 

3. Select the data and choose Copy. Click on an empty cell below the data and choose Paste > Transpose. 
Your new sheet should now look like the following. Transposing our data makes it easier to make a 
chart. 

 
 

4. Now we need to make a percent field. Highlight the first empty cell to the right of the LESS THAN 
HIGH SCHOOL DEGREE and enter the formula “=(B5/$B$4)”. This will calculate your percentage of the 
population 25 years and older. Drag the formula down so that it is applied to all the cells. (The dollar 
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signs in the denominator means  that the data will always reference the total population when you 
drag the data down.) 
 

 

 
 

 
5. Rename the fields to create headings that make better sense. These should be descriptive for the 
reader. 
 
 POP_EDU = POPULATION 25 AND OVER 

LESS_HS = LESS THAN HIGH SCHOOL DEGREE 
 MORE_HS = MORE THAN HIGH SCHOOL DEGREE 
 SOME_COL = SOME COLLEGE 
 HAS_BA = HAS BACHELORS DEGREE 
 HAS_MAST = HAS MASTERS DEGREE 
 HAS_PROF = HAS PROFESSIONAL DEGREE 
 HAS_PHD= HAS PHD 
 
Following these changes, the table should look like the following. 
 

  
 

6. With your Ctrl key pressed down (or option-control on an Apple keyboard), highlight the fields you 
want to make the table with. When you  highlight the fields, it will look like below. 
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7. Click on the Insert tab and select the Column or Bar Chart option in the Charts section. Choose 2-D 
Stacked Bar. You should get a chart like the following. 

 
 

 
 

Adjust the formatting to improve your chart, remember that labeling your chart is very important. Give 
the name of the title to something that logically represents the chart. Helping the reader interpret your 
chart is important, if numbers are not visible or legible, the teaching staff will not be able to grade your 
assignment and your potential clients will not be able to understand the information you are presenting.  
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To access formatting options, click on the various components of your 
chart. 
 
To label the bottom axis, click on the bottom axis, then go to Format Axis. 
Axis Options -> Number -> Category -> Percentage. This will change the 
bottom axis labels to a percentage value. 
 
To label the individual bars, right-click on the bars in the chart and go to 
Add Data Labels. To format these, click again once you have added data 
labels and navigate to Format Data Labels… Here in Label Options, you will 
see a Number option. Set the category to Percentage, and use 1 decimal 
place. 
 
To change the title, click on the Chart Title and edit the text. 
 
 
 
 

 
 
Your final chart should look something like the following. This is a very basic bar chart. While effective, 
we encourage you to be creative and explore the various chart settings.  
 

   
 
 

 

OBJECTIVE 5: CREATE A LAYOUT WITH MULTIPLE MAPS 

In the following part of this exercise, we are going to create two maps side by side that show the 
variables we created. One map will show the Percentage of Individuals with a Masters Degree, which we 
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created in Excel, and the other map will show the Percentage of Individuals without a High School 
diploma, which we created in ArcGIS. The practice of this is the same as creating a locator map. 
 
1. Return to ArcMap and open Boston_Education_2017_ACS.mxd (the map document we have been 
working in). 
 
2. In the bottom of the map document, toggle from Data View to Layout View to see our page layout. 
Remember we have done this to compose maps in previous weeks. 
 

 
 
 
 
 

3. In File -> Page and Print Setup, set the orientation to be Landscape. Click OK. We are going to lay our 
two maps side by side. 
 
4. Adjust the location of your data frame. If you right click on the data frame and enter the Data Frame 
Properties, you can be precise with your layout size and position. When adjusting size and position 
settings, remember you are working on an 8.5 inch by 11-inch page in Landscape orientation. The origin 
in your measurements is in the lower left corner, 0 inches, 0 inches. In the screenshot below, I set the 
anchor to be in the lower left, then set a left margin at .35 inches, and a bottom margin at 1 inch. The 
size of the data frame is set to 5 inches by 5 inches. Click OK.  
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Your map will look like the following. You might need to zoom into the Boston area to adjust the extent 
of area shown in your map. 
 

 

 
 
5. Add a second data frame by going to Insert -> Data Frame. A new data frame will appear in the center 
of your view. 
 
6. Adjust the location of your new data frame. Right click on the data frame and enter the Data Frame 
Properties. Again, when adjusting size and position settings, remember you are working on an 8.5 inch 
by 11 inch page in Landscape orientation. The origin in your measurements is in the lower left corner, 0 
inches, 0 inches. In the screenshot below, I set the anchor to be in the lower right, then set a left margin 
at .35 inches by using 10.65 inches (11 inches minus .35 inches), and a bottom margin at 1 inch. The size 
of the data frame is set to 5 inches by 5 inches. Click OK. 
 

 
 

Your layout should now look like the following: 
 

Figure 56. Set the parameters 
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7. Rename the Data Frames. Click on the names of the data frames (in the ‘Table of Contents’ ) and edit 
them. Call the left data frame “Less HS” and the right data frame “Has Masters”. 
 
8. We need data in our new data frame. This is easy to do, drag the layers in ‘Less HS’ to ‘Has Masters’. It 
will create a copy for you. You will likely need to zoom into Boston to see the data clearly. Note, I’m also 
going to turn off my town boundaries and roads. 
 
At this point, your map will look like the following. 
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9. The maps both show the same variables. Re-symbolize the right map to be symbolized based on the 
normalized Master’s Degree data we created in Excel. Right click on Watershed_Tracts_Edu_2016 in the 
Has Masters data frame and go to Properties -> Symbolize. Remember the field containing our data is 
called PERC_MAST. Set the colors and breaks to be the same as the other map. Symbolized, your map 
will look like the following. 
 

 
10. When comparing two maps, it is important to compare apples to apples. This means making the 
scale the same on each map, and the display extent the same for each map. Let’s set this up.  
  
 a. Right click on ‘Less HS’ in ‘Table of Contents’ to activate the ‘Less HS’ data frame. 
 
 b. Set the display extent for ‘Less HS’ by right-clicking on ‘Watershed_Tracts_Edu_2017’ and 
selecting zoom to layer. The map will zoom to the extent of your layer. 
 
 c. Set the map scale. The map is not completely centered. At the top of your map document is 
the map scale control. Change this for ‘Less HS’ to 1:305,000. 
 

 
 
  

d. Click on ‘Has Masters’ (in  ‘Layout View’ , right frame) to activate the ‘Has Masters’ data 
frame. 
 

33



e. We are going to set the extent of this data frame to match the LESS HS 
frame. Right click and go to Properties. Click on Data Frame, and set Extent 
to be Other Data Frame. Here select LESS HS, and set the margin to be 
100%. 
 
 
 
 
 
 
 
 
 

 
 
Completing these steps, your map document should look like the following. 

 
 

11. Add a Legend. Let’s right click on our Watershed_Tracts_Edu_2016 layer, go to Properties > 
Symbology Under labels, edit text to contain the following breaks: 
 
 0 
 0.1-5% 
 5.01-10% 
10.1-20% 
20.1-30% 
More than 30% 
 
This will allow us to create only one legend for both of our maps. One legend won’t always be an option 
because datasets can be very different, but it does in this circumstance. 
 
Because we used the same scale for each map, we can add one legend that will work for both maps. Go 
to Insert -> Legend. Symbolize the Legend based upon the Watershed_Tracts_Edu_2017 layer. Using the 
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legend design skills you have learned in the first couple weeks of class, add the legend in a nice location 
at the bottom of your map.  
 
If you had differing scales and legends, you can right click the data frame names and scroll down to 
activate in order to ensure you are creating a legend for the appropriate data frame.  
 
12. Add the other map elements to complete your map. Click on the map to activate its respective data 
frame, then for each, add an informative title, scale bar, and north arrow, and in your layout, put 
information on date, author, and data source. Use the map design skills you learned in the first two 
weeks of class. Your final output will vary based on design and preference. My final map looked like the 
following. Note the differences between the two datasets!  
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