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11.205 – Intro to Spatial Analysis – Fall 2019 

[OCW Users: The following document refers to various online resources (Stellar, Athena, and CRON) that 
are not available to users outside MIT.] 

Week 0 Objectives - 

I. Learn about the Athena and MIT Computing.
II. Organization is #1 in GIS – Map it!
III. Make your first map.
IV. Learn about personal websites at MIT
V. Create a GIS Portfolio website in your MIT Athena space

II. Opening ArcGIS for the First Time!! (Let’s get organized)

GIS software is a database tool that enables using, managing, visualizing, and analyzing large geographic 
datasets. The datasets, for example, might contain every single road centerline in the state of 
Massachusetts, or contain every single census tract in the United States. As you can imagine, these files 
are big, so knowing where you store your data and save your analysis results so they don’t get lost when 
using GIS is very important. It is also important for the speed of the software. 

We want to start by going over some key concepts to help you understand and navigate the GIS 
environment. This is meant to serve as a reference guide with six principles, conveniently abbreviated: 
“M.A.P.I.T.” Familiarize yourself with these steps, noting that they’re slightly different for Arc and Q! Use 
them as a checklist every time you start a GIS project: 

Make sure the ‘Home Folder’ and ‘Default Geodatabase’ are not on cloud.

Activate ‘Relative Pathnames’ for your ArcGIS files.

Place files in the right place to keep your ‘Workspace’ organized and efficient

Identify and clean-up unused ‘Folder Connections’

Turn ‘Hidden Files’ visible and show ‘File Extensions’

In this course, we will be using ArcMap and QGIS as our main software products. ArcMap only runs on 
the Windows environment, so in CRON labs you should log-in to Windows to use ArcMap. QGIS runs in 
Windows and Mac. 

1. Make sure the ‘Home Folder’ and ‘Default Geodatabase’ are specified correctly.

ArcGIS is database software, meaning it requires a connection to backend database to properly function. 
ArcGIS uses a format called “Geodatabase”. The Geodatabase format was created by Esri (the makers of 
ArcGIS) to store and manage geographic datasets in a fast, searchable manner. It is proprietary to Esri, 
meaning it can only be used with ArcGIS and other Esri software. Geodatabases can be very large. 
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When you launch ArcGIS, it looks for a designated home folder in which it will store data and temporary 
files. ArcGIS is dependent on a Home Folder that is set in the computer registry. By default, ArcGIS 
places the home folder in the user application data folder, which in the Athena network resides in your 
personal locker. The home folder contains your default geodatabase and custom toolboxes. It is 
important that this home folder is NOT on the network, but instead living on the machine you are 
working on. 

When you login to Windows on a public cluster machine, a script runs automatically that sets your 
home folder to C:\temp and automatically creates the default geodatabase (“default.gdb”) there. If 
the home folder is over the network, it can be one cause of ArcMap operating slowly and crashing, and 
one of the ways that you can accidentally fill up and crash your Athena lockers. Therefore, this home 
folder (a.k.a. the default data storage location) should be located on your local machine in a location 
called ‘temp’. Following are instructions for how to change the location of the geodatabase from your 
Athena locker to your C:\temp folder on your local machine. 

Let’s make sure CRON’s automatic script configured ArcMap properly. 
a. Open ArcMap.
b. As the program starts, it will provide a New Document window in which you can set up a new

map project. In the Choose a Template prompt on the left side, select New Maps -> My
Templates -> Blank Map.

c. Right below that, in Default geodatabase for this map, confirm that it lists the Default.gdb file
located in C:\temp. In some cases, the default geodatabase might be in
YourName\Documents\ArcGIS\Default.gdb. This is OK too.

d. Click OK to open up ArcMap.

IMPORTANT NOTE: This is a temporary default database ArcGIS creates when it starts. Think of it like an 
untitled word document when you open Microsoft word the first time. This default database  will be 
saved to the local CRON computer which you will not have access to from any other CRON computer; 
local files are often deleted off CRON computers – so it’s NOT WISE to save your files locally (c:/temp), 
but its ok to do today since you do not have your external hard drive yet.   

When you are using ArcGIS, you will be moving between different computers and will not have access to 
this computer so when saving files, make sure you save them to your external hard drive. 
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2. Activate ‘Relative Pathnames’ for your ArcGIS files

When moving from computer to computer, your file paths will change on a regular basis.  What’s a file 
path you ask? 

A ‘file path’ is the direction to the directory in which your data is stored. i.e. C:/sarahfiles or E:/ericfiles. 
The C:/ and the E:/ are Windows hard drives. Your external hard drive will have its own path when its 
plugged into the computer. Sometimes it will be E:/ , F:/, G:/ it’s hard to predict. Hard coding of drive 
letters causes all kinds of problems in ArcGIS so we want to make sure that ArcGIS does not save the 
drive letter, just saves everything after the drive letter - this is called saving relative path names. 

When you move between computers, each computer has different drives and settings, so your path will 
often change (C:/, E:/, F:/). If relative path names are not set in ArcGIS, you will ‘break’ the link between 
the map document and your data files, and your data will not show in your map project. ArcGIS allows 
us to store relative path names, and when stored, it will attempt to fix these broken links.  

a. After starting a new blank map go to File > Map Document Properties
b. Check the box that says “Store relative filenames to data sources”
c. Click OK and save your file.

3. Place files in the right place to keep your ‘Workspace’ organized and efficient

It is good practice to save all of your files in the same root directory, SarahGISClass for example. Then 
add folders under that. You will have a folder for each week. Week1, Week 2, and then typically  ‘data’ , 
‘projects’ , ‘graphics’ , ‘shp’ to help you organize the different types of files you have. Staying organized 
helps you from losing data. GIS demands order, and if your files are organized haphazardly, both ArcGIS 
and QGIS will have a hard time finding your data. 

ArcGIS is unique in that in order to add data, or see and modify folders in ArcGIS Catalog, you must 
‘Connect’ your map document to the directory in which your data is stored. Unlike other programs, you 
cannot use Windows Explorer to locate and find files. Instructions to connect to a folder are as follows: 
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a. Connect to a Folder

1. Open ArcCatalog. The icon should be on your

toolbar and looks like the following
2. In Catalog, select ‘Connect to Folder’.
3. Navigate to your working directory, click OK.

By default, ArcMap will save the locations of folders you have opened to retrieve or view data once you 
connect to them. Although intended to be a convenience to the user, these connections can slow down 
the program, especially if they are located on networked or unavailable drives (such as portable hard 
drives). Therefore, it is a good practice to keep these folder connections to a minimum. In addition, if 
you are an advanced user and connect to remote Database Servers, this same principle applies. We 
want to remove all folder connections we are not using to prevent ArcGIS from looking for something 
that is not there. 

b. Disconnect from a Folder
If you need to disconnect from a folder, you can do that easily. This is for future use as you probably
don’t have any folders connected now.

1. In the “Catalog” window find the section labeled “Folder Connections”
2. Right click on all folders, except for C:\ and C:\temp, and click “Disconnect Folder” (remember these
file paths are only shortcuts).

4. Identify and clean up unused ‘Folder Connections’

Working in ArcGIS for any length of time can very easily create an overwhelming cacophony of files. We 
strongly recommend creating well-organized workspaces and Map Documents. Organize your data files 
and map documents into folders that will help you keep track of where files and documents are. You 
should also keep your map documents organized. Organize your ArcMap Table of Contents by right- 
clicking on “Layers” and creating “Group Layers,” as shown below. You don’t need to do anything at this 
step, just keep your stuff organized! 
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You can close ArcMap, the goal for this week is simply to set up your environment so you can be off and 
running next week without a hitch. We’ll save our first map for next week! 

5. Turn on ‘Hidden Files’ and show ‘File Extensions’.

One last important item to get set up in your environment is to change your system settings so that you 
can see hidden files and file extensions. Operating systems do this by default to simplify the experience 
for the average user, but, unfortunately, it hides some files that GIS makes use of. 

On Windows… 

In the Start menu, type File Explorer Options. Select File Explorer 
Options from the list of programs that appears. The File Explorer 
Options dialog will open. 

Click on the View tab, this is where we can make two changes to 
show Windows displays our files. 
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Figure 6. Customize File Explorer options 

In Advanced Settings, find and check Show 
hidden files, folders, and drives, and then find 
and uncheck Hide extensions for known file types 

Click OK. You are ready to go! 

Using macOS… 

While Arc only runs on Windows, it may still be useful to you to know how to do the same thing on 
macOS.  

To show hidden files, simply navigate to any Finder window and press CMD + Shift + . . Do this in your 
home folder (like in the screen shot below) to see some big changes! 

To see file extensions, while a Finder window is active, navigate to the Finder dropdown in the top-left, 
select ‘preferences’ and then ensure that ‘Show all filename extensions’ is on. 
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See? M.A.P.I.T.! 

III. Making Your First Map:

The main purpose of this first class is to get you familiar with the MIT computing environment, but to 
get your first test drive of GIS.  

Step 1 : Download Zip File  
Please download this week’s Zip file from the class Stellar page. You will notice we follow our own rules 
and the files are orderly.  

There should be the following folder: 

Data – where all your data for this weeks exercise is.  
Documents – where the exercises for this week are located 
Graphics – exports of maps  
Projects – where the main map projects exist.  
www- files for the website we will make 

Included in these files is a map I made of Airbnb prevalence in Cambridge and Somerville, as well as the 
Charlestown neighborhood of Boston which joins Cambridge and Somerville on the north side of the 
Charles river.  

Go to Start>All Programs>ArcGIS> ArcMap 10.7 

Open w0_arc.mxd - File> Open> w0_arc.mxd  

The following should appear on your screen.  
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This is a map of the ratio of the total number of Airbnb units listed between 2014 and 2019 and the total 
number of housing units – basically, a map of Airbnb prevalence in Cambridge, Somerville, and 
Charlestown. 

This is a very common map style, called a graduated symbol or choropleth map. Basically, it’s a map 
where the area in question is used to symbolize one of its attributes (in other words, it’s made darker 
for higher levels of incidence, lighter for lower, etc.). 

Let’s see how the file is structured! 

Go to File>Map Document properties. 

Notice that some of the best practices of GIS we already mentioned are included here. The geodatabase 
(default.gdb) is on the c:\temp and the project stores relative paths. See circled below.  
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Go to File>Export Map to make a jpeg of your map to post online with some discussion of Airbnb in 
Camberville. I called mine airbnb_map.png and made the file type PNG. See below.  

Objective IV. 

When doing spatial analysis and mapping, it is often useful to know how to build and work with 
websites. Many maps are created for display and collaboration on the web. In this class, the exercises 
and projects you complete will include many visual deliverables, such as maps, charts, and graphs. We 
would like you, for each assignment, to submit a copy to the submission portal on the class Stellar page, 
and then also place a copy on your website. This website can serve as a portfolio of the work you 
complete in this class. You can customize it and make it more feature-rich as you become more 
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comfortable with web design. We encourage you to use it as a portfolio of your work during your time 
here in DUSP! 

Learning the MIT Computing Ecosystem 

As you may recall from the GIS Cookbook or the orientation session, working on the computers in the 
labs around campus is a bit different than working on your own personal machine. All of the MIT-owned 
(lab) computers are connected on a network called “Athena.”  

Athena essentially a large distributed computing system, and you are given space that is accessible 
over a network connection and to the World Wide Web. Meaning you can use it to make Websites. 

Athena knows who you are through your Kerberos authentication. You might ask yourself “how do we 
authenticate?” There are different answers to this depending on the application. When you log into a 
CRON computer, you’re actually authenticating against the Kerberos credentialing system, which is why 
you have access to Athena and network resources on public CRON computers. This is managed using 
‘Tokens’. 

When you log into a CRON machine your tokens should already be installed – entering your username 
and password on log-in does that for you. This means that you have access to AFS via the ‘I:’ drive on 
Windows and what are called ‘symlinked’ folders on Mac.  

Note for Windows users: On Windows, the AFS ‘I:’ drive doesn’t map correctly. If this is the case, simply 
restart your machine and it should work.  

Web Certificates 

On CRON machines, web certificates only travel from machine to machine within the Firefox web 
browser. This makes a strong case for using Firefox as your browser of choice on CRON machines. 

Web certificates are used to securely authenticate your use of MIT web services. The following steps will 
help you install a Kerberos certificate in your browser – again, use Firefox! - if for some reason you are 
missing one; at this point, you should have done this on your own machine as well.   

1. Go to https://ca.mit.edu/ca/ and fill out the identifying information. Click “Next”.

https://ca.mit.edu/ca/
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2. On the next screen, use the default settings to finish the certificate process. Click “Next”
3. Close your internet browser.

The network allows access to on-campus computers, authenticates campus-wide licenses and 
applications, and provides each user with a small amount of storage space in something called a ‘locker.’ 
Lockers can store documents and files that you can access wherever you log in. 

The benefits of Athena are many. For starters, you can create a profile that will configure your 
computing environment to start up in a consistent manner no matter what computer you sign on to, 
and you can save documents to the network that you can then open on any computer. You can use it to 
make your first Website. 

Because your files actually live on the Athena computer, which is only available over the internet, some 
large files take a while to download. This is the case for GIS files. WE NEVER WANT TO USE GIS FILES 
OVER ATHENA, it’s just too slow. Plus, the large file size will eat up modest 8 GB of storage space you’re 
allocated on AFS. 

STORING FILES : 

Get an external hard drive! The solution to this is to make sure the datasets you are using are not 
stored on the network, but instead on a local drive or a thumb/external hard drive. We recommend you 
get at least 120GB for your time at DUSP; it’s also worth getting an SSD (solid state drive) if you can 
spare the change. 

On CRON macOS boot… 

If you must store files on the computer, use ‘Desktop’ or ‘Documents’ – other folders will be wiped 
every 60 days! 
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On CRON Windows Boot… 

Do not use the C: Drive or any included folders (Desktop, My Documents, etc.) for storage – these are 
automatically deleted! Use the I: drive or an external hard drive!!! 

Publishing a Simple Website at MIT 

Specific folders in your Athena space can hold webpages that can be viewed on the internet. Two of 
these are the ‘www’ folder and ‘Public’ folder. The ‘www’ folder is configured to run as a server for your 
webpages, and the Public folder is for sharing files. 

Let’s look at our Athena space using a tool available to all MIT users, SecureFX. 

Go to Start>All Programs>SecureFX  

The following dialog will appear.  

Let’s connect to your AFS space, where you have a folder openly available to the web. 

In those hostname field type : athena.dialup.mit.edu 
username : your user name, mine is sew, put your Athena account name here. 

It will ask for your Athena password. Add that.  
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The following will appear: it is showing me all my files on Athena. You can see I have a lot. Anything I put 
in the www folder will automatically be stored on the web.  

Let’s try to make our Image available to the world.  

Drag and drop the image you just created into the www folder. Mine was called Springfield. See below. 

Now navigate to the file on the web.  

Go to the following web address in your web browser. 

http://mit.edu/(yourusername)/www/ 

For example, mine is: 
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http://mit.edu/sew/www/ 

Then at the end, add the name of your file. I called mine: 

airbnb_map.png 

So, the web address is: 

http://mit.edu/sew/www/airbnb_map.png 

It should look like the image below. This is just showing the image online, now let’s make an html file so 
we can describe what is going on.  

Introducing Text Editors 

In the next few steps, you are going to make a webpage! Using text editor software is helpful; most 
modern text editors include Syntax Highlighting, which will help your eye navigate your code as it gets 
more and more elaborate. You can use whatever text editor you want, but we recommend Atom, which 
is installed on all CRON machines. Using Finder on the CRON machines, open Atom. This is a plain text 
editor you can write some code for a website. 

If you are on your laptop, you can install the text editor of your choice. Again, we recommend Atom, 
but there are many other popular editors, including Sublime Text, Brackets, Notepad++, BBEdit, or (for 
the particularly adventurous) VIM and EMACS. You can download and install Atom for free at 
https://atom.io/. 

http://mit.edu/sew/www/
https://atom.io/
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Important note: The Word processors you may be accustomed to (Microsoft Word, Wordpad, 
LibreOffice Writer, Apple TextEdit, Pages) will NOT work for this. These are designed for writing and 
formatting print documents. It adds a bunch of extra information to your file that will confuse a web 
browser. 

Create a Simple HTML Webpage 

NOTE: If you are on a laptop, you will need to connect to AFS using FTP. Fortunately, this is 
easy! See the “AFS Connection Instructions for Laptops” document on Stellar. 

1. Open Atom, and click on the ‘’untitled’ tab. Click on File > Save As > create a new file and save it in
your ‘www’ folder. You can find this folder by clicking on the drop down menu listing ‘Desktop’. Select
your Kerberos user, and select the ‘www’ folder in the week 0 download.

2. In the empty text file, copy and paste the following HTML template into your file.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 
<html xmlns="http://www.w3.org/1999/xhtml"> 
<head> 

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<link type='text/css' rel='stylesheet' href='style.css'/> 
<title>My Name - DUSP @ MIT</title> 

</head> 
<body> 

<h1>This is my first webpage!</h1> 
<p>Here I can add text, images, and links.</p>
<a href="http://dusp.mit.edu">Click here to go to the DUSP website</a>
<a href="http://www.google.com">Click here to go to Google</a>

</body> 
</html> 
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3. File > Save As… Name it myfirstpage.html, using all lowercase letters and no spaces. Naming the file
with a ‘.html’ extension will convert the file from a text document to an html document. Save the file to
your “www” folder in your Athena space. If you get a permissions issue when saving, please see the
following pages to troubleshoot.

4. In file explorer drag this file to your www folder on Athena.

5. Open up Firefox and navigate to http://web.mit.edu/username/www/myfirstpage.html - You now
have a webpage that contains a heading line, a line of text and two links.

Your Basic Webpage http://web.mit.edu/<username>/www/myfirstpage.html 

6. Experiment with changing the content of the HTML file. Change ‘My Name’ to your name, and add a
line of text that says ‘I love websites!’ Resaving the file in your ‘www’ folder will update the website on
the internet when you refresh your page. Pretty cool!

Objective III. Create a Website to Showcase Your Class Work 

During your time in DUSP, you will work on many projects and create many maps, graphics, and other 
deliverables, all of which will be wonderful to build a portfolio of your work with and fantastic to show 
to future employers. Over the course of this first semester, we want each one of the students to create 
and maintain a website. Make this website your own. It can be as simple as you want, and can be in your 
Athena locker or on your own hosting site. You can take this with you when you leave DUSP and move it 
to your own hosting! 

We have made a template for you of a very simple webpage that contains the code you need to post 
your materials. Feel free to use it as is, or get creative and make something completely different! 

1. In your weekly materials, locate the www folder. In the www folder, you will see the following files.
Copy and Paste these files into your www folder in your Personal Athena space.
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2. Now, navigate to http://web.mit.edu/yourusername/www/. You should see the following! (Note, this
has my name on it, not yours. We will modify the HTML to have your information.)

Next, we are going to modify the index.html document to replace some of the information with your 
own. If you have made a website before, this should be easy! If not, no worries, it is not challenging. To 
help you through the document, there are many notes to help you. 

Our little website consists of three files, an HTML file (index.html) that contains the markup language 
for the webpage, and a CSS file (style.css) that contains the styling for our webpage. There is a link built 
into the myfirstpage.html page we made in the previous step. 
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3. If you haven’t yet, unzip all the files in “Week0_LabMaterials.zip’ and copy them to your ‘www’ folder.
Using Atom or your favorite text editor (NOT A WORD PROCESSOR!!!), open the index.html file. Using
‘Finder’ in macOS, right-click on the file and select ‘Open With’, and click on Atom. The file will open as a
tab in Atom. Close other tabs to maximize your working space. We will break down each of the sections,
and you can customize to your liking. The index.html file:

The index.html file is what is requested by default when a browser navigates to your page. It is split into 
head and body elements. The <head> element contains meta information and the <body> element 
contains our page content. 

4. Customize the <head> Element. Remember to save your work after each of the steps below in order
to update your ‘www’ folder.

At the top of the document, you see the <head> element. This contains metadata on your HTML file 
and other information to help your page properly display. In the screenshot below, line 4 contains the 
title of the page that goes in our browser tab. Line 5 contains a link to our stylesheet (style.css), which is 
also in our www folder. An important note, see that all sections have a beginning tag (ie <head>) and 
end tag (i.e. </head>). Ends are signified with a forward slash (/). 
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Change this to your name, and leave the other items for now. Save and refresh your document. 

5. Customize the <body> Section:

The <body> section is where the magic happens. This is where your content sits. Our body element is 
split into three divisions (or containers) called <div> elements: 

• a <div id=“header”> section that contains our page title, a short personal bio, and links.
• a <div id=“main”> section, this will contain our exercises for the semester. There is also a

<div id=“details”> section that you can use to write up paragraphs and other information
about your individual exercises.

• a <div id=“footer”> section that contains information we want at the bottom of the page.

Notice all of the code that is contained within <!-- --> brackets. This is called a comment. This will 
not be interpreted by the browser and you can use it to make notes in your document to help human 
readers. We have include a bunch of these to help you find your way around the document. 

i. Customize the header section <div id=“header”>

The header section contains our name and some other information about ourselves, including a nice 
little link to the first page HTML document we made in the previous section. The code follows: 

In line 11, change Eric’s GIS Portfolio to what you would like the header of your page to look like. Then 
in line 12, customize the blurb to your liking. The text in these two sections are contained in <h1> and 
<h3> tags, this signifies heading and emphasizes the text. Read more about heading tags and elements 
here:  https://developer.mozilla.org/en-US/docs/Web/HTML/Element/Heading_Elements 

Next in line 14, add a short bio. Note this is in a paragraph tag, <p>. Paragraph tags are good for 
containing larger blocks of text. https://developer.mozilla.org/en-US/docs/Web/HTML/Element/p 

https://developer.mozilla.org/en-US/docs/Web/HTML/Element/Heading_Elements
https://developer.mozilla.org/en-US/docs/Web/HTML/Element/p
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Lines 16 and 17 contain links. These are done with an anchor tag, <a>. You can change these, or leave 
these and modify them later. https://developer.mozilla.org/en-US/docs/Web/HTML/Element/a 

ii. Customize the main element <div id=“main”>

The main element will contain the bulk of our information, and here we can put our exercises when we 
are done with them. The code follows: 

In Line 24, you see the heading for the specific assignment. Next, in line 25, you see an image tag 
<img>. This is how you add an image to your document. src= “<image location>” is an attribute 
of the image tag that specifies the image location, or source. The line currently just adds the map.jpg 
image we have in our web folder. 

Change the image by changing the source. The following steps show you how to do this. 

How to upload a new image? 
a. Find image. How about the map you just created in ArcGIS.
b. Place it in your www folder (web folder).
c. Use an image tag in your HTML, changing the source (src) to be your image’s name (ie airbnb.png). alt
is what appears if your image is not found.

Line 26 contains a short little caption for your photo, using a <p> tag. Note there is a link in here that 
you can change to another location (href). Example, upload a link to a PDF of your exercise to your web 
folder, change this to the name of your PDF! 

Finally, take a look at Line 27. This contains a paragraph you can write to summarize your exercise 
submission. Right now it contains dummy text. Feel free to change this to whatever you want. 

iii. Remove comment tags to show elements

Code for the exercises is included in comments throughout the page. You can ‘uncomment’ these 
elements by removing the <!-- --> brackets. 

https://developer.mozilla.org/en-US/docs/Web/HTML/Element/a
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How do I update the code you gave me for my website? 
1. Locate a given exercise in the comments.
2. Place a PDF or an image of your completed assignment your www folder (web folder).
3. Uncomment code by removing <!-- --> brackets.
4. Change images, links, and details by modifying the HTML.
5. Save. Done!

iv. Customize the footer element <div id=“footer”>

In the footer element, change the email addresses to be yours. This will create a nice and easy contact 
link for you. 

Save and refresh your page in your browser! Looking good! 

6. Introducing CSS (Cascading Style Sheets):

There is one element of our page we haven’t looked at yet, that is how it is styled. This is contained in a 
stylesheet named style.css. CSS stands for Cascading Style Sheet, and allows you to style elements in 
your page based on a bunch of guides you set. This can include size, font, text color, background color, 
location, opacity, and many more items. 

The way CSS works is actually quite simple, you pick an element on your page, such as <body>, set some 
properties, and those properties will be applied to everything with the body tag. The style sheet 
‘cascades’, or will work for any sub-elements unless you set them to be something else. Setting 
something the <body> element will change everything within body. If you set a style for a <p> element 
within the body, it will be supersede the body styling. 

Open our style.css. You can see how this works. 
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In CSS, the references to your page elements are called Selectors. They ‘select’ and style elements from 
your page. If the CSS selector contains a # before it, it references a specific element that has that ID. If 
you see a dot (.) before it, it is referencing a “class”. A little more on that here: 

http://www.w3schools.com/cssref/css_selectors.asp 

You don’t have to modify this document if you don’t want to. It is not required, but if you want to dig in 
and customize, this is where you can create amazing styling. 

Save and refresh, you have an MIT homepage! 

While this is not a web programming course, we encourage you to learn a bit more about websites, 
HTML and CSS, and get as creative with your sites as you want. 

We won’t grade appearance of these sites, but an awesome personal portfolio can serve you 
well for years to come. 

Website and Web Programming Resources 

Again, this is not a web programming course. Basic knowledge of web programming will help you, 
however, not only in this course, but also in many endeavors during your time at DUSP. We are going to 
make some web maps using Google Maps and CartoDB at the end of the semester, and you can use your 
webpage for them. The following are some great starter links and entry level tutorials that will introduce 
you to the concepts behind webpages. Look for DUSPviz sessions this fall that will introduce websites 
and basic concepts that can get you started. 

• DUSPviz “Code your First Website”:
http://duspviz.mit.edu/web-map-workshop/code-your-first-website

• DUSPviz “Using Bootstrap: Website Templates”:
http://duspviz.mit.edu/web-map-workshop/bootstrap-templates/

http://www.w3schools.com/cssref/css_selectors.asp
http://duspviz.mit.edu/web-map-workshop/code-your-first-website
http://duspviz.mit.edu/web-map-workshop/bootstrap-templates/
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• W3schools:
http://www.w3schools.com/html/default.asp

• Codecademy:
http://www.codecademy.com/tracks/web

• Code School:
https://www.codeschool.com/paths/html-css

http://www.w3schools.com/html/default.asp
http://www.codecademy.com/tracks/web
https://www.codeschool.com/paths/html-css
http://web.mit.edu/haijing/www/
http://web.mit.edu/haijing/www/
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