
Lab 5: Mapping Boston Zoning Variances 


Purpose: 

ArcView allows access to Oracle tables on our database server. In this exercise, we'll 
learn how to access Oracle tables from ArcView and use this capability to create a 'pin-
map' showing the location of zoning variances on the Boston maps that we used earlier in 
the semester. 
Needed Info: 

•	 Clark Broida's database of Boston Zoning variances (stored in the ZONING* table 
on the Oracle server) 

• Assorted Boston maps described in the web page of CRL-supported datasets. 

(1) Preparing the ZONING data 
In class, we explained how the table lonlat4 contained 'geocoding' information about the 

location of each zoning variance --namely, the longitude and latitude of the 

corresponding parcel. However, the longitude values needed to be multiplied by -1 to 

represent values in the Western Hemisphere. We used the following Oracle query to 

create a 'view' that made this change:

CREATE VIEW lonlat5 AS 

SELECT casenumber, -1 * longitude longitude, latitude,

streetname, quality
FROM lonlat4; 

Use SQL*Plus to connect to Oracle and create your own view, lonlat5, to convert the 
longitudes. 

(2) Connecting ArcView to Oracle 
The SQL connection from ArcView to Oracle can be made from the SQL Connect 
option of the Project menu. The SQL dialogue window that pops up allows you to run a 
single SQL command that extracts a table from Oracle and makes it available as an 
ordinary ArcView table (that can be linked or joined with other ArcView tables). (Note 
that, however small or large the resulting SQL table, ArcView will bring over the entire 
table right away. Don't use this method to access directly the entire parcel database for 
Boston!) 

Open ArcView and use this method to grab a copy of the lonlat5view that you just 
created. Name the table 'lonlat5' in the SQL dialogue window so that you remember from 
whence it came. 

* Kindly refer to Lecture Notes section 

http://gis.mit.edu/metadata


(3) Mapping the Zoning Variances 
To map the zoning variances, you'll need to convert the latitude/longitude values in the 
lonlat5 table into 'points' on your map. Since all the Boston area maps we've been using 
are in Massachusetts State Plane coordinates (not latitude/longitude), we'll have to worry 
about map projections. 

(a) Open a View window and use the View > Add Event Theme menu item to convert 
the latitude/longitude values in your lonlat5 table into 'pin-map' points on your ArcView 
map. Enough zoning variances have been georeferenced for the general envelope of 
Boston to be visible around all the dots. HOWEVER, the coordinates are expressed in 
lat/lon -- not the state plane coordinates we have used when drawing maps of Boston and 
vicinity last month. If you were to add, say, the Massachusetts town boundary map in 
/mit/massgis/2000/state/towns (polygon) to your view, the lonlat locations of the zoning 
variances won't line up with the town boundaries (which are in Massachusetts State Plane 
Coordinates, Mainland Zone, NAD83, meters). 

(b) Open a second View window and add the Massachusetts town boundaries as a theme 
in this view. Once we've projected the latitude/longitude of the zoning variances, we will 
be able to add them to this view. 

(c) Now, let's project the variances from latitude/longitude to state plane coordinates. 
Highlight the first View window (showing only the zoning variances from lonlat5 
mapped in latitude/longitude 'geographic' coordinates). Choose View > Properties from 
the menus and set the Map Units to 'decimal degrees' (to indicate that the coordinates 
read in from disk are geographic coordinates expressing latitude/longitude location in 
decimal degrees). Next, click the 'Projection...' button and set the coordinate system to be 
used by this View window to be 'State Plane - 1983' with type set to 'Massachusetts, 
Mainland'. Note that, when you click OK and return to the View Properties dialogue box, 
the map units have been reset to meters (in accordance with the projected state plane 
parameters for the projected view you are about to see). You may set the distance units to 
the units of your choice. When you click 'OK' the zoning variances will now be displayed 
in Massachusetts state plane coordinates -- but they still are saved on disk in 
latitude/longitude. Highlight the projected zoning variance theme in your View window 
and choose Theme > Convert to Shapefile from the menus to save the projected zoning 
variances in the projected units -- i.e., Massachusetts state plane coordinates. As usual, be 
careful to select (and remember) an appropriate directory in which to store the projected 
shapefile. Once you've save the projected zoning variances to disk, you can add them to 
the other View (with the Massachusetts town boundaries). 

Alternate strategy for projecting zoning variances 

To project the zoning variance latitude/longitude values to Massachusetts State Plane, 
you can follow a slightly different procedure from the one we used in class. This method 
uses the Projector! extension. This procedure, when it works, is a bit more streamlined 
than that outlined above. However, in some cases, obscure permission problems have 



prevented students from using the Projector! button to do the coordinate transformation. 
Depending on what ArcView operations you have done, ArcView may refuse to save the 
projected coverage because it does not have write permission for the MassGIS towns 
shapefile. In such cases you can use the original method demonstrated in class instead of 
the Projector! extension. 

Highlight the first View window (with the mapped zoning variances from lonlat5). 
Choose the File > Extensions menu option and load the 'Projector!' option. Notice the 
new 'projection' button at the far right of the toolbar. Click it to see if we can figure out 
how to convert the zoning variances. When you do this ArcView will complain if you 
haven't set any map units yet -- we need to tell ArcView that the coordinates of our 
mapped zoning variances are expressed in decimal degrees. Use the View > Properties 
dialogue box to set the map units to decimal degrees. Now click the projection button 
once again, accept the default choice of 'meters' for displaying the projected results, and 
then (in the next popup window) set the projection to be 'State Plane - 1983' so that it 
uses the 1983 North American Datum. The 'type' will reset automatically to 
Massachusetts Mainland (a fine choice...). Click 'OK' to accept the projection and then 
'Yes' again when asked whether to recompute lengths/areas in meters. Now, click 'Yes' 
and 'OK' when asked whether to add the resulting shapefile as a theme in one of your 
View windows. Add the projected zoning variances to your second View (with the 
Massachusetts town boundaries) and, when prompted, specify a path and filename in 
which to save the projected theme as a shapefile (and then load it into your View 
window). 

Now you have 'pin map' of the projected zoning variances showing up within the town 
boundaries of Boston where they belong. (Compared with the projection method used in 
class, this way is a little more direct in projecting, saving, and adding the zoning 
variances to the Massachusetts Town view.) 

(4) Analyzing Spatial Patterns of the Zoning Variances 
Let's examine and map various subsets of the zoning variance cases -- for example, all 
approved variances. We're not quite ready to do this since thelonlat5 table has none of 
the zoning variance characteristics -- we'll have to join it to the ZONING table* using 
'casenumber'. We can do this in Oracle or we can move the entire zoning table into 
ArcView and do all the queries (and joins) there. Since the ZONING table isn't that big, 
bringing the whole table into ArcView is manageable. However, for other situations --
such as the landuse owner categorization exercise that we did earlier, we might want to 
run the queries in Oracle, store the results in a SQL 'view' and pull the view over to 
ArcView. 

(d) Now let's add a few other coverages to give more meaning to the zoning variance 
map. Add the msa5_tr90 and bostnbrd coverages (showing Eastern Mass 1990 census 
tracts and Boston neighborhood boundaries). On CRL machines you can enter the 

* Kindly refer to Lecture Notes section 



environment variable $BOSTON_METRO into the 'add theme' dialogue box. These 
environment variables are described on the CRL metadata help page 
http://gis.mit.edu/metadata and retain the same names even if the data are moved to 
another CRL locker.) Finally, if you want to get more exotic, add the MIT OrthoServer 
extension so that you can slip orthophoto imagery under your maps as demonstrated in 
class. 

(e) After joining the zoning data to your projected-and-mappedlonlat5 data, generate a 
pin-map showing the location of all variances (that were geo-referenced) which proposed 
to convert vacant land to housing. Your map should be zoomed in to just fit Boston 
onscreen and should show city boundaries and census tracts as well as the zoning 
variance locations. 

(f) Now change the symbols used to draw the Part (e) variances (involving vacant land 
converted to housing) so that a different symbol is used for those which were 
APPROVED (code 1 or 2). You will also want to exclude the missing value cases so the 

than one way to do this. For exam

two symbols apply only to approved/not-approved variances. Once again, there is more 

ple, you can use the 'hammer' query tool associated 
with the theme properties of your zoning variance theme. Select only those variances that 
are vacant-to-housing and have a known Board decision. Then set the symbols to be 
displayed based on the Board decision. Alternatively, you could write an Oracle query 
that creates a view with a WHERE clause limiting the variances -- and then pull the 
resulting table over to ArcView. The former option is easier here. But, if you wanted to, 
say, tag the zoning variances with some of their 1980 census characteristics* (which are 
stored, by sub-neighborhood, in the Oracle table called CENSUS), then it would be easier 
to generate the desired table in Oracle before pulling it across. 

(g) Next let's examine whether the approval rate of vacant-land-to-housing variances 
appears to be different across parts of Boston that have high/medium/low housing value -
- as measured by the 1990 census data. Selected 1990 Census tract data are stored in an 
INFO table called msa5_tr90.dat stored together with the msa5_tr90 census tract 
coverage mentioned earlier. The data table is stored in an INFO database (this is the 'info' 
part of the software called ArcInfo.) Add this table to your ArcView project -- just 
remember to set the table type to 'INFO' and to look in the sub-directory called 'info' in 
the $BOSTON_METRO directory (N:\meters83\massmaps\boston). You will have to 
join (or link) this data table to the msa5_tr90 theme in order to map the census data. The 
column names in the msa5_tr90.dat table are the official Census Bureau names. As 
explained in Tom Grayson's Census notes in lecture no. 3 of 11.208, the technical 
documentation for STF3 census data contains the data dictionary for these variables. But 
we'll save you some time: the H061A001 variable contains the median value of owner-
occupied housing units. Use this variable to generate a thematic map of the housing 
values across the Boston census tracts. Now zoom in a bit on a part of town of particular 

* Kindly refer to the Lecture Notes section 

http://gis.mit.edu/metadata
http://www.census.gov/td/stf3/tbl_mtx.asc
http://www.census.gov/td/stf3/tbl_mtx.asc


interest to you and fiddle with the map so that the Part (f) variances (with approved/not-
approved symbols) are readable on top of your thematic map. 

(h) Finally, let's ask some questions about the zoning variances that fall within 
high/medium/low value tracts. How many vacant-to-housing variances are in above-
average value tracts (1990)? What fractions are approved? From the map, we can see 
which variances fall within the high/medium/low value tracts. But we can't easily 
compute the counts and fraction-approved because the zoning variances aren't 'tagged' 
with the number of the census tract that contains them. Here's an opportunity to use some 
of the spatial data processing capabilities of our GIS. We can do a spatial join -- in this 
case a so-called 'point-in-polygon' operation -- to find out which zoning variances 
(points) are contained within which census tracts (polygons). There are several ways to 
do this. (You may also want to refer to one of last Fall's 11.520 lab exercises for more 
information. We'll use the method that involves a 'spatial' join of the lonlat5 attribute 
table to the msa5_tr90 attribute table. 

Open up the attribute table for msa5_tr90 shapefile and click on the column heading 
marked 'Shape'. Next, open the attribute table for your lonlat5 theme and click on its 
'Shape' column. Now select the menu item Table > Join. The attributes for msa5_tr90 
will disappear. If you examine the attribute table for lonlat5, however, you should now 
see all the census tract columns appended to the lonlat5 table. You've done an (outer) 
join of the census tract table to the lonlat5 table using the spatial location of the zoning 
variances to relate each variance to the census tract that contains it. All the zoning 
variances within a census tract have the same (duplicated) census data brought over from 
msa5_tr90. The 'Shape' columns aren't true attributes; they serve as placeholders that 
remind us that each row of the attribute table is tagged with a hidden spatial object ID 
that associates it with the vector geometry of that object's boundary. That geometry is 
used to carry out the 'spatial join'. 

We still have a ways to go to answer the part (h) questions because the original 
msa5_tr90 attribute table had only the census tract identifiers -- and not the census 
variable that are in the msa5_tr90.dattable and have to be joined in. Once you have 
joined in the data table, use ArcView's query tools (and Field > Statistics options) to 
compute the desired numbers: the number of vacant-to-housing variances in above-
average income (1990) tracts and the fraction of them that were approved. In addition to 
computing these two numbers, turn in a printout of a table showing the casenumber, 
board decision, 1980 nsa number, and 1990 census tract number for all vacant-to-housing 
variances that are within ROSLINDALE (i.e., NSA subnghbrd 49, 50 and 51). 

If we could easily put ArcView tables back into Oracle, it might be easier to do these last 
few steps in Oracle. But ArcView can't easily update Oracle tables. Hence, we are stuck 
with the one-way path for moving portions of Oracle tables into ArcView before we do 
any spatial processing. There are tools around that facilitate moving tables from ArcView 
into Oracle, but we won't use them until the project portion of the course. 



Lab Assignment 
The only parts of this exercise that you need turn in are: 

(a) The two numbers (variance count and fraction approved) and the Roslindale table 
from Part (h), and 

(b) A printed layout showing your two maps of Boston from Parts (f) and (g) with the 
location of the vacant-to-housing variances highlighted in various ways. 

Be sure to put your name and Athena username on your sheet for part (a) and on your 
map layout for part (b). 

OPTIONAL Question 1 (just for fun...) 
For simple queries, it's easier to use ArcView's SQL tools to run the queries using the 
SQL connection -- or even to query *.dbf versions of the ZONING database* and lookup 
tables (rather than do the queries in Oracle and bring them over with the browser and 
addins). But, suppose you wanted to use the institutional categories of ownership that you 
developed in the last homework set. It took a while to develop these as you accumulated 
the SELECT and UPDATE SQL statements that built the cross-reference table. Hence, 
you'd like to leave all this on a network database server that could protect private data 
while letting you reach it quickly from any Athena or PC 'client' when you had a chance 
to work on it and map the results. 

For all those variances whose board decision is known, what is the approval rate (code 1 
or 2) broken down by your institutional categories? What fraction are in high income 
neighborhoods and tracts (as defined earlier) by each institutional category? What about 
for the vacant-to-housing subset? Map the locations of the variances in the various 
institutional categories. Do you see any patterns worth pursuing? Are they closer to major 
roads, downtown, more/less dense residential neighborhoods,...? Perhaps you are 
comparing apples and oranges -- the institutionally owned property might not be 
comparable to the one-, two-, and triple-deckers owned by individuals. Use the 
'existzonin' variable to zero in on those variances on property that is zoned for single 
through 3-family structures and then redo some of these comparisons. 

OPTIONAL Question 2 (just for more fun...) 

Now let's do an exercise similar to Part (f) above that uses additional 1990 census data--
viz. census data that aren't already included in the data tables for the ArcInfo census tract 
layer. We'll mount Massachusetts STF3A data online at CRL and pull off the needed 
STF3A data. In this case, let's find census data indicating the extent of auto ownership in 

* Kindly refer to the Lecture Notes section 



each Boston census tract and compare the incidence and approval rates of vacant-to-

housing zoning variances within 1990 census tracts that are above/below average in your 

measure of auto ownership. As explained in the 11.208 Census notes, the technical 

documentation for STF3 census data has several variables related to vehicle usage. For 

example:

H38. AGGREGATE VEHICLES AVAILABLE(1) BY TENURE(2)


Universe: Occupied housing units
Total: 
Owner occupied
Renter occupied

Use these variables (with appropriate normalization) to construct some measure of auto 
ownership that allows you to group Boston census tracts into above/below 'average' 
categories. Think about your reasoning and the specific census variables and formulae 
that you used to compute your measure. Generate a map (just as you did earlier) showing 
the location of all variances (that were geo-referenced) which proposed to convert vacant 
land to housing. Use color (or grayscale) again to distinguish approved/dis-approved 
variances but this time use thematic shading of the census tract map to indicate parts of 
town where auto ownership is high/medium/low. 

http://www.census.gov/td/stf3/tbl_mtx.asc
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