
Today: using MATLAB  to model LTI systems  

• 2nd order system example: 
– DC motor with inductance 

• derivation of the transfer function 
• transient responses using MATLAB 

– open loop 
– closed loop (with feedback) 

– Effect of feedback gain 
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DC motor system with non-negligible inductance  
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Theoretical tasks 

•	 Derive the values of damping ratio ζ, natural frequency ωn 
analytically based on the TF from the previous page 

• Express the conditions such that the 2nd order DC motor model 
would become over/under damped 

PLEASE TURN IN THIS PAGE BEFORE YOU LEAVE THE LAB  
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MATLAB tasks /1  

•	 Select values of R, L, b, J, Km(=Kv) such that the open-loop (OL) 
response should be overdamped. Calculate the poles of the 
transfer function based on your choices, and compare the rise time 
of the response you get from MATLAB with the rise time that you 
expect from the theory. Make sure to “turn off” the feedback loop by 
setting the value of the gain to equal zero. Print out the MATLAB plots. 

PLEASE TURN IN THIS PAGE BEFORE YOU LEAVE THE LAB  
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MATLAB tasks /2  

•	 Select values of R, L, b, J, Km(=Kv) such that the open-loop (OL) 
response should be underdamped. Calculate the poles of the 
transfer function based on your choices, and compare the rise time, 
overshoot and damped oscillation frequency of the response you get 
from MATLAB with the corresponding values that you expect from the 
theory. Make sure to “turn off” the feedback loop by setting the value 
of the gain to equal zero. Print out the MATLAB plots. 

PLEASE TURN IN THIS PAGE BEFORE YOU LEAVE THE LAB  
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MATLAB tasks /3  

•	 Now set the value of the inductance L to zero, and keep the 
feedback loop “turned off” by setting the value of the gain to equal 
zero. How does the open-loop (OL) response change in MATLAB? 

PLEASE TURN IN THIS PAGE BEFORE YOU LEAVE THE LAB  
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MATLAB tasks /4  

•	 Restore the value of the inductance L to non-zero, and select the 
remaining values such that the open-loop (OL) response is again 
overdamped. Now “turn on” the feedback loop by gradually cranking 
up the value of the feedback gain. At some point, you will observe 
that the response becomes underdamped (oscillatory.) Print out the 
low-gain response (overdamped) and high-gain response 
(underdamped) and record the value of gain where the transition 
happens. 

PLEASE TURN IN THIS PAGE BEFORE YOU LEAVE THE LAB  
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MATLAB tasks /5 

•	 In the last lab, we also had a second-order system where we 
observed the response change from over- to underdamped by 
cranking up the gain in the experimental flywheel system. Comment 
on the difference(s) between the model for the last lab’s experiment 
and the model used in this lab’s numerical exploration. 

PLEASE TURN IN THIS PAGE BEFORE YOU LEAVE THE LAB  
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APPENDIX  

MATLAB Control Systems Toolbox  

Tutorial  

2.004 Spring ’13 Lecture 09 – Tuesday, Feb. 26 9 



2.004 Spring ’13 Lecture 09 – Tuesday, Feb. 26 

Courtesy of The MathWorks, Inc. Used with permission. MATLAB and Simulink are registered trademarks
of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional trademarks. Other
product or brand names may be trademarks or registered trademarks of their respective holders.

10 

www.mathworks.com/trademarks


MATLAB Linear Model Representation  
• Transfer functions 

s + 2  
H(s) =  

s2 + s + 10 

sys = tf ([1, 2] ,[1, 1, 10]) 

• State-space Models 

A, B, C, and D are matrices of appropriate dimensions, x is the state vector, and u and 
y are the input and output vectors respectively. 

• Note: There are also other more complex forms of linear systems 
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State-space System Representation Example ①  

• Recall from Lecture 5inductance dissipation
(due to windings) (resistance of windings) 

dissipation load 
(viscous friction (inertia)

in motor bearings) 
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State-space System Representation Example ②  

• Reorganizing the system and write in matrix form 
8 
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Here our input is vs and output is ω; we also have 
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⇥ 
0 1  

⇤ 
· 
 

i 
! 

� 
+ [0] · vs(t) 

•  

• Now we have our A B C D matrices ready 
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State-space System Representation Example ③ 

•	 In MATLAB, we can represent the motor system using following 
command: (need to define all parameters first) 

A = [-R/L -Kv/L; Km/J -b/J]; 
B = [1/L; 0]; 
C = [0 1]; 
D = [0]; 
sys_dc = ss(A,B,C,D) 

•	 We can also convert this state-space system to transfer function or 
Pole/zero/gain form: 

★ sys_tf = tf(sys_dc) %(to transfer function) 
★ sys_zpk = zpk(sys_dc) %(to ZPK form) 

•	 NOTE: The state-space representation is best suited for numerical 
computations and is most accurate for most cases. 

• 
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LTI Objects and Manipulation 

•	 Control System Toolbox software uses custom data structures called “LTI objects”. 

•	 The state-space model we have created for the DC motor is called an “SS object”. 
There are also TF, ZPK, and FRD objects. 

•	 “LTI objects” enable you to manipulate linear systems as single entities using “get” 
command in MATLAB, we can see the detailed entities. 

get(sys_dc) 

sys_dc.a=A_new 

(This line allows you to manipulate 

individual quantities) 
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•

Creating Multiple Transfer Functions 

s s + 1  s + 2  • Assume the three transfer functions are , and 
s + 5  s + 6  s2 

+ s + 5  

• Collect all numerators and denominators in cells; use the following MATLAB command: 

N = {[1, 0], [1, 1], [1, 2]};  
D = {[1, 5], [1, 6], [1, 1, 5]};  
sys = tf(N, D)  
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Interconnecting Linear Models -- Arithmetic Operations 

• Addition (parallel systems): 

tf(1, [1 0]) + tf([1 1], [1 2]);  This line represents 
1 
s 
+ 

s + 1  
s + 2  

= 
(s + 2) + s(s + 1) 

s(s + 2) 

Transfer function:  
s^2 + 2 s + 2 

s^2 + 2 s 

• Multiplication (cascaded systems): 

2 * tf(1,[1 0])*tf([1 1],[1 2]);  

Transfer function:  

This line represents 2 · 1 
s 
· s + 1  
s + 2  

2s+2  

s^2 + 2 s  
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------------------

Interconnecting Linear Models -- Feedback loop  
•	 Example system: 

sys_f = feedback(tf(1,[1 0]), tf([1 1],[1 2]) 

Transfer function: 
s+2 

s^2 + 3 s + 1 
•	 NOTE: You can use the “lft” function to create more complicated feedback 

structures. 
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The LTI Viewer 
•	 “LTI Viewer GUI allows” you to analyze the time- and frequency-domain 

responses of one or more linear models. 

•	 Syntax: 
ltiview(model1,model2,...,modelN) 

This syntax 
opens a step response plot 

of your models 
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General LTI Viewer Menus  
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Adding More Plots To LTI Viewer  

• Select Edit > Plot Configurations. 

• You can also designate specific type of plots to view on the right hand side of 
this window. 

2.004 Spring ’13 Lecture 09 – Tuesday, Feb. 26 21 

Courtesy of The MathWorks, Inc. Used with permission. MATLAB and Simulink are registered trademarks
of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional trademarks. Other
product or brand names may be trademarks or registered trademarks of their respective holders.

www.mathworks.com/trademarks


Change Plot Type 
• To view a different type of response on a plot, right-click and select a plot 

type.  
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Analyze System Performance 
• Right-click to select performance characteristics. 

• Click on the dot that appears to view the characteristic value.  
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Importing Models into the LTI Viewer 
• Select “Import” under the “File” menu. This opens the Import 

System Data dialog box 

• All the models available in your MATLAB workspace are listed  
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This syntax views the 
step response of our 

Alternative Command to Simulate Different Responses  

• you can open the LTI Viewer and import systems from the MATLAB 
prompt. 

ltiview('step', sys) 

• More options: 
'step' -------- Step response 
'impulse' -------- Impulse response 
'initial' -------- Initial condition 
'lsim' -------- Linear simulation 
'pzmap' -------- Pole/zero map 
'bode' -------- Bode plot 
'nyquist' -------- Nyquist plot 
'nichols' -------- Nichols plot 

• Multiple plots are allowed. Example: ltiview({'step';'impulse'},sys)  
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Displaying Response Characteristics  
• Right-click on the plot 

• Example: select Characteristics > Rise Time. 
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Toggling Model Visibility 
•	 This figure shows how to clear the second of the three models using 

right-click menu options. 
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The Linear Simulation Tool 
•	 In the LTI Viewer, right-click the plot area and select Plot Types > 

Linear Simulation. 

• You can also use the “lsim” function at the MATLAB prompt: 
Syntax: lsim(modelname) 

2.004 Spring ’13 	 Lecture 09 – Tuesday, Feb. 26 

Courtesy of The MathWorks, Inc. Used with permission. MATLAB and Simulink are registered trademarks
of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional trademarks. Other
product or brand names may be trademarks or registered trademarks of their respective holders.

28 

www.mathworks.com/trademarks


Using The Linear Simulation Tool 
•	 Specify the time duration you want to simulate: 

–	 Import the time vector by clicking Import time (From workspace) 

–	 Enter the end time the time interval in seconds 

•	 Specify the input signal 
–	 Click Import signal to import it from the MATLAB workspace or a 

file 

–	 Click Design signal to create your own inputs 

•	 If you have a state-space model, you can specify the initial 
conditions 
–	 click the Initial states tab 

• For a continuous model, select an interpolation method
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Functions for Frequency and Time Response  

2.004 Spring ’13 Lecture 09 – Tuesday, Feb. 26 

Courtesy of The MathWorks, Inc. Used with permission. MATLAB and Simulink are registered trademarks
of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional trademarks. Other
product or brand names may be trademarks or registered trademarks of their respective holders.

30 

www.mathworks.com/trademarks


Using a Response Command  

•	 Example: 
h = tf([1 0],[1 2 10]) 
impulse(h) 

• Plot:  
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Response for Multiple Systems 
• Command (Collect transfer functions into a vector array): 

h = [tf(10,[1 2 10]) , tf(1,[1 1])] 
step(h) • Plot: 
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Alternative Command for Multiple Systems 

•	 Syntax: 
stepplot(sys1, 'r' , sys2, 'y--' , sys3, 'gx') 

This 
command generates a step plot (sys1 with 

solid red lines, sys2 with yellow dashed lines, 

impulseplot(sys1, 'r' , sys2, 'y--' , sys3, 'gx') 
bodeplot(sys1, 'r' , sys2, 'y--' , sys3, 'gx') 

•	 NOTE: Options for plot color and shape are optional (all in blue solid 
lines) 

Example: stepplot(sys1, sys2, sys3, sys4, sysN) 
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Controller Design -- PID Tuner 

•	 To launch the PID Tuner, use the pidtool command: 
pidtool(sys,‘type’) Type 

•	 The PID Tuner automatically designs a controller for your plant. 

•	 You can use the Response time slider to try to improve the loop 
performance 
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The PID Tuner  

Response time slider 

Controller type 

Response 
type 
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The PID Tuner  

• Right click on the plot and select Characteristics to mark the 
characteristic times. 
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The SISO Design Tool 
• Open the control design GUIs with the following command 

sisotool 
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Define The Control Architecture  

• In the 
“Architecture 
tab”, click 
“Control 
Architecture” 

• Select proper 
architecture and 
specify the sign of 
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Specifying System Data  

•	 In the Architecture 
tab, click System Data 

•	 You can select values 
or transfer functions 
from MATLAB 
workspace or a *.mat 
file 
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Compensator Design 
•	 In the Compensator Editor tab, you can manually define the 

compensator form. 
•	 Right click on the “Dynamics” table allows you to add/delete Poles, 

Zeros, Integrators, Differentiators etc. 
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Graphically Tuning Control Parameters ① 
•	 In the Graphical Tuning tab, you can configure the plots you want 

to see in the Graphical Tuning Window. 
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Graphically Tuning Control Parameters ②  

•	 In the Graphical 
Tuning Window, you 
can grab and drag the 
pink squares using 
the small hand in the 
toolbar. This changes 
the constant multiplier 
value of the 
compensator. 

•	 You can also add 
poles and zeros in this 
window using the 
“cross” and “circle” in 
the toolbar. 
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Viewing Damping Ratios ① 
•	 Right-click on the root locus graph and select Requirements > 

New to add a design requirement. 
•	 In the New Design Requirement dialog box choose Damping 
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Viewing Damping Ratios ② 
•	 Applying damping ratio requirements to the root locus plot results in a pair 

of shaded rays at the desired slope 
•	 Try moving the complex pair of poles you added to the design so that they 

are on the 0.707 damping ratio line. 
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Analysis Plot ① 
• In the Analysis Plots tab, select a plot type 
• Select the type of response for each plot 
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Analysis Plot ② 
• Click Show analysis plot in the Analysis plots tab 
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.

Storing and Retrieving Intermediate Designs 
•	 Click the Design History node or Store Design, both located on 

the SISO Design Task node in the Control and Estimation Tools 
Manager 
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Exporting the Compensator and Models 
After you design the controller, you may want to save your design parameters 

for future implementation. 

• Select File > Export in the Control and Estimation Tools Manager 

• Select File > Export in the Graphical Tuning window. 
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