Instructions Assignment

Art, Craft, Science

Intro to Blender!

Hello! I'm excited to teach you about my favorite form of “craft”! It’s an incredibly versatile one, and all
you'll need is your computer. Blender is a free and open source software program that allows you to bring
almost anything you imagine to life. Because it gives you so much creative freedom, the controls may
seem a bit intimidating at first, so I'm here to walk you through some basics step-by-step. I think that
knowing your way around Blender is a super helpful skill for anyone - whether you want to design
something to 3D print, visualize a 3-dimensional space to help with perspective drawing, or create a
rigged character for a video game, Blender is your first stop. As a good first project to teach you some of
the most important skills I've learned over the years, let’s make a little Frog friend to keep you company
during late nights psetting! I'll include some helpful illustrations along the way, but feel free to take your
own creative liberties. Let’s get started! I know you're busy, so don’t worry- if you follow these steps toa T

this shouldn’t take long!

Step 0 is to download Blender. This shouldn’t be too much of a hassle. If you type “Blender” into your

browser, https://www.blender.org should be one of the top hits. Click “download” in the menu at the top

of the screen, and it will walk you through the process. There are tons of great addons for Blender - many
of them free - that you may want to explore in the future, but for this simple project we'll stick with the

base program.

Our goal is to create a cute little frog creature with nice colors, and render a pretty image of him. Our

steps will proceed as follows:

1. Sculpt a basic model
2. Texture

3. Render

4. Retopology
5. Rigging

A small note: you can navigate Blender easiest with a mouse, but for the first few years of using it, I made

do with a touchpad, so you'll be ok either way.


https://www.blender.org/
https://www.blender.org

1. Sculpt a basic model
When you first open up Blender, you'll be met with a menagerie of buttons and tools and panels. Don’t be
intimidated! I'll show you exactly what you need to press. :)

Let’s start with a dictionary of basic navigational and editing controls:
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e To pan around in 3D space: With the touchpad, click anywhere on these colorful 3D
axes in the top right corner, press and hold, and drag around. You can do the same with the

mouse, or you can press and hold the middle mouse button and drag.

O

e To move up/down/left/right on your 2D view:

e

Press, hold, and drag on this little hand icon.

e To zoom in and out: Press, hold, and drag on this magnifying glass, or use the scroll wheel

on your mouse.

e To toggle between orthogonal and perspective: Simply click on this plane. See how it
changes the viewport’s appearance?

e To get “front view” (place yourself on the Y axis): Press 1 on your numpad. This is a really useful
shortcut. If you don’t have a numpad, I highly recommend going into Edit(top
left)>Preferences>Input>Emulate Numpad. Don’t forget to save your preferences! (Three lines on
the bottom left of your preferences popup).

e To get “side view” (place yourself on the X axis): Press 3 on your numpad.

e To get “top view” (place yourself on the Z axis): Press 7 on your numpad.

e To scale something up or down: Click the object and press S on your keyboard. Move your cursor
side to side to change the scale. If you want to change scale along only 1 axis, press S and then the
relevant axis button. (i.e., to make something taller, click S and then Z, and then drag the cursor
up to scale up on the Z axis.)

e To move an object: Click G and drag around as you like. If you want to constrain movement to
one axis, that’s G, then X/Y/Z.

e To organize your objects: You'll find a helpful panel on the top right that contains all the objects
in your viewport. Double click to rename them (i.e. “Cube” to “Frog”) or toggle their visibility in
the viewport with the eye button or the render (we'll get to that later) with the camera icon.

There are lots of other shortcuts and tools, but I use these ones the most. Feel free to play around to

familiarize yourself with the navigation! If you don't like something you did: Ctrl+Z.



It’s always a good idea to have some idea of what you want to create. If it helps, you can make a quick

sketch as a reference, like this:

(

That only took a minute, and it can serve as a really helpful baseline! If you want, you can even import

your sketch as a reference image with Add>Image>Reference, but it’s not necessary.

The first thing you'll see (aside from the starting popup, which you can get rid of by clicking somewhere
else on the screen) is what’s known as the default cube. A lot of people start by deleting it, but we'll use it
this time. (We'll leave it at default scale, 2 meters on all sides, but if you care about real life scaling for any reason
you can set that by clicking N on your keyboard and checking out the popup that shows you.) I always find that the
best place to start when it comes to modeling is with a sphere. But don’t be tempted to add a sphere in the

mesh menu, as its geometry will be a bit weird for our purposes. That’s better left for things that stay

. With the

default cube selected, click Add Modifier>Subdivision Surface. Turn the number of subdivisions

spheres, like eyes. Instead, we'll use a modifier.

e Subdivide the mesh. On the right side panel, navigate to the modifiers panel:

(“levels viewport”) up to, say, 3. If you don’t like a modifier, you can get rid of it with the X
button. To make its effects permanent, click the v to the left of the X and click “Apply”.
Apply that modifier. Now we have something that should be easy to work with. My goal is to make this
look like my design from the front (numpad 1) and the side (numpad 3). I'm going to do this by switching
to a new mode.

e Switch modes by clicking the top left corner where it says “Object Mode”. You'll see a dropdown
menu. Edit Mode is very useful because it allows you to edit the individual vertices of your mesh
(object), but we'll start with Sculpt Mode.

When you enter Sculpt Mode, you'll notice the tools available to you have changed. To start, we'll

manipulate the shape of our low-poly sphere into the rough shape of the frog’s main body, minus the legs.

Let’s use the Elastic Deform tool for that. First and foremost, enable X-Symmetry in the top

right: . Now, assuming your frog is symmetrical, as most animals are, you'll only have to



do the work of sculpting one side of him. Let’s start by adjusting his shape from the side (numpad 3) and

then from the front (numpad 1):

Use your artistic eye for this and do what feels right! It may help to adjust your deform tool’s radius or
strength at the top left. When you're satisfied, we'll make some extra details by changing the number of
vertices in the mesh, or remeshing.

e Remesh the object. You'll notice that right now there are so few vertices in the mesh that you

@

make only a minor indent - probably not what you were expecting. It’s easier to make broad

can’t add fine details. For example, if you try drawing with the Draw Sharp tool, it will
adjustments to shape when the object is “low-poly” like this (small number of vertices), but now
we're ready to add his cute frog face, so we need a higher resolution surface to work with. At the
top right, click Remesh and lower the voxel size. Careful- if you go too small your computer will
hate you. Or, more specifically, it will attempt to calculate millions of points and crash. A voxel
size of 0.01 will be plenty!

You'll notice that nothing looks different after you hit Remesh, but if you zoom in, you'll see that the

edges of the faces look a little fuzzy. If you try a tool like Draw Sharp on the surface now, it will work as
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all over the mesh and watch it get smooth! If you try to use Smooth on a very low-poly mesh, it will have

expected! I like to start by smoothing out the old faces using the Smooth tool. Just press and hold

much more of a significant subtractive effect, but on a high-poly mesh its effects will be more subtle. Play
around with the strength until you like its effects! Smooth the back, sides, top, and bottom - never forget

you're working in 3 dimensions!

Swmotn




Great! Now that we have a smooth surface, we can add face details. Let’s use Draw Sharp to make a little
smile (click and drag on the mesh). It may take a few tries to get this right, so Ctrl+Z is your friend. It will

help to switch to front view (numpad 1), zoom in, and make the brush radius very small.

B

You'll notice that the mouth you carve looks very pixelated. Don’t attempt to smooth it out - that will just
erase the mouth! Instead, we'll tell Blender to shade the mesh differently when we're ready, and it will fix
that.

Let’s also add a little bump for the eyes. We'll add the eyes themselves later. You have a few options for

this, but the easiest is the E Inflate tool. You may want to adjust the brush radius again, and return
to front view if you've left it. Just move the cursor back and forth over the area you want the eyes to be

situated until you're happy with the result.

B

Remember that, with X symmetry enabled, what you do to one side will happen to the other!

He's coming along! It’s time for some little legs. Let’s add another mesh.

e Add additional meshes. First, go back to object mode. On the bar across the top of the screen,
click Add>Mesh>Cube. It’s good practice to build everything with a cube base unless you have a
good reason to use something else.

We'll subdivide the cube again as before, 3 times. Go ahead and apply that subdivision. To make it work as

a leg, we'll scale it down so it’s small, then scale it up on the Z axis so it’s elongated. Grab it and move it to

his left side.
8



You might notice it’s disappeared inside the frog. You can bring it up front going to side view (numpad 3),
grabbing it, and dragging it forward. (See navigational dictionary at the beginning for a reminder of how
to scale and move things!) You'll probably want to move it forward and down. You may also like to rotate

it using R. You can rotate it along a fixed axis with R then X, for example.

It won't matter since we'll be merging it with the main mesh later, but you should know that it’s good

practice to apply transforms like rescaling and rotation. Otherwise, it could cause problems for you later.

Object>Apply>Rotation & Scale. You can leave the leg like this, but feel free to make some adjustments

using your new sculpting skills. For instance, I'm going to use the @ Grab tool to give the leg little

frog feet:

oo

Sides () axs U
(3)

He should really have 2 front legs, so let’s take care of that. Go back to Object Mode. We'll use another
modifier, like the subdivision. This time, look for the Mirror modifier. By default, it mirrors across the X
axis, so that doesn’t need to be changed. Just set Mirror Object to your main frog mesh, and now he has 2
front legs! We'll apply that modifier in a minute. To give him back legs, simply duplicate the front leg
mesh.

e Duplicate the mesh. Using Shift+D, you can copy the front legs. From side view (numpad 3)
move them to where you'd like them. Rotate, move, and sculpt to your liking. Make sure you're
happy with their appearance from all angles.

When you're ready, apply the mirror modifier on both legs. Make sure they’re phasing inside of the main
body mesh a bit. Now we just need to combine it all into one!

e Join the meshes. Select all the meshes by holding shift and clicking on each. Click on the main
body last. Hit Ctrl+]J to join them.

*Saving Reminder!” You can never save your work too often. This is your reminder to Ctrl+S!



To make this combination seamless, first Object>Apply>Rotation & Scale, and go back into sculpt mode
and Remesh the new mesh. Again, 0.01 should be plenty. Use the Smooth brush to smooth out all the
seams as you see fit. To make him look nice and polished, do Object>Shade Smooth in Object Mode.
Now all he’s missing is a pair of eyes! Do Add>Mesh>UV Sphere. Scale it down and place it where you'd
like your eye to go. It may help to add the mirror modifier now to get an idea of your preferred eye
spacing. I want my frog to have tiny little stylized eyes, so I'm going to make the sphere small and scale it

up on the Z axis a bit.

When you're ready, go ahead and apply the mirror modifier, as well as the rotation and scale. Shade them

smooth. Don’t join the eyes to the base mesh, as we'll want to give them a different material.

2. Texturing
He'd probably look better with some frog colors! If you care to retopologize your model (See bonus
content), which is not necessary, you'll want to do that first. The reason you'd want to retopologize is to
keep the nice details you sculpted without your computer running slow due to the high number of vertices
you're asking it to keep track of. Otherwise, navigate to the Shading tab at the top of the screen. So far
we’'ve worked in the Layout tab, but this is where we’ll add colors, as it shows us the shader node editor.
Let’s click the main body mesh. If you haven't already, this is a great time to rename it “Frog” in the
sidebar. Here’s where you get to customize him! Pick his color from the Base Color selector at the top of
the Principled BSDF node. By playing with roughness, you can make him shiny or not. See what the
different options do! You can do the same with the eyes. Add a new material and pick a color. Turn the
roughness way down to make them shiny! To further customize, you could draw on him by adding an
Image Texture node and creating a new image with Alpha set to 0, and adding a Mix Color node. Connect
the Image Texture’s Alpha to Factor and its Color to B. Make A your desired base color. Then have fun

drawing on your frog in the Texture Paint tab (left of the Shading tab)! Be sure to save the image if you do.

3. Rendering
Once you're happy with how your frog looks, it’s time to render a nice image to be our final product. You
don’t have to, but to easily place your frog in a nice environment, you can download an HDRI for free. For
example, I found one on PolyHaven.com called “Mossy Forest”. This is an easy way to give your scene nice
lighting information. Once you've downloaded it, in Shading, just switch from “Object” to “World” in the

top left corner of the node editor in the shading tab. Replace “Background” with Add>Environment


https://PolyHaven.com

Texture, and open your HDRI. You won't notice a change in viewport unless you change some settings,
but it’s there when you go to render preview (the shiny ball - the leftmost setting in the top right). Now
you can go back to Layout and position your camera. The easiest way is to Click N, go to View, and turn
on Camera to View. Now you can click on the camera icon (under the magnifying glass and hand) and use
the viewport navigation controls to look through your camera and move it as you like. On the top of the
right side tool panel, go to Render (the camera) and change from EEVEE to Cycles. Now, at the top, just
hit Render>Render Image. If you notice anything strange, remember that things disabled in viewport
(closed eye icon) may still be enabled in your render (the camera icon beside it). This includes default
viewport lighting, which could clash with your HDRI and may look harsh. When your render looks done,
hit Esc to stop it (as it may want to go on for quite a while with diminishing returns in clarity) and save
your image! Congratulations, you've made your first creation in Blender! Hope you enjoy your new frog

friend! :)

Here’s Mine!

There’s so much you can do with Blender - this is just the tip of the iceberg. You can add a mustache to
your frog with a particle system (or, more recently, with a geometry nodes hair system). You could
visualize 3D landscapes and bring them to life (which is one of my favorite things to do with Blender). You
can pretty much do anything you can imagine, and the only real obstacle is the learning curve of figuring
out how to do it. Even if you don't care to make frogs, I hope that this exercise helped you get the hang of
the interface and made that learning curve a little easier on you. Next time you want to bring something

you imagine to life, I hope you think of Blender, and feel like it is accessible to you!



Optional Bonus Material!

4. Retopology
It’s not necessary for this exercise, but if you see yourself creating with Blender in the future, you should
at least know about this. Retopology is the process of creating a low-poly mesh of the same approximate
shape as your high-poly mesh and “baking” your fine details into it as an image texture. This will tax your
computer significantly less than if you try to keep working with the high-poly model. I'm stressing this
step because, in high school, I got stuck on a project for a year because I just didn"t know what retopology
was and tried to rig an extremely high-poly mesh, which my computer simply couldn’t handle. The more
complex things you try to do with Blender, the more necessary retopology becomes. It can be as simple or
as complex as you want.

e Simple Retopology (5-10 min)
The easiest way to do it, which will work just fine for our frog, is to make a “messy” low poly mesh to use.
Simply duplicate the high-poly frog mesh, and hit Esc so it doesn’t move. You can use the Decimate
modifier to reduce the poly count. You'll lose detail, but that’s the point. With the decimate modifier on
the Collapse setting with a ratio of 0.01, I reduced the number vertices from about 120,000 to about 1,200.
This corresponds to a significant improvement in performance. Apply the modifier. Shade it smooth, and
it should look pretty decent.

e Complicated Retopology (Forever, to be honest)
Unfortunately, the decimate modifier is terrible for a mesh that you plan to rig or animate. It’s convenient,
but you lose structure and cleanliness, so it will deform in unexpected ways, especially on faces. You'd
have to instead retopologize by hand, creating a nice low-poly mesh over the surface of the high-poly
mesh. There are countless resources for this on YouTube- just know that it exists.

e Texture Baking
Either way, once you have your low-poly model, you'll need to bake the texture of the high-poly model
onto it. Here’s the crash course: Quickly UV-Unwrap the low-poly mesh. This creates a UV map, which is
how 2D textures are mapped onto the 3D surface. Select all vertices with A, then click U, Smart UV
Project, Island Margin 0.01, Unwrap. Unwrapping is something you can do manually, but this should be
good enough. Go into Shading. Have both meshes visible in viewport. Select the low-poly. Add a new
material, or if you already have one, just add an Image Texture node to it. (It's a good idea to go into
Edit>Preferences>Add-ons and enable Node Wrangler.) Connect its color output to the color input of a
Normal Map node. Connect the Normal output of that to the Normal input of your Principled BSDF, the
main shader. On the Image Texture: New. Add Title. Maybe multiply the width and height by 2 to get
better resolution. Enable 32-bit Float. Confirm by clicking New Image. With the Image Texture selected,
select the high poly mesh, then control select the low poly mesh. On the top of the right side tool panel,
go to Render (the camera) and change from EEVEE to Cycles. Scroll down to the Bake tab. Bake type:

Normal. Enable Selected to Active. Extrusion 0.05. Hit Bake. Now, the low-poly should look just like the



high-poly. Make sure to save the newly created normal map image, or it will be lost when you close

Blender.

5. Rigging

Want to pose your frog in different ways? No problem! This, like retopology, can be simple or complex
depending on your model. For the frog example I gave you, you'd really only care to move the legs, I would
imagine. That could be done by simply adding a bone (Add>Armature), moving it into the correct position
within the leg (tip: make it so that you can still see it from inside the frog by going to the object panel
(orange square), Viewport Display, and checking In Front). You'd find Edit Mode useful for moving it
around. When it’s in place, in Object Mode, select the frog, shift select the armature/bone so it’s active
(light orange), hit Ctrl+P, and With Automatic Weights. Now if you select the armature, go into pose

mode, and move it, the frog should move, too. For rigging more advanced meshes, look into Rigify!
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