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Introduction


This tutorial provides a step-by-step guide to performing a basic functional
MRI analysis using NeuroLens. The idea is to explain how to execute ba-
sic tasks and also expose some useful functionality that may not be obvi-
ous to the user.  Weʼve tried to make the software as open and intuitive as
possible, but there is no substitute for actually taking a guided tour of a
program by following a tutorial. Iʼve made fairly extensive use of footnotes
to keep the main text clear while providing details where it might be help-
ful. 

The dataset provided is a simple visual activation experiment performed
on a human subject in a 3 Tesla whole body scanner.  The scans of inter-
est include a whole brain structural scan and a functional MRI image se-
ries. The exercise starts with raw DICOM files transferred directly from the
scanner and finishes with the export of activation maps into a word proc-
essor.  The data analysis topics include spatial normalization but stop just
before group analysis. Group analysis will be the topic of a second
(shorter) tutorial. 

The exercises in this tutorial take you through a fully interactive analysis
session, but the entire analysis performed in the exercise could also be
scripted (this will be the topic of a later tutorial). 

If you donʼt already have the NeuroLens software it can be downloaded at
http://www.neurolens.org/Download/. This tutorial document is distributed 
in a zip archive which contains all data and other files required to do the
exercises. You can always download the latest version of this tutorial 
(data and instructions) at http://www.neurolens.org/Tutorials/Tutorial1.zip 

We would like to thank the Office of National Drug Control Policy for fund-
ing this work as part of the MGH Phenotype-Genotype Project on Addic-
tions and Mood Disorders. 
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Exercise 1: Loading the DICOM files 

NeuroLens makes it easy to work with output directly from the MRI scan-
ner.  You can read DICOM files1 directly into NeuroLens without any pre-
paratory format conversion and run any viewing or processing operation.
Typically you will still want to export them to another format such as MINC 
as a more convenient working format, and this is what we will do in this
exercise. 

MINC is supported as a preferred working format because a single file can con-
tain an entire acquisition series. It typically takes many DICOM files to represent
the same information. MINC also provides support for all the descriptive meta-
data used by NeuroLens. In the future we will also support NIfTI export. 

To get started, follow the steps listed below: 

Launch NeuroLens 
You launch NeuroLens by double-clicking its icon, which is usually in the 
Applications Folder. 

Open the files
You will load all of the DICOM files for the tutorial experiment.  These can 
be found in the DICOM Folder of the folder Tutorial1 that was unzipped
when you downloaded this tutorial (normally downloaded to your Desk-
top). 

You can open a folder of DICOM files by dragging the folder onto the Neu-
roLens icon in the Finder or Dock. You can also select File > Open in 
NeuroLens and select the folder that contains all of the DICOM files. 

View the session info 
After all the files are read, a window will open showing the list of “series”
contained in the folder2. This provides a much more useful summary of
the information than the folder full of DICOM files. An example of this win-

1 DICOM is the image data standard used by virtually all vendors of clinical medical imag-
ing systems. More than a file format, it is a standard for network communications be-
tween imaging systems in a hospital PACS environment.  As currently implemented by
most manufacturers, DICOM has a few disadvantages as a working file format for scien-
tific users - in particular the number of files used to represent a single acquisition can be
very large (hundreds of files). 

2 The term “series” is used to denote the set of DICOM files that comprise a single scan.
The files in a series usually represent different slices of a volume, and may include repeti-
tions of the volume over time. 
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dow is shown in the figure labeled “DICOM Folder Browser”. On the left 
side of the window (blue box) is a list of the series that were found in the
folder.  On the right side of the window (red box) is a list of acquisition pa-
rameters for the selected series. At the bottom of the window is a text field 
displaying the disk location where files will be saved in MINC format if the
“Convert” button is clicked. 

Acquisition InfoSeries List 

DICOM Folder Browser 

For this tutorial, only the series number 5 and 9 of a longer scanning ses-
sion have been included in the DICOM folder (for faster download). The 
series number reflects the order of the scan in the session. Series 5 is a 
T1-weighted structural scan (the protocol name is Flat Sag 3D revro
scaled3) and series 9 is a functional MRI time series (protocol ge_func-
tionals_644). 

Try loading a series by double-clicking its entry in the series list, or by se-
lecting it and clicking the “Load” button. Each dataset should open in a
new window displaying slices along the three anatomic planes and a plot
of the MRI signal as a function of time for series 9. 

3 Sagittal 3D scan intended for cortical reconstruction and flattening using a reverse
readout and improved scale factor. 

4 Gradient-echo functional scan with a 64x64 image matrix. 
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While NeuroLens can load DICOM files very quickly, it will generally be 
more convenient to export the scans to a format in which there are fewer
files. In preparation for the next Section, specify a location on your disk
where you can create files (e.g. your Desktop) by clicking the “Choose...”
button. Then select both series in the list5 and click the “Convert” button to 
export these series to MINC format at the specified location. A new folder 
will be created at the location you chose and each series will be written to
a single file inside it. 

Exercise 2: Viewing MRI scans 

Finding the data
Now locate the newly exported MINC files in the folder you selected in the
previous session. This folder will be named “demo1-trio-20501-20040113-
083038” based on descriptive information read from the DICOM files6. 
Note also that NeuroLens creates a preview icon that shows the contents
of the file: 

Series 9Series 5 

Folder name 

5 ⌘-A selects all series, or you can ⌘-click to select multiple series one by one. 

6 The hypen-separated fields in this name are: patient name as entered on the scanner
computer, scanner model, scanner serial number, session date, and session time. 
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Loading the data
To open a file, just double-click on the icon or drag it onto the NeuroLens 
icon7. Each dataset should open in a new window.  Note that the window 
for series 9 shows a plot of the EPI8 signal in yellow by default, while the
window for series 5 shows a large view of the central slice instead. You 
can select large image views for series 9 using the tabs at the top of the
window labeled Axial, Sagittal, and Coronal and conversely for series 5 
you can view plots of spatial intensity profile by selecting the Plot tab
(highlighted with green box in “NeuroLens Volume Window” Figure). 

Series 5 
(structural) 

Series 9 
(functional) 

Viewing the data
You can adjust a number of display parameters using controls along the 
menu bar at the top of the window.  You can access a more extensive set 
of controls by clicking the “Inspector” item in the menu bar (this white “i” 
on a blue background). Try adjusting the different parameters - the upper 
and lower window levels are the data values that map to the upper and
lower end of the selected color space (below, yellow box).  The default 
color space for data loaded directly from DICOM is grey - you can change
the colorspace using the popup menu button of the same name in the in-
spector. 

The “Coords” tab of the Inspector Panel allows precise control of the cur-
sor location within a volume, and the “Plot” tab provides controls for the
display of signals. The “ROI” tab allows you to get statistics on data val-
ues within a region of interest that you paint or derive from another data-
set. Note that the controls in the Inspector Panel change when you select 

7 Only DICOM data requires you to open a Folder in NeuroLens, since scans are distrib-
uted across multiple files in a way that is generally not obvious from the file names. 

8 Echo-Planar-Imaging, the MRI technique used to perform high-speed imaging for func-
tional MRI. 
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a different window - the single panel always refers to the currently active 
window. 

Navigating through space
You can navigate to any point in the volume by pointing (clicking) and 
dragging in the image views in the window.  As you move about, the nu-
meric data value of the voxel under the cursor is displayed along the bot-
tom of the screen (magenta box) along with the spatial and time coordi-
nates. 

The idea of this window design is that the three small tri-planar views and the plot
provide an overview of the dataset. You can get a more detailed view by selecting on
of the large tab panes in the right of the window.  

You can zoom in on the location of the cursor by dragging the slider below 
each of the large tabbed slice views. To see the whole image again just 
click the small image at the left end of the zoom slider. 

Inspector Panel Color Legend
Data Value 

View Selection Tabs 

Axial 

Sagittal 

Coronal 

Toolbar 

NeuroLens Volume Window 
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Navigating through Time 
In the functional scan, the default view
shows a plot of the MRI signal in the large
tab pane. You can navigate through 
space in this data as described above,
and also through time by clicking or drag-
ging along the time axis in the plot9. 
When you drag along the time axis on the
plot, pay careful attention to the image
views along the left of the window - you
will see variations in the noise over time 
and small shifts in the brainʼs position. 

Drag 

By default the
range of the signal plot is set to include the
maximum value in the entire dataset, as well as 
zero. If you want to continuously re-scale the
axes to cover the range of the current signal
(providing a more detailed view), check the
Autoscale checkbox in the lower right corner of
the plot tab pane. 

9 You can also step forwards or backwards through time by clicking on any image or plot 
view and holding down the right or left arrow key.  Pressing the up and down arrow keys
will move along a spatial direction, depending on the last image view that was clicked. 
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Coordinate Displays 
The exact coordinates of the current cur-
sor location can be displayed in a number
of ways: 

1.World Coordinates:  these are the coor-
dinates in millimeters in the MRI scanner 
frame of reference. The origin is at the
center of the gradient coils, and X Y and Z 
are along the corresponding gradient 
axes. X increases from subject left to sub-
ject right, Y increases from posterior to an-
terior, and Z increases from inferior to su-
perior.  In the case of a spatially normal-
ized dataset, the world coordinates are in
the MNI space (approximately Talairach). 

2.Volume coordinates:  these are coordi-
nates in millimeters along the rows, col-
umns, and slice normals of a scan. The 
origin is at the lower left posterior corner of
any volume. X increases along the most
left-pointing volume axis, Y increases 
along the most anterior-pointing volume
axis, and Z increases along the most
superior-pointing volume axis. 

3.Index coordinates:  these reflect the or-
der in which the digital pixel samples oc-
cur in the file and in the memory buffer 

Coords Tab used while a volume is loaded. The column co-
ordinate is the fastest varying one, followed by

row, and finally slice. 

You can specify exact coordinates using any of the above formats, under 
the “Coords” tab of the Inspector panel. You can also set which format is 
displayed at the bottom of the window using the “Coordinate Display Type”
popup button at the bottom of this tab (blue box, left), or by selecting Neu-
roLens > Preferences and setting the same control under the “Volume” 
tab. 
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Mosaic Display 
A useful feature is the ability to view all slices 
along a given anatomic plane as a mosaic.
This can be easily done by clicking the “Show
All Slices” checkbox in the large view tabs10. 
This works for all cardinal planes, and clicking
at a location in the mosaic view will cause the 
tri-planar views and coordinates to update to
the correct coordinate. You can also step 
through time in the mosaic view by dragging

the frame or t sliders on the “Coords” Tab. 

Viewing file metadata
Another useful feature is the ability to see descriptive information about a
dataset. You can do this easily in Neu-
roLens by selecting File > Show file 
metadata... in the main menu. This will 
cause a sheet containing a wide range
of information about the data acquisition
settings, subject demographics, and
other topics to drop down in the current
window: 

10 You can also click in any image and press the “m” key to toggle mosaic mode.  Select 
Help > Mouse and Keyboard for a detailed list of keyboard shortcuts. 
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Try clicking on the various tabs (Volume, Acquisition, Demographic, Dis-
play, Processing, and Annotation).  Note that some of this information can 
be edited - the demographic tab allows you to edit information about the
subject (age, weight, etc.) and also to add new fields. Note that these ed-
its only affect the copy of the dataset in the application memory until you 
save the file to disk. 

Note that under the Volume tab you can edit many of the parameters, 
such as the voxel step sizes and the data orientation (Axial vs. Sagittal vs.
Coronal). Changes to these parameters will be reflected in the data dis-
play in real time - this can be useful
when loading non-standard files in 
which images are flipped or displayed
in the wrong orientation. As noted be-
fore these edits do not effect the disk 
file unless the dataset is saved by se-
lecting File > Save or File > Save As... 
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Editing Geometry Parameters 

After experimenting with viewing and editing the file metadata, quit your
NeuroLens session without saving your changes. You will re-load the 
MINC files in the next exercise. 

14




v1.5.0 

Exercise 3: Pre-processing Image Data 

In this section you will load the EPI series (9)
containing the functional MRI data and perform 
preprocessing and statistical operations on it.
All processing modules in NeuroLens are im-
plemented as plugins, which means they can be
developed, packaged, and installed separately
from the core application11. These processing
modules can be accessed under the Actions 
menu, or by selecting the Action item on the 
toolbar of a dataset window12. 

Most Actions provide their own 
online help which should ex-
plain usage details and the underlying method used.
This can be accessed by clicking the purple “?” button in
the lower right corner of a Action menu, or by selecting 
Help > Actions and selecting the appropriate Action 

name. 

Running an Action usually produces a new dataset that opens in its own 
window without modifying the input dataset (the window that was selected
when the Action was launched). 

Load the Data 
First, load the MINC file for series 9 by double-clicking on the file. Inspect
this fMRI data for motion by dragging through time on the plot while ob-
serving the edges of the brain in the tri-planar views. This subject stayed
fairly still, but you should be able to spot small positional shifts around the
edges. Even small shifts like this can cause prominent artifacts in voxels
at the edge of the brain. 

Run Motion Correction 
The first pre-processing step you will apply is Motion Correction. This 
module tries to align each volume in the functional image series to a
specified target frame, to minimize the effects of subject motion during the 

11 This helps keep the main application simple and allows users to extend NeuroLens by
adding their own custom functionality. 

12 Generally some Actions will be greyed out in the menu because they can not be ap-
plied to the current dataset. For example fMRI analysis does not make sense on a data-
set that does not have a time dimension. 
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scan13. Click on the “Action” item (the one with the gear icon) on the tool-
bar of the window for series 9, select Motion Correction, and examine 
the menu that appears. In most cases the default parameters that are
suggested will be appropriate and you can just click “Ok” to run the opera-
tion (donʼt do this yet though). 

In this exercise, the only change you will
make is to request graphs of the motion cor-
rection parameters after running the Action. 
To do this, select the Outputs tab of the Ac-
tion interface and select the Motion parame-
ters checkbox. 

The Action should take a few seconds to 
run and will cause three new windows to 
open: the motion-corrected dataset, a plot
of the estimated brain translations (x,y,z) 

over time, and a plot of the brain rotations (x,y,z) over time.  

Translations Rotations Aligned Series 

You can determine the contents of each window by looking at the title bar 
of the window.  In most cases, in addition to the file name14 there will be a 
description of the dataset as in the example below (Translation Parame-
ters). The description of the aligned series is not changed - the descrip-
tion of the input dataset (the MRI protocol name) is used. You can identify
the motion-corrected series however by the suffix “-MC.mnc” that is added
to the file name of the input: 

13 The motion correction Action is based on source code adapted from AFNIʼs 3dvolreg
program and the method described in Real-Time 3D Image Registration for Functional 
MRI. Bob Cox and Andrzej Jesmanowicz. Magnetic Resonance in Medicine 
42:1014-1018 (1999). We have simplified the code and optimized it to use the Macʼs 
hardware vector processor (AltiVec) for increased performance. 

14 Note that the output of an Action is not written to disk by default, so in this case there is
no actual file until you invoke a File > Save or File > Save As... 
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Examine the plots of the X, Y, and Z translation parameters (red, green, 
and blue respectively). You should notice that the Y translation (green) 
shows a consistent negative drift15. The motion correction plots are shown
in units of millimeters (translation) and degrees (rotation). The vertical 
axes are by default set to a range of ±2 mm and ±2 degrees, to provide a
consistent scaling for the evaluation of motion16. 

Compare the image stability in the original series with that of the motion-
corrected series by dragging the mouse along the time axis in the plot
while carefully inspecting the edges of the brain in the slice views. It can 
also be helpful to “blink” back and forth between the beginning and end of
the series by clicking (not dragging) near both ends of the time axis. 

When you have finished looking at the scans, close all the windows except
for the motion-corrected series (which will be used in the next section). 

Run Spatial Smoothing
The next step in preprocessing is to spatially filter the data. This amounts 
to smoothing each volume using a 3D Gaussian kernel in order to improve
the signal-to-noise ratio (at the expense of image resolution). This prac-
tice is acceptable (in moderation) since the activated regions of interest in
many studies are diffuse and span many voxels.  Moreover the contrast-
to-noise ratio in many experiments is too low to detect parenchymal acti-
vation without smoothing17. 

15 As noted above, X is left-to-right, Y is posterior-to-anterior, and Z is inferior-to-superior. 
Negative Y is therefore in the posterior direction.  This is often seen as the pillow under
the subjectʼs head compresses over time. 

16 Full-scale motions (i.e. of 2mm or 2º) would be considered large. However the impact
of this on the quality of the eventual result depends strongly on the nature of the move-
ment. Gradual drifts in position can be well corrected even if they result in a final position
several millimeters away from the start, and sudden jerks of just a millimeter can cause
severe intensity fluctuations by disrupting the excitation history of a slice. 

17 Acquiring fMRI data at a higher resolution and then smoothing to a lower resolution is
often necessary because acquiring the initial data at too low a resolution will cause ex-
cessive susceptibility artifact. 
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To smooth the data, select the window 
containing the motion-corrected series by
clicking on it. Then open the Action by se-
lecting Spatial Smoothing under the Ac-
tion item on this windowʼs toolbar.  The 
sheet displayed on the left should open.
In this case we will smooth at the default 6 
mm width18, so you can just click OK to
run the Action. 

A single new window should open, con-
taining the spatially smoothed dataset.
The new dataset will appear visibly

blurred, but much of the anatomic informa-
tion (in this already low resolution scan) should still be discernible. The 
range of noise fluctuations visible on the signal (yellow plot) should be
smaller after smoothing19. You can inspect the signal at the same location
in two or more open datasets by ⌘-clicking in an image of one of them.
This will cause the cursor to go to the same location in world coordinates
in all open datasets20. 

Keep the spatially smoothed dataset open (its file name will have the suffix
-MC-SM.mnc) for the next exercise. You may close the previous file 
(whose name ends with -MC.mnc) if you like. 

18 The width is the full-width-at-half-max (FWHM) of the Gaussian smoothing kernel in all
three directions. Note that it is specified in millimeters and not in pixels, and that the
smoothing takes place between slices as well as within slices. 

19 If you click in background voxels with Autoscale turned on, you will notice that the sig-
nal appears discretized. This is due to the fact that the integer storage type of the data-
set is preserved, and the data values can therefore only assume integer values. 

20 Because the world coordinates are synchronized between datasets, the cursor should
go to the corresponding brain location in any dataset acquired in that scanning session -
even if the spatial resolution and slice angulations are different. 
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Exercise 4: Statistical analysis of data


Now you are ready to perform an actual statistical analysis on the data.
This will consist of modeling the signal over time at each voxel as the sum
of a set of a hypothetical response waveforms plus a constant and drift
terms21. The response waveform is elevated during the periods where a
particular stimulus or task was applied. Since there may be more than
one stimulus type applied during the experiment, you can specify more
than one response waveform22. The linear modeling action computes
weighting parameters to apply to the different waveforms to produce the 
best fit, defined as producing the minimum sum of squared errors, to a
given signal (this is done at each voxel). 

This is illustrated in the figure below, where two response waveforms, plus
a constant and three drift terms (blue traces, left) are combined to produce
the purple signal on the right as an approximation to the observed signal
at a voxel (yellow). The parameter values applied to the five waveforms
are listed at the top of the plot on the right23. Note that the use of two re-
sponse waveforms allows the different blocks of activation to have differ-
ent heights. 

Fitting a Linear Signal Model 

21 This approach is commonly referred to as the Generalized Linear Model or GLM. Vari-
ants of this method are used in most major fMRI packages such as SPM, AFNI, and FSL. 

22 These waveforms may also be referred to as basis functions or regressors. 

23 These graphs are taken directly from the NeuroLens views used to specify a model
and display the fit. 
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The model fit produces estimates at each voxel of the response ampli-
tudes (the model parameters) and a measure of the residual error (differ-
ence between the model and the actual data - in practice the standard er-
ror is used24). The probability of a response being “present” (i.e. not a 
random noise fluctuation) at a voxel is computed by dividing the estimated
effect size by the residual standard error and computing the p-value for 
this ratio (the T-statistic).  To assess an individual run, you would view the 
T-statistic or the negative logarithm of the corresponding p-value. The ef-
fect size and standard error can also be viewed and saved (these are
used as inputs to higher level group analyses). Usually we are interested
in the significance of a specific combination of response waveforms, and
these are generally expressed as a contrast. A contrast is simply a list of 
values (one for each basis function) indicating the weight it is to be given
in computing the summary output. In the example illustrated in the figure
above, a contrast of “1 0 0 0 0 0” would produce maps of T-statistic, effect 
size, and standard error including only responses to the first basis function 
(the top one in the graph on the left)25. Now we are ready to run the
analysis. 

Run Linear Modeling 
To fit a linear model to the spatially smoothed 
dataset, click on its window and select Linear 
Modeling from the toolbar Action item.  The 
sheet shown on the left will open in its own
window.  The first thing you will do is specify
the stimulus timing (the design). One way to do
this is to enter the design as “Sampled Regres-
sors” by clicking on the pull down menu and
changing from “Table of Events” (see screen 
shot to the left). In this format, each stimulus
type is represented as a sequence of numbers
(typically 0ʼs and 1ʼs) separated by spaces.
The numbers should be separated by spaces
(no commas) and are read from left to right, top
to bottom. If there is more than one stimulus 
type, they can be represented one after the
other in the editor (white space is ignored). 

24 Calculated by computing the square root of the average squared error and dividing by
the degrees of freedom for the effect (a value slightly less than the number of image 
frames). 

25 A contrast of “1 -1 0 0 0 0” would provide the difference in response to the first and 
second function. The basis functions for which the contrast is zero are often called re-
gressors of no interest. If we want to we can test for any regressor however.  A contrast 
of “0 0 0 1 0 0” would test for a linear drift. 
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You can type this expression directly into the text view on the sheet, or 
read it from a text file (.rtf or .txt). We have provided a text file containing 
a representation of the visual stimulation applied to the subject when se-
ries 9 was acquired. Load the design now by clicking the button labeled
“Read file...” and navigate to the disk image containing the tutorial. There 
you will find a file called “Stimulus Timing.rtf”.  Select this file and click 
“Open”. The contents of the file should be displayed in the design expres-
sion editor and a checkmark should appear beneath it, signifying that the
design is valid for this dataset26. After you have performed this step the
action interface should look like this: 

Stimulus Block 

Right Hemifield 

Stimulation 

Left Hemifield 

Stimulation 

26 If the design expression is not valid, a red ! symbol will appear.  Usually this is due to
the use of commas in the expression or because the number of values supplied is not a
multiple of the number of frames. 
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The design entered describes two stimulus types (visual stimulation of the
left and right halves of the visual field)27. 

To visualize the design bring up the “HRF 
and Model” window, displayed on the left, 
which should have opened when the Linear
Modeling Action was first run.  The bottom 
window pane shows the two stimulus types
you have specified (green waveform, fol-
lowed by blue waveform) plus a third order
polynomial used to model baseline plus
drift. Itʼs a good idea to always look at this
view after entering a design to make sure it
looks as expected. 

You may notice that the response wave-
forms appear to have been slightly
smoothed (the corners are rounded). This 
is due to the application of an assumed
hemodynamic response function (HRF) in
this analysis mode. This is intended to ac-

count for the fact that the BOLD response28 is not instantaneous but rather 
occurs with a small lag and dispersion. This is usually described using the
impulse response (the response to an idealized short stimulus), which has
been found to be reasonably approximated in fMRI by the sum of one or
more gamma functions29. The HRF used in the current model is viewed 
as the red waveform in the top pane of the above screenshot. The view 
shows a plot of the assumed HRF sampled with the inter-scan interval of
the input series. You can modify the parameters of the HRF by clicking on
the “HRF” pane of the Linear Modeling actionʼs window.  From this page,
you can also change the polynomial drift order or perform pre-whitening of 

27 Periods where a given stimulus was applied are specified by a value of one in each
sequence in this example. The number sequences for the two stimulus types are sepa-
rated by a blank line for clarity (white space is ignored). Note that the organization of
stimulus blocks into rows of values is optional (also for clarity). The above design could
just as well be specified by a single column with 180 rows, or by entering all 180 values
on a single line. 

28 The blood oxygenation level-dependent response that is the most commonly used con-
trast mechanism in functional MRI. 

29 The default in NeuroLens is to use a single gamma function, which approximates the
small delay and dispersion of the response. Some (but not all) stimulus types lead to
responses in which an overshoot and undershoot are seen. This can be modelled by
adding a second negative gamma function with suitable width and delay.  Checking the
“Undershoot” box will do this. 
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the data using the AR1 parameter.  For this exercise you do not need to
change any of the settings from their default values. 

The final bit of configuration you need to do before
running the Linear Modeling Action is to specify the 
contrast. You can view and change this by clicking 
the “Contrasts” tab of the Linear Modeling actionʼs 
sheet. The default contrast in NeuroLens is always a
single “one”30. This will test for a non-zero value of 
the first regressor.  Change the contrast by clicking
on the number “1” in the list31. Change the default
“1” to “1 -1”. This will test the difference between the 
responses to left and right hemifield stimultion at
each voxel. Now change the default “Contrast #1” to
something more descriptive like “Left - Right”. When 
you are finished the list should look like the one on
the left. 

Now you are ready to go! Click the RUN button to run the action. In a few 
seconds a map of the -log(p) value32 should appear in a new window33. 
You should also see a new curve plotted in purple in the window of the in-
put dataset. This is the estimated signal model at the current cursor loca-
tion. Compare with the yellow observed signal. 

30 The contrast string entered in the sheet is padded with zeros so that its length equals
the number of regressors. For convenience you only have to specify up to the last non-
zero value. 

31 It is possible to evaluate several contrasts at once. You can add additional contrasts 
by clicking the “+” button below the list. 

32 this is the negative logarithm of the p value associated with the T statistic for that voxel. 

33 Other output maps are available and can be selected under the “Output” tab of the ac-
tion sheet. For this exercise you will just produce the default map of -log(p). 
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Input dataset with 
Map of -log(p)

model fit 

View the model and activation map
Here it will also be useful to synchronize coordinates in multiple windows
by ⌘-clicking at very red or blue locations in the -log(p) map 34. After doing
this look at the signal in the input dataset (the spatially smoothed one).
The appropriate response term (left or right stimulation) should be very
prominent in the modeled and observed signals. 

Overlay the activation map on other scans
The activation map alone is difficult to interpret because there is no anat-
omic contrast. This can be addressed easily in NeuroLens by overlaying
the activation map on the source EPI scan or, better yet, on the subjectʼs 
high-resolution anatomic scan. 

34 The -log(p) map is by default displayed using the Spectral color scale. In addition the
-log(p) map is also displayed with symmetric windowing, which means the upper and
lower window limits will be equal in magnitude and opposite in sign. This forces zero val-
ues to be green regardless of the overall data range. In the Spectral color scale “colder”
colors (blue, purple, black) denote negative response while “hotter” colors (yellow, red, 
white) denote positive activation. 
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Overlay the -log(p) map on the time-
series EPI scan by clicking the
popup button marked “Overlay” in
the toolbar of the EPI time series 
and selecting the -log(p) map from
the list that appears35. The statisti-
cal map should immediately be dis-
played as a transparent overlay over
the EPI scan. You can adjust the 
opacity of the overlay by dragging
the Opacity slider in the Inspector
panel. You can also set a threshold 
below which values in the overlay 

dataset are made completely trans-
parent. Note that when an overlay is
active, the color legend, content de-
scription, and some image controls
for the overlay are displayed in the
Inspector panel for the underlay.  You 
can remove the overlay by setting the
Overlay popup in the toolbar to
“None”36. 

Overlaying the -log(p) map on the
EPI scan from which it was derived 
seems natural because they have
the same image dimensions. In 
NeuroLens it is also possible to over-
lay an activation map on a high-
resolution anatomic scan even 
though the image dimensions and
slice angulations are in general dif-
ferent. The procedure is the same
as before - just open the anatomic
scan from the demo dataset (series
5) and select the -log(p) map from 

35 You can also assign this overlay by holding down the Option key and dragging one of 
the -log(p) map images over the window of the EPI dataset and dropping it onto one of
the EPI image views. A third way is to click in a -log(p) map window, select Edit > Copy, 
and then Edit > Paste after clicking in an image view of the EPI series. 

36 You can also remove an overlay by clicking in any image view and typing “x”. 
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the list under the Overlay popup in the windowʼs toolbar37. The -log(p)
map will be immediately interpolated onto the high resolution scan, allow-
ing you to view the functional information in a much better anatomic con-
text. 

Save the statistical map
Save the map of -log(p) to disk by clicking on its window and selecting File 
> Save As... from the main menu. You should save it to the same folder 
as the converted MINC files for series 5 and 9. 

Leave the individualʼs -log(p) map and high-resolution anatomic scan open
for the next exercise. 

View the processing history
A useful feature of NeuroLens is the ability to view the processing history 
of a dataset. This can be done simply be selecting File > Show file me-
tadata... . The “Processing” tab in the sheet that opens (shown below)
contains a list of the processing steps used to generate the dataset in
question. Clicking the disclosure triangle of a step reveals the settings
used for that operation. Under the Processing tab there is also a vertical
tab containing Results and Settings. The Results pane shows any de-
scriptive parameters that were computed in a processing step (e.g. de-
grees of freedom in a statistical analysis). 

37 You can also copy and paste (⌘-C/⌘-V) an image onto another dataset to assign it as
an overlay.  This way is often easier if the windows are overlapping. 
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Exercise 5: Spatial normalization 

It is often desirable to transform an individualʼs brain data into a standard-
ized coordinate system so that visualization may be performed under
more consistent settings or so the data can be pooled for group statistical
analysis. 

NeuroLens provides a module which allows you to compute the transfor-
mation required to align an individualʼs whole-brain EPI scan with a group
average EPI brain38 in Talairach coordinates.  Once this transformation is 
computed, it can be applied to the individualʼs activation maps to resample
them into a standard format that can then be used for visualization or 
group statistical analysis. 

The Volume Registration Action allows you to supervise the fitting proce-
dure. If the fit begins to go off track, you can pause the automatic fit and 
adjust the transformation parameters manually.  You can then resume the 
fit to see if the numerical optimization will converge to an optimal solution. 

Run the Volume Registration Action
Make sure the individualʼs EPI series (#9) is open. Click on its window to 
make it current, then select Actions > Volume Registration. The window 
shown below should open: 

38 Some software packages compute a transform based on the subjectʼs high-resolution
anatomic scan and then apply this to their activation maps, which are derived from the
subjectʼs EPI scans. We chose to focus on an EPI-based alignment because it is the EPI
scans which need to be accurately aligned for group analysis. Moreover it appears that
EPI-based registrations may be less prone to bad fits due to the numerical optimization
procedure getting trapped in local minima. 
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The “Setup” tab displayed by default shows the settings used in the multi-
step alignment procedure. Three passes are performed, with successively
less smoothing and subsampling of the source and target datasets. Each 
step also includes a different set of alignment parameters that are allowed 
to vary - these can be selected using the checkboxes in the columns for
the different fit parameters.  We will use the default steps here. 

To start the registration procedure you will 
need to specify a target (the “Fit” button is
disabled until you do so). You will use a 
group average EPI scan in MNI space as a
target. To open this dataset, click the button 
labeled “Show Standard Targets”. This will 
cause the sheet shown on the left to open.
Select the file 3T-EPI-Target.mnc and click 
“Open”. The selected target39 should open in
a new dataset window and it will be assigned
as the target in the
action window. 

Click on the Volume Registration window to 
make it current again, and select the “Fitting”
tab to see a display of the fitting progress. At 
this point the progress display will show the
input dataset (series 9) overlaid on the target
with no transformation applied: 

40 Subject 3T EPI Target 

39 This dataset is an average of 40 gradient-echo EPI scans acquired from different indi-
viduals at 3 Tesla and registered to the MNI standard space. 

28




v1.5.0 

As you would expect, there is substantial misregistration at the start. To 
begin the alignment, click the “Fit” button. You can follow the progress of 
the fit in the three overlay views - the opacity of the overlay can be modi-
fied using the vertical slider to the right of the views. You should see the 
input dataset (blueish purple) aligned reasonably well over the target
(greyscale). 

When the text for “Current Registration
Phase” changes to “Finished” the reg-
istration is complete. At this point a
transformation has been computed that
represents the optimal alignment of the
source to the target. You can open this
transformation as a document40 by
clicking the “Open Transform” button 
under the “Fitting” tab of the Volume 
Registration Action.  A new window will 
open like the one shown on the left. To 
save this transform, click on the trans-
form window and select File > Save 
As... 

The saved transform can be loaded later and assigned as the initial trans-
form of the Volume Registration Action.  You can then use the action to 
resample volumes using this transform. 

40 A document is any data that can be loaded in NeuroLens using the File > Open com-
mand. Documents are displayed in the Recent Files menu and under the Windows 
menu. Supported document types include volumes (which may be time series), surfaces,
fiber tracts, and transforms. 
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Make sure you leave the Volume Registration window open, because weʼll 
use it in the next step of this exercise. 

Resample the activation map
Now youʼve computed the transform, but it hasnʼt been applied to any da-
tasets. First weʼll resample the -log(p) map generated in the previous ex-
ercise using the computed transform. Make sure the -log(p) map is still
open from the previous exercise41. In the window of the Volume Registra-
tion Action, select the “Resampling” tab.  Configure the two popup buttons
in the interface so they look as shown below: 

This will cause the -log(p) map (suffix -logp-c1.mnc) to be resampled at
the voxel locations of the EPI target (a standard voxel grid) using the
computed transform. Note that at this point you will not be able to change
the transform (that popup is dimmed), because the current instance of the
Volume Registration Action has been used to perform a fit.  If no fit has 
been performed you can set the transform popup to any loaded transform
document (allowing you to resample a dataset using a transform loaded
from disk). Click the “Resample” button, and in a few seconds you should
see a new window open with a resampled copy of the -log(p) map. 

Now click in a slice image of the resampled
-log(p) map and type ⌘-C (copy to clipboard),
then click in a slice image of 3T-EPI-Target.mnc 
and type ⌘-V (paste). This will cause the re-
sampled statistical map to be overlaid on the tar-
get. You should see the regions of visual activa-
tion overlaid at the approprate locations in the
occipital lobe (as shown at left). 

-log(p) map overlaid 

on EPI target 

41 By now you may have several windows open, which can be cluttered on a small dis-
play.  This is a good situation to use Exposé, which allows you to tile windows. To ar-
range all of the NeuroLens windows side by side, press the F10 key.  It should then be 
easy to select the -log(p) map. 
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Verify the registration
It is generally a good idea to check the registration quality by resampling
either the individualʼs anatomic scan or their EPI scan and overlaying it on
the target dataset. Using the steps described above for the resampling
stage (keep the Volume Registration window open - you donʼt need to 
redo the fit), resample the subjectʼs anatomic scan (series 5) and their EPI
scan (used as input to the Volume Registration) with the already computed
transform and overlay it on the EPI target. You should see a fairly good fit,
although being a linear transformation it will never be perfect. 

Locate peaks in the activation map
It is often desirable to locate the set of peaks in the -log(p) map that are
above (or below) a certain threshold. This can be done by clicking on the
window of the spatially normalized copy of the -log(p) map and selecting
Actions > Find Peaks. The sheet below should open: 

For this exercise specify an amplitude threshold of 10 (p≤10-10) and a clus-
ter size threshold of 625 voxels (about 5 ml). Click OK to run the action,
and a window like the one shown below should open. 

The new window contains two tabs, “Positive” and “Negative”. These con-
tain a list of all the local maxima (or minima) at which the absolute value of 
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the data value exceeds the specified threshold (in this case 10) over at
least 625 adjacent voxels (5 ml)42. Note that there can be several local 
maxima within each cluster.  By default the table is sorted so that the
highest value in the whole dataset is at the top of the list (the most nega-
tive value will be at the top of the list under the Negative tab). The world 
coordinates of each local maximum are also given - in this case, because
the input dataset is in MNI-Talairach coordinates, these values are the 
MNI-Talairach coordinates of the peak.  If we were to operate on a native
space (non-spatially normalized) dataset these coordinates would simply
be in the world system for the session. 

The cluster ID refers to the set of contiguous voxels in which a peak lies.
These can be displayed by checking the “Cluster IDs” box when running
the action. The cluster IDs are assigned in decreasing order of cluster
size (largest = 1)43. The cluster volume in milliliters is also given. The 
column labeled “Comments” can be used to annotate the peaks. 

42 This may seem like a lot of voxels, but remember that the spatially normalized -log(p)
map has been resampled onto a sampling grid with a spacing of only 2 mm. 

43 The rows of the table can be sorted based on any of the columns. To group all cluster 
IDs together click on the Cluster ID column heading. Within clusters the secondary sort
order will be whatever was in effect before re-sorting.  Clicking the Peak heading followed
by the Cluster ID heading will group clusters together with peaks sorted by height. 
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Note that, if you double-click any row of the tables, the cursor location in
all open datasets will go the coordinates of that peak. Try double clicking 
on the first row of your list of positive peaks (the entry in the Value column 
should be 66.52757). The cursor in the spatially normalized -log(p) map
should go to the hottest spot in the entire volume44. Conversely if you ⌘-
click at a location in the spatially normalized -log(p) map, the closest row
in the table will automatically be selected. Try these actions (double-
clicking table rows and ⌘-clicking in the input dataset) a few times to get
familiar with this feature. 

You can export the annotated list of peaks to any word processing or 
spreadsheet program by selecting the peaks you want (⌘-A to select all) 
and clicking the button labeled “Copy selected rows to clipboard”. Then 
select the document where you want to insert the table and perform a 

44 Note that the coordinates in the non-normalized volumes will not be correct, since the 
peaks are listed in the space of the normalized -log(p) map. 
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paste (⌘-V). We will look at more methods of exporting data in the next 
lesson. 

Peaks table exported to 

Excel spreadsheet


In the final lesson you will need the spatially normalized copies of the sub-
jectʼs anatomic scan and their -log(p) map. Save these to disk and/or
leave them open in NeuroLens. You will also use the native space -log(p) 
map and original EPI scan. 

34




v1.5.0 

Lesson 6: exporting results 

Now that you have performed a complete analysis of an fMRI run45, it may
be useful to export the results to a word processing program or email them
to a colleague. NeuroLens has a number of features which makes this 
convenient. 

Arranging the figure
Open or select the spatially normalized -log(p) map. Click in any of the
slice images and type ⌘-C to copy this dataset to the clipboard. Press 
the F10 key to tile the dataset windows via Exposé and select the spatially
normalized anatomic map. Click in an image view of the normalized anat-
omic map and type ⌘-V to paste the -log(p) map. 

Copying and pasting images
Now open the Inspector for the normalized
anatomic scan by clicking the Inspector toolbar
item (or typing ⌘-I)46. Type a value of 20 into 
the Threshold field in the Overlay box and hit 
return47. Drag the Opacity slider in the Overlay
area all the way to the right so the value is 1.0.
Uncheck the Visible box under the Cursor area 
to make the cursor invisible. The axial view of 
the overlay should look like the image on the
right, with most of the activation map transpar-
ent (the regions below the threshold). 

To export this graphic, open a Word document 
or email. Click in the NeuroLens image you
wish to export, and type ⌘-C to copy the image. Then click in the docu-
ment and type ⌘-V to paste the image. This works on both slice images
and plot views. 

You may also want to grab a copy of the color legend.  Just click on the 
color legend in the Overlay area of the normalized anatomic scanʼs In-

45 Group analyses will be covered in Tutorial II. 

46 ⌥ refers to the Option key. 

47 Entering values into text boxes generally does not take effect until you type return or 
tab to leave the text box and commit the change. 
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spector panel, type ⌘-C, and paste it into the document by typing ⌘-V 48. 
The result should look like this: 

-60 -40 -20 0 20 40 60 

If you want to paste the color legend into a document (like a slide) with a
dark background, you can change the default text color used when copy-
ing by opening the Preferences window and clicking on the color well un-
der the Copy & Paste tab: 

You can also adjust the colors and display settings used for plots of sig-
nals. This can be useful in adapting figures for export into non-color
documents or slides. 

48 Most things that can be done using copy and paste can also be done by Option-
dragging the item you wish to export. ⌘-C is a shortcut for Edit > Copy. 
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Adjusting plot display settings 

The adjustment shown above was achieved using the plot settings in the
Inspector panel shown below. 
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Plot display settings

The plot display settings can be changed using 

the controls shown on the left. You change plot 

colors by selecting a signal in the Plot list and 

clicking the color well in the box labeled 

Selection. Note that you can select multiple 

rows in the list (!-clicking or !-A) and adjust 

the parameters in the Selection box. The 

changes will be applied to all selected rows. 

The color and weight of the axes as well as the 

fonts used can be adjusted using the controls in 

the Axes box.  If you want your changes to be 

propagated to all open datasets you can click 

the "Use for all" button. If "Only same type" is 

selected then only datasets with the same 

content description (seen in the title bar) will be 

changed. 

Saving image graphics to disk
In addition to copying and pasting, you
may want to save an image in NeuroLens
to a disk file. This can be done easily by
control-clicking on the image and select-
ing “Save image to file...”. In the Save 
dialogue that opens select the folder
where you want to put the file, give it a
name, and click Save. 

The save format will be either TIFF or 
PDF - you can set this under NeuroLens 

> Preferences > Copy & Paste as shown 
below. 
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PDF is a vector format that will allow plots, text, and the cursor crosshair
to be scaled without loss of quality.  You can load the PDF file into pro-
grams like Adobe Illustrator if you need to fine-tune the appearance.  TIFF 
is best suited for image data. 

Exporting data for use by other programs 

Sometimes itʼs useful to export the
actual numerical data for further 
processing in a program like Mat-
lab or Excel. This can be done by
copying the signal values to the
clipboard and pasting into another
program or by saving the values to
a text file. 

39




v1.5.0 

Conclusion 

This concludes the first NeuroLens tutorial. Hopefully you now have a feel
for how to perform basic operations in the software, providing you with the
tools needed to analyze an fMRI run. Topics not covered here include 
group statistical analysis, region of interest (ROI) analysis, and surface-
based visualization. These will be covered in subsequent tutorials. 

Where to get help
There are several sources of help and documentation for NeuroLens.
These include: 

• online help for NeuroLens and actions accessed using the Apple help 
system 

• an online userʼs forum at http://www.neurolens.org/forums/ where you
can post questions, feature requests, and report bugs. 

• these tutorials 

Hopefully these will be useful! 
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