
 
  

 
 

        
        

                     
      

   
            

      
           

             
          

 

         

 

               
     

Introduction to GIS & Mapping: ArcGIS 
Desktop 
Your task in this exercise is to determine the best place to build a mixed use facility in Hudson County, NJ. In 
order to revitalize the community and take advantage of special loans, you want to build your facility in an area 
with at least 1.5 times the national unemployment rate (It was 4.4% as of August 2017, which is the year of our 
data). You will also explore what sort of railroad transit is available in this area. 

Open ArcGIS Pro 
1. Before you begin, decide where you will be storing the GIS files that you will be downloading and 

creating in this exercise. You can create a working folder on the desktop or in the Documents folder. The 
exercise data is in the folder you downloaded before the workshop in the folder Data\Final Exercise. 

2. Open ArcGIS Pro (Start (Windows icon)) > All Programs > ArcGIS > ArcGIS Pro). You will see an open 
screen where you can create a new map from a blank template. Click on “Map” to do so. 

3. You will see a new form where you will name your project and where it will be located: 

4. Uncheck the “Create a new folder for this project” checkbox and select the folder where you 
downloaded the data to (and not the folder that actually contains the data). 
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Arcgis Pro is designed like most Windows programs.  All of the menus are context sensitive. In the top area (the 
toolbar), you see a number of tools. Those tools change with the selection of tabs and depending on what data 
layers you have highlighted. 

Add a basemap from ArcGIS Online 

Notice that the map you created is not blank, but includes a default basemap. You can change the basemap if 
you choose: 

1. Click the Map tab and Basemap. 
2. Click on Imagery. 

Note that the layer is served over the web so it may take some time to draw (and you have to be connected to 
the internet for it to continue drawing). What you see depends on the scale you are working in on your map - as 
you zoom in closer you will typically find more detailed information. Your scale is displayed below the map and 
automatically adjusts as you zoom in and out. 

To navigate your data, you will primarily use these buttons in the Map tab: 
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From left to right, top row first, they are used to Zoom to the extent of all layers in the map, zoom to selected 
data, fixed zoom in, and fixed zoom. You can use the scroll button on your mouse to zoom in and out and you 
can left click and hold the click to pan around the map. 

Find and add data 
As you learned, there are many sources for GIS data. We will first find transportation data for New Jersey. 

1. Go to: http://njogis-newjersey.opendata.arcgis.com/datasets?t=Transportation. This shows all the open 
transportation data for New Jersey. We found this site by doing an internet search for “new jersey gis 
data.” 

2. Search for “railroad” in the top search box. Options should drop down from the search box. View the 
Passenger Rail Stations data layer by clicking on its name. 

3. A page opens that previews the data on a map. Click the download icon to the left of the map. 

4. A download pane opens on the left side of the screen. Click Download under Shapefile. 
5. While the file downloads, click the information icon. 

Brief metadata is provided in the sidebar. Click the View Full Details button to see more. 
6. Return to the search box and repeat this process to locate and download the Railroads Network. If you 

want to explore any other data from this area, feel free to download it. 
7. Move the data to your working folder and unzip each file by right clicking and selecting 7-zip > Extract 

here (or use whatever data extraction tool you have installed on your computer). 
8. Click the Add Data button on the Map tab and navigate to your working folder where you unzipped the 

data and add it to the map. One is called Railroads_Network and one has a long code name. 
9. Right click on each layer name and select Properties. In the General tab rename Railroads_Network to 

Railroad_Stations and the long code name to Railroad_Lines. 
10. In addition to the transportation data you just downloaded, add census unemployment data from the 

workshop materials. It can be found in GIS_Level1_Data\takehome_exercise. 
11. Right click on Hudson_tracts and select Zoom to Layer. 

The US Census divides the country into continuous polygons and aggregates census data for these polygons 
before releasing the data to the public so that individual responses cannot be identified. Our data is for 
census tracts, which contain between 1200 and 8000 people total. 

12. In the Table of Contents of ArcGIS (where all layer names are listed) turn the layers on or off using the 
checkboxes located to the left of each layer name. Leave the basemap layer unchecked for now so that 
the next few steps will go more quickly. 
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13. Adjust which layer draws on top by dragging layers above or below one another. You will want your rail 
stations and rail lines on top so they won’t be covered by the census tracts polygons. If your layers will 
not drag, click the List by Drawing Order button at the top of the table of contents. 

Explore the attribute table 
1. Right click on each layer and select Attribute Table. 

Every point, line, or polygon file has an attribute table. Any data in the attribute table can be used for displaying 
and labeling on the map and making queries. You can also create new columns in the table and add data or 
calculations. Metadata can be key to understanding attribute tables that use codes and abbreviations. 

2. Leave the attribute table for the tract unemployment data open. 

Can you tell what any of the column headings mean? It’s unlikely, so you will need to look at the metadata. 

3. Open the text file (outside of ArcGIS Pro) that is in your Data\Final_Exercise folder. You now see the 
definition for each column. This data was downloaded from a database called Social Explorer, and joined 
to a polygon file from the US Census. 

Variable A17005_003 is the number of unemployed people in the civilian population. Is this what we want to 
map? Why or why not? 

Mapping raw numbers is usually not useful because the total population in one census tract may be more or less 
than another. One way to “normalize” the data is to take into account the total population and calculate a rate. 

4. At the top of the Attribute Table, click the Add field button. 

5. Name the variable Unemp_rate and choose the type as double (you may need to double click on the 
Data Type box in order to select it with the cursor). Close the Fields window with the “X” and save your 
changes. 
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6. Right click on the new column that was added and select Calculate Field. 

We want to divide the number of people unemployed by the total number of people in each tract. Based on the 
metadata, which columns will you use? 

7. Add fields to the equation by double clicking on them in the list. Make sure your equation matches this 
one: A17005_003! / !A17005_001! and click Run. Be patient, it will take a few seconds. 
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We want to find tracts that are 1.5 times the national unemployment rate. This is equal to .066 or greater. 

8. Click the Table tab at the top of the window, then Select By Attributes. Keep all of the defaults and then 
click Add (+) New Expression then Create a new expression. 

9. In the Where clause of the expression, you will notice three fields: 
a. In the left field, change the column that you want to work with from FID to Unemp_rate in the 

dropdown list. 
b. In the middle field, change “is equal to” to “is greater than or equal to”. 
c. In the last field, enter 0.066. Click Run to select the tracts that have an unemployment rate 

greater than 0.066. 

All rows that correspond to a tract with a higher than average unemployment rate are highlighted and the 
corresponding tracts are highlighted on the map. 

10. Close the Attribute Table. 

Export to a new file 
We will export the selected tracts to a new data layer so that we can more easily visualize which tracts have high 
unemployment. Exporting a smaller area of data is the easiest way to subset a dataset to only the desired 
records or keep your file sizes smaller and more manageable. 

1. Make sure the Hudson_tracts is highlighted in the table of contents. 
2. Click the Data tab and Layer from Selection. Note that this layer is temporary until we export it. 
3. Right click on the new layer created from the selection and select Data > Export Features. 
4. Click on the folder icon to view and edit the save location. Select the folder where you want to save the 

file (you’ll name the layer in the next step). 
5. In the Output Feature Class box name the layer unemp_high. 

Note that file names and locations can be very important when working on projects. GIS software tends to 
generate many files, so you want to make sure to use file names that are descriptive and easy to remember in 
the future. 
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6. Click Run. 
7. Clear the selected features by selecting the Clear button in the Map tab. 

8. Save your map document. 

Symbolize data 

Change a single symbol 
Rather than completely covering the unemployment polygon layer with the one for high unemployment, we can 
change the symbology of the high unemployment layer so that we can still see the tracts for the entire county 
underneath. 

1. In the table of contents, double click the colored rectangle below the high unemployment layer 
(unemp_high) and change the fill to a pattern, such as 10% simple hatch (you will have to scroll down to 
find it). That way we can still see the unemployment tract data layer underneath. 

2. Close the Symbology box. 

Explore data distribution 
Before we make a choropleth map of the unemployment rate, we need to examine our data in order to create 
the most appropriate map. A quick way to explore the distribution of our data in ArcMap is to make a graph. For 
future projects, you will likely want to explore your data outside of ArcGIS in statistical or data visualization 
software in order to better understand it. 

1. Click on the Hudson_tracts_unemp_2017 layer in the Table of Contents. 
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2. At the top of the window under Feature Layer, select the Data tab. 
3. Click Create Chart, choose Histogram. 
4. Choose Unemp_rate as the Number. Feel free to change the number of bins and see how the histogram 

changes. 

This histogram is showing the number of tracts (y axis) that fall into each unemployment range (x axis). Not all 
ranges are shown because of size constraints on the axis, but this still gives you an idea of the general shape of 
your data. We see that unemployment rate is relatively low, but that there are some outlying tracts with a high 
employment rate. 

5. Close the Chart Properties box and the chart itself. 
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Make a choropleth map 
1. Make sure the Hudson_tracts_unemp_2017 layer is highlighted in the table of contents.  At the top of 

window, click the Appearance tab. Click on the dropdown triangle below Symbology and select 
Graduated Colors. This will open the Layer Properties window. 

2. Select "Unemp_rate" as the Field. 
3. Symbolize the data in whatever way you think is best. Map symbology can be used to alter the way 

people view and understand information, just like statistics. It is important to understand what you want 
to express in your map and how to best symbolize your data. 

a. Chose a classification method and number of classes. In order to help you choose a classification 
method. Here is more information about each method: https://pro.arcgis.com/en/pro-
app/help/mapping/layer-properties/data-classification-methods.htm 

b. Pick a color scheme from the drop down menu. 
c. You can adjust the number of decimals shown by clicking the Advanced symbol options button 

and adjusting the Rounding options. 

4. Close the window when you are finished. 
5. Save your map document. 

Do you have an idea about where you might build based on the unemployment rate? Obviously many factors go 
into selecting a building site. We will examine one more: train access. 

Find tracts that have railroad stations 
You will use the Select by Location tool to select all tracts that contain a railroad station. 
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1. Click on the Map tab. In the Selection menu at the top, click “Select By Location”. 
a. For the Input Features, choose Hudson_tracts_unemp_2017. 
b. Change Relationship to Contains. 
c. For the Selecting Features, choose Railroad_Stations_in_NJ. 

2. Click Run. Now all tracts that contain a railroad station are highlighted in blue. This is temporary until 
you clear the selection. 

3. Make these into a temporary layer again in the Data tab using the Layer from Selection button. We don’t 
have to export them to a permanent layer this time. 

Choose a tract for building 
1. With the Hudson_tracts_unemp_2017 layer selected in the Table of Contents click the Map tab and the 

Clear button. 
2. Now choose the Select button in the tab. Click on the tract that you want to build in, based on the 

visualization you have made. You can select more than one tract by holding the Shift key as you make 
your selection. 

3. Again, create a layer from the selected data. Export the data using the method in the Export to 
A New File section of the exercise. 

4. Clear the selection once you have exported the layer and change the symbology of the layer to show it is 
the one you selected for building. 

5. Wondering what area was actually chosen for this building? Add Bay_street_building from 
Data\Final_Exercise. You may need to double click on the point symbol and adjust the size to see it. 
Read the article here. 

6. Make final changes to the color of any of the data layers and zoom and center your map to prepare for 
creating a layout. 
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Create a layout of your map 
1. At the top of the window, in the Insert tab select New Layout. 
2. Select 8.5” x 11” Letter under ANSI Landscape. 
3. You should have an empty page. Click the Insert tab and Map Frame. Select the image of your map. 

Draw a box where you would like the map placed. Drag the corner of the map to fill most of the page 
but leave room for a title, scale bar etc. If you need to adjust the scale once the map frame has been 
inserted, select or type in a value in the scale bar at the bottom of the screen (the smaller the number, 
the more zoomed in the map). 

4. Click on the Insert tab and Legend. You need to drag the box big enough to see all of the entries. Only 
the visible layers in your map will be included in the legend. 

5. Using the same procedure, insert a North arrow. 
6. From the Text dropdown (it will say rectangle now), choose Text and place it on your map. Write a title. 

Export your map 
1. Click on the Share tab. 
2. Click Export Layout from the Output section. 
3. Choose PDF in File Type and select the location to save to. 
4. Click on the Export button. 

Note that if you save as an AI (Adobe Illustrator), the layers will remain as separate, editable layers in 
Illustrator. If you save as JPEG or TIFF, you can adjust the resolution of the exported file. 

5. Open your map in Adobe Acrobat to see what it looks like. 

Save your ArcMap document 
1. Click Save button. 

Note that when you save an ArcGIS Pro document, you are only saving a link to the layers in your project. If you 
move your project to a new location, you will need to move all the files linked to your project with 
it. Each shapefile has multiple files associated together, and they need to stay together to work properly! It is 
best to save all files in the project folder so they are more transportable with the project. 
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