Overview ........................................................................................................................................ 2
Introduction ................................................................................................................................... 2
Logistics/Mechanics ................................................................. 2
Background: What is a Web Site? How should it be designed? ......................................................... 2
Section I: Setting up your Accounts ......................................................................................... 4
   Step 1: Getting Your Athena Account ................................................................................. 4
   Step 2: Accessing Your Sloan Account .............................................................................. 5
Section II: Building Web Page Files ....................................................................................... 5
   Microsoft FrontPage ............................................................................................................... 5
Section III: Publishing your Web Site ...................................................................................... 12
   Preparing Your Athena Account for Web Site Publishing ............................................... 12
   Transferring Your Web Page Files and GIF Picture Files to Your Athena Account ......... 12
   Accessing Your Published Web Site .................................................................................. 13

All contents Copyright © 2001 MIT Sloan School of Management
Overview

Introduction
The purpose of this note is to give you first-hand experience with publishing information on the World Wide Web (WWW). You will go through all the steps involved in web site design, construction, publication, and use, thereby gaining a practical appreciation for the power of this new medium for organizations. The note involves using Microsoft FrontPage, an application specialized in editing and publishing information on the WWW.

Logistics/Mechanics
This note involves using Microsoft FrontPage to browse, build, edit, and test your web site. Furthermore you will be using a Telnet application (preferably Host Explorer – downloadable from MIT, see page 22) to remotely connect to your Athena account (available to you as an MIT student) in order to prepare your web site for publication and a file transfer application (SecureFX – also downloadable from MIT, see Section IV)

If you are not a Sloan student, you have to immediately contact us in order to get an account at the Sloan Computing Labs

Background: What is a Web Site? How should it be designed?

The WWW can either be an extremely powerful tool for information retrieval and exchange, or a chaotic labyrinth full of dead ends and out-of-context data. The difference lies in how well the information that is posted on the web has been chosen and designed. Considering what and how to display information on the web is what Stephen Wilson calls “expanded design” in his “World Wide Web Design Guide” (Hayden Books, 1995). Wilson defines expanded design for the web using four principles:

• *Surrounding Context*: Why is the site being created? What is/are its target audience/s? What is the site’s definition of significant information? What other web sites cover related material, and how do they do it? Why use the web as a publishing medium at all?

• *Information Structure*: How well is the information structured? What categories of choices are offered? What conceptual frameworks seem to underlie those categories? How is the information structure made clear to web visitors?

• *Interactivity*: How is interaction orchestrated? What links are there? How are navigational options made clear? What would be typical navigational scenarios? What multimedia tools are being used (text, hypertext, image, video, sound?) How well are they used? How fast does a page load? (studies have shown that users leave slow sites!)

• *Visual Impact*: On first view, what will be most noticeable about the site? What will engage visitors? How does the site’s presentation work visually? How does its composition influence its effectiveness and appeal? What will visitors find new or surprising about the site?
Although you may have used the web extensively in the past, you may not have thought critically about the above aspects. Please head out browsing the WWW and look at a couple of web-sites thinking about the design principles mentioned above and in the handouts. It will help you to discover some pitfalls of web-page design and improve the design of your own home-page. Furthermore you may find some sites that you would want to link to from your own home-page.

<table>
<thead>
<tr>
<th>RATIONALE FOR SELECTION</th>
<th>WEB SITE NAMES</th>
<th>ELECTRONIC ADDRESSES (URL)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Consulting firms</td>
<td>Bain and Company</td>
<td><a href="http://www.bain.com">http://www.bain.com</a></td>
</tr>
<tr>
<td>(explore career opportunities)</td>
<td>Marakon Associates</td>
<td><a href="http://www.marakon.com">http://www.marakon.com</a></td>
</tr>
<tr>
<td>Financial firms</td>
<td>Morgan Stanley</td>
<td><a href="http://www.ms.com">http://www.ms.com</a></td>
</tr>
<tr>
<td>(explore career opportunities)</td>
<td>Merrill Lynch</td>
<td><a href="http://www.ml.com">http://www.ml.com</a></td>
</tr>
<tr>
<td>Firms you buy services from</td>
<td>Northwest Airlines</td>
<td><a href="http://www.nwa.com">http://www.nwa.com</a></td>
</tr>
<tr>
<td>(explore services offered)</td>
<td>American Airlines</td>
<td><a href="http://www.aal.com">http://www.aal.com</a></td>
</tr>
<tr>
<td>Book stores you can buy from</td>
<td>Amazon</td>
<td><a href="http://www.amazon.com">http://www.amazon.com</a></td>
</tr>
<tr>
<td>(explore web shopping)</td>
<td>Barnes and Noble</td>
<td><a href="http://www.barnesandnoble.com">http://www.barnesandnoble.com</a></td>
</tr>
<tr>
<td>B-Schools</td>
<td>Stanford</td>
<td><a href="http://www.gsb.stanford.edu">http://www.gsb.stanford.edu</a></td>
</tr>
<tr>
<td>(explore information provided)</td>
<td>Harvard</td>
<td><a href="http://www.hbs.edu/">http://www.hbs.edu/</a></td>
</tr>
</tbody>
</table>

If you would like further information on web site design, consult the Style Guide web sites:

http://www.w3.org/Provider/Style/Overview.html (authored by Tim Berners-Lee)
http://www.w3.org/Style/Welcome.html
http://info.med.yale.edu/caim/manual/contents.html
The instructions in this note apply to the PCs (running the Windows operating system), and have been written for students with no previous experience with these steps. If you have some experience with the web, you may want to skip ahead to further sections, according to this table:

**Section I: Setting up your Accounts**

**Step 1: Getting Your Athena/Kerberos Account:**

Athena/Kerberos is a campus-wide networked computer system serving the needs of MIT’s academic community. All MIT students are entitled to an Athena account with 20 Megabytes of disk space, 1200 free pages of print, e-mail facilities, software use, consulting, and training about the system. You will use these resources (particularly the disk space) to publish your web site.

You only need an Athena account to publish your web-site, and as it takes approximately 24 hours to activate an Athena account once you have registered, we recommend you register for an Athena account immediately (if you have not already done so).
Step 2: Accessing Your Sloan Account

The Sloan School provides its students with additional computing resources in the Sloan Computer Labs. If you are a regular Sloan student you will have obtained a Sloan lab account. If you don’t have a Sloan user name for some reason (e.g., you are not a Sloan student or you have forgotten your previously assigned Sloan user name), please contact your TA.

Once you have a Sloan user name, you should log into the Sloan computers to make sure you have access to the appropriate resources.

Section II: Building Web Page Files

There are a variety of tools available to design your web-site from which we have chosen to support one. We felt that FrontPage would give you the opportunity to build more complex projects with heavy use of links. Please note, however, that FrontPage is a complex program with a lot of features which we will not expect you to learn for this class. FrontPage is a commercial product (you will need to purchase a copy).

A variety of additional products can generate web pages (like Microsoft Word or PowerPoint). You are welcome to use one of these other products, but you have to understand that our ability to support you in case you run into problems is limited to Microsoft FrontPage.

The rest of this section explains how to generate a home page with Microsoft FrontPage and perform the tasks we asked you to do step by step.

Microsoft FrontPage

This is by no means a comprehensive introduction into FrontPage. It will only show you how to perform the few steps you need to do in order to build a simple home page! We urge you to explore additional features of FrontPage yourself, should you choose it for your web publishing projects.

Microsoft FrontPage is an integrated Web-site development environment. Writing and editing a small web site with FrontPage is relatively simple. There are appropriate wizards (little programs which support you in accomplishing some tasks) which help you with most complicated chores. Furthermore FrontPage has an intuitive Graphical User Interface (GUI), and you do not have to deal with Hyper Text Markup Language (HTML), the language used to display files on the World Wide Web.

The following steps walk you through creating a number of interlinked web pages, which will constitute your personal web site.
Creating your own personal web-site

Start up Microsoft FrontPage. Choose File from the toolbar and select New. The new Navigation pane on the right hand side will ask you what kind of web you want to create. Choose ‘Web Package Solutions’ under ‘New Web Site’, then select the ‘General’ tab in the dialog box that opens up and choose ‘Personal Web Site’. Then select the Browse button to specify the location and name of your web page.

After entering the location for your files, click ‘OK’. All you will have to do now is to change it to your liking and insert links and applets.

**ATTENTION:** Make sure your home page is saved as “index.html” and not “index.htm”. Any other name than “index.html” will prevent your website from being published correctly on the Athena network. Make sure you name your home page “index.html” before you create any other links to it from other pages.
Figure 2: Overall view of FrontPage Navigation pane

Figure 2 shows a screen dump of the FrontPage Navigation pane. You choose different views on your site at the bottom. Currently the ‘Navigation’ view is chosen which shows you a graphical representation of the web, with a home page and sub-pages (interests, photo-gallery and favorites). On the left you can see the actual files relating to the pages including their titles and some additional information about them. You can change the pages name’s by double-clicking them in the upper graphical view. If you want to edit one of the pages double-click on its respective file which opens the FrontPage Editor displaying the chosen page.

FrontPage automatically generates code that will help you to navigate between the web pages you can see in the ‘Navigation’ View.

Before we go on examining and editing a single page we will choose an overall theme for our web site. Choose the Format from the toolbar and select Themes. Click on the page that you would like to apply a theme to and in the Theme’s Navigation pane on the right, select the Theme that you would like to apply to this page. When you are done, close the Theme’s navigation pane on the right. Then return to the ‘Navigation’ by clicking on the button ‘Navigation’ at the bottom of the application and make sure you are in the tab that is called ‘index.html*’.
Examining HTML Code

FrontPage automatically transforms your GUI editing commands into HTML code so that any web browser can interpret and thus display your page appropriately. Before you start editing, take a few minutes to examine the HTML code of the template home page to get a sense of what it looks like. To do this, click on the ‘Code’ button at the bottom (see Figure 3). You may recognize some of the text you can see in the template in addition to all types of instructions to the web browser how to display the text. The line “<p align="left"><font size="4" face="Arial">Welcome to my Web site!</font></p>” for instance instructs the browser to align the following paragraph left, then change the font size to 4 and the font type to ‘Arial’ and then write the paragraph ‘Welcome to my Web site’. Once you’ve viewed some HTML, you can return to the ‘Design’ Tab by clicking on the Design button at the bottom.

Editing your Home Page

To enter text about yourself into your home page, simply type over the text that is provided by the template. Remember to keep saving your home page as you work on it, to retain your changes (e.g. use ‘File’ → ‘Save’ or the Save button in the tool bar). You can edit the text of your home page as though you were working on a word processor. Text formatting options are in the ‘Format’ menu or in the toolbar. You can choose different font sizes and colors for your text, arrange the text in unordered or ordered lists, or choose different levels of indentation.
Note, however, that due to certain HTML limitations, you will not have as many formatting options as you usually have in a word processor such as MSWord.

✔ You can copy and paste some text from a word processor into the FrontPage Editor. However, you will lose any formatting you might have added to the original text file. So, you will have to do some text formatting in the new web page file within FrontPage Editor to ensure the text looks good.

**Inserting Links into your Home Page**

A hyperlink or link is a clickable reference to another HTML document. This could be another page on your web site or a page on another web server. To insert links in your home page, first highlight the text and/or images you want to transform into a link, and then click on the ‘Link’ button, displayed as a ‘globe and chain’ link icon (or go to the ‘Insert’ menu and select ‘Hyperlink’). A ‘Edit Hyperlink’ window appears where you specify the exact URL (including the “http://” prefix) where you want the browser to take your readers when they click on that text.

You can also make links that go to a place within your own Home page. This is particularly useful when web pages contain a lot of information, and can be indexed. To do this, you must first establish internal Bookmarks, which will be then referenced in normal links. Choose a place where you want an indexing link to take you within your home page, place the cursor there and choose ‘Edit’ → ‘Bookmark…’. It then asks you for a name of this bookmark. Give the bookmark a name, and click OK. The next time you insert a link, select the Insert, then Hyperlink, then select ‘Place in this Document’ on the left in the dialog and select the bookmark you want the browser to jump to.

To create a link on your home page to another local page (e.g. your resume page), select the page at the top of the link dialog using the Browse for File option instead of entering a URL.

**Inserting a graphic or your Photo into your Web Page File**

To embed pictures in web pages, you need to have a file created using one of the common graphics representations for use with the web: GIF or JPEG (abbreviated JPG in Windows machines). GIF generally has better quality, while JPG, being a compressed image representation, takes less disk space and loads faster. You can use icons/pictures from the web or you can insert pictures that are already saved on your computer. If you’d like to use icons/images from the web, a good source is [http://www.iconbazaar.com/](http://www.iconbazaar.com/) for all kinds of icons. Please think about the copyright implications when you use a picture from another web page. Whichever option you used, you now have a JPG or GIF file with an image, which you can insert into your home page. Within FrontPage Explorer choose ‘Insert’ → ‘Picture’ → ‘From File’, then select the picture you want to add. If you are in the ‘Navigation’ view you will see the newly added picture and you can resize and handle it just like all other elements (Additional properties of the picture can be edited by clicking on the picture with the right mouse button and choosing the ‘Show pictures toolbar’).

**Adding a Java applet**

Java applets can be added to your web page by inserting html “tags”. In order to run an applet inside a web page you need to use three different tags. The first is `<APPLET>`. This tag specifies the name of the program that will be run, the height and width of the box on the web page that the program will occupy. After the APPLET tag, series of `<PARAMETER>` tags are
used to specify run-time arguments the Java program needs. Finally, the </APPLET> tag is used to indicate that the applet is completely defined.

The syntax for the <APPLET> tag is:

```html
<APPLET
    CODEBASE = codebaseURL  Directory on web server were the applet is located
    CODE = appletFile  Name of the applet
    WIDTH = pixels HEIGHT = pixels  Size of the applet
>
```

The syntax for the <PARAM> tag is:

```html
<PARAM NAME = {Attribute Name} VALUE = {value}>
```

For a more detailed description of the <APPLET> tag please refer to Sun’s java documentation at http://java.sun.com/products/jdk/1.1/docs/guide/misc/applet.html.

To keep the exercise simple, the text of the actual tags that you will need to invoke the applet you choose will be provided. The code should be copied into FrontPage. There are two ways of inserting a Java applet in FrontPage Editor: You either insert it using an interactive form or edit the HTML-code directly.

**Inserting an Applet in the HTML code – EASIER**

You can edit the HTML code directly by clicking on the Code Tab at the bottom of the FrontPage Editor. Find the appropriate position and enter the Applet Code exactly as it appears below. Change back to the normal view of the FrontPage Editor by clicking on the ‘Design’ Tab.

**Inserting an Applet using the interactive form**
Figure 4: Defining an applet parameter in FrontPage

To insert the applet using the interactive form place the cursor in the FrontPage Editor at the place where you want to enter the applet. Then choose ‘Insert’ → ‘Web Component’ → ‘Component Type’ → ‘Advanced Controls’ → ‘Java Applet’ and enter the information about the applet.

In both options FrontPage displays an icon with a big ‘J’ where you insert a Java applet to represent it.

There is a choice of three applets, which you can select from to incorporate into your home page, a clock, a calculator, or a limited spreadsheet. The code required for each is given below.

**The Clock**

To add the clock insert this code:

```html
<APPLET codebase="http://web.mit.edu/15.561/www/java/Clock"
code="Clock2.class" width=170 height=150>
<PARAM name=fgcolor1 value="ffff00">
<PARAM name=fgcolor2 value="ff0000">
<PARAM name=bgcolor value="0000ff">
</APPLET>
```

**The Calculator**

To add the calculator button insert this code (to actually start the calculator, click on the button):

```html
<APPLET codebase="http://web.mit.edu/15.561/www/java/Calculator"
code="AppletButton.class" width=350 height=60>
<PARAM name=windowTitle value="Pocket Calculator">
<PARAM name=buttonText value="Pocket Calculator – Press here to start calculator ";>
</APPLET>
```

**The Spreadsheet**

To add the spreadsheet insert this code:

```html
<APPLET codebase="http://web.mit.edu/15.561/www/java/SpreadSheet"
code="SpreadSheet.class" width=320 height=120>
<PARAM name=rows value="3">
<PARAM name=columns value="3">
<PARAM name=b1 value="v456">
<PARAM name=a1 value="v123">
<PARAM name=c1 value="fA1*B1">
<PARAM name=b2 value="v100">
<PARAM name=a2 value="v200">
<PARAM name=c2 value="fA2+B2">
</APPLET>
```

Once you have entered all the tags for the applet, you can see if it is working correctly by viewing the document in the browser. You can test the page (and the Java applet) at any time by saving it and choosing ‘File’ → ‘Preview in Browser…’. The browser will then display the page as other people will see it on the web and also initialize and show you the exact appearance of the Java applet. If the applet is working correctly, a message will be displayed in the status line at the bottom of the screen indicating that the applet is running, when the mouse is positioned on within the applet region of the page. If there are problems, an error message will be displayed.
After the Java applet is working correctly, try modifying the parameter values to see how the applet changes.

*Testing Your Web Page Files*

You'll find that things are much easier if you keep adding small things to a “working” home page document. So start with something very simple and see how it displays. Then start adding stuff. If something goes wrong, you'll know it was the change you just made. Periodically, you can select ‘Preview in Browser…’ from the ‘File’ menu of FrontPage Editor.

**Section III: Publishing your Web Site**

**Preparing Your Athena Account for Web Site Publishing**

The final part of publishing a web page consists of installing your web page files onto the Athena server, so that your web site becomes accessible to us (and the entire world!). For that to happen, you have to prepare your disk space in the Athena servers for web site publishing. Specifically, you must login to your Athena account and create a world-readable WWW directory directly under your home directory, where you will then place your web pages (home and other pages) and GIF picture files.

[!] If you have already installed a ‘www’ directory in your account and opened its access to everybody (e.g. as part of another assignment or as part of the Media and Technology Club’s presentation) just skip to “Transferring Your Web Page Files and GIF Picture Files to Your Athena Account” section.

Having accessed Athena, a Telnet window will appear where the Athena system prompts you for your Athena/Kerberos user name and password. Type them in. Some introductory messages will then be displayed and finally the prompt athena% appears, indicating that it is ready to accept user commands. Type the following UNIX commands, each on a separate line (i.e., press enter after each line):

```
mkdir ~/www
fs sa ~/www system:anyuser read
logout
```

The last command (logout) should terminate your connection with the Athena server, and quit the Telnet application. If it doesn’t do this, you can do it yourself by closing the Telnet window.

**Transferring Your Web Page Files and GIF Picture Files to Your Athena Account**

To publish your web site, you must copy all your web page files (index.html and e.g. Resume.html) and other related files (such as your JPG or GIF picture file) into the www directory you just created. Follow these steps:

2. If all goes well, at this point you will have been connected to your Athena folder. SecureFX will display two windows: One showing your local files and another displaying your Athena folders.

3. Drag and drop your web page and all related files (such as your JPG and GIF picture files) from your local files window to the www directory of your Athena folder.

4. You are done!

After you have finished these steps, your web page should be accessible from any Web browser.

Note: URL's are case-sensitive. Thus Jsmith and jsmith are different URLs.

Accessing Your Published Web Site

After you installed your home page on the Athena server, check to make sure it works by trying to access it from a browser. Open your web browser and type in what you think is your URL. If you can’t access your home page, we won’t be able to either! Make sure you check all the links you have included in it. Full credit will only be given to a fully functional web site.

Congratulations!