Lab 7 - Site Selection with Vector Data

Site Selection with Vector Data

Introduction
Imagine that you are looking for a place to build a warehouse for your environmental engineering supply
company. You would like to build it in Cambridge or Somerville. Although you doubt that there is much
room left to build in these towns, you want to use GIS to quickly assess what sites are available. You
will need to fulfill a number of requirements for your warehouse - you need to be near a train line and
you are only interested in sites that are zoned appropriately: Light Industrial and General Industrial.
To accomplish this task, you have a number of spatial datasets:
●
●
●

Land Use
Zoning
Train Tracks

You will use follow this process:
●
●
●

find the areas near train tracks.
find the land that is zoned appropriately.
find out the current land use.

All of the datasets were obtained directly from MASSGIS, the state agency charged with the collection,
maintenance, and distribution of spatial data in Massachusetts. The data have been re-named for ease of
use, and have had the projection defined as Mass State Plane (Mainland).
The MASSGIS web site is http://www.state.ma.us/mgis. The landuse and zoning codes are available
from this website. They are provided below for your convenience.
Zoning - Primary Use (PRIM_USE) codes:
CP - Conservation/Passive Recreation
R1 - Single Family Residential, >= 80,000 sq. ft.
R2 - Single Family Residential, 40,000 - 79,999 sq. ft.
R3 - Single Family Residential, 20,000 - 39,999 sq. ft.
R4 - Single Family Residential, 15,000 - 19,999 sq. ft.
R5 - Single Family Residential, 5,000 - 14,999 sq. ft.
RA - Residential/Agricultural Mix
ML - Multi-family, low density (3-8 D.U./acre) (D.U. = dwelling units)
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MM - Multi-family, medium density (9-20 D.U./acre)
MH - Multi-family, high density (> 20 D.U./acre)
MU - Mixed Use
IN - Institutional
HC - Health Care
OP - Office Park
HB - Highway Business
LB - Limited Business
GB - General Business
CB - Central Business
LI - Light Industrial
GI - General Industrial
NZ - Not Zoned
Landuse
CODE - ABBREV - CATEGORY - DEFINITION
1 - AC - Cropland - Intensive agriculture
2 - AP - Pasture - Extensive agriculture
3 - F - Forest - Forest
4 - FW - Wetland - Nonforested freshwater wetland
5 - M - Mining - Sand; gravel & rock
6 - O - Open Land - Abandoned agriculture; power lines; areas of no vegetation
7 - RP - Participation Recreation - Golf; tennis; Playgrounds; skiing
8 - RS - Spectator Recreation - Stadiums; racetracks; Fairgrounds; drive-ins
9 - RW - Water Based Recreation - Beaches; marinas; Swimming pools
10 - R0 - Residential - Multi-family
11 - R1 - Residential - Smaller than 1/4 acre lots
12 - R2 - Residential - 1/4 - 1/2 acre lots
13 - R3 - Residential - Larger than 1/2 acre lots
14 - SW - Salt Wetland - Salt marsh
15 - UC - Commercial - General urban; shopping center
16 - UI - Industrial - Light & heavy industry
17 - UO - Urban Open - Parks; cemeteries; public & institutional greenspace; also vacant undeveloped
land
18 - UT - Transportation - Airports; docks; divided highway; freight; storage; railroads
19 - UW - Waste Disposal - Landfills; sewage lagoons
20 - W - Water - Fresh water; coastal embayment
21 - WP - Woody Perennial - Orchard; nursery; cranberry bog
22 - - - No Change Code used by MassGIS only during quality checking

Starting ArcGIS and adding data to the map
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Start ArcGIS with a new, empty map.

to open the Add Layer Dialog. Navigate to the folder indicated above, and add
Use the add button
the following files to your map:
●
●
●
●
●
●
●
●
●

zoning_camb.shp (Cambridge Zoning - polygons)
zoning_som.shp (Somerville Zoning - polygons)
lus_camb_p.shp (Cambridge Land Use - polygons)
lus_som_p.shp (Somerville Land Use - polygons)
roads_camb.shp (Cambridge Road Centerlines - lines)
roads_som.shp (Somerville Road Centerlines - lines)
trainsa1.shp (Massachusetts Railroads - lines)
schoolx1.shp (Massachusetts Schools - points)
biketrails.shp (Massachusetts Bike Trails - lines)

Look at the data. You are looking at all of Massachusetts. Zoom in so that you are only seeing the area
around Cambridge and Somerville.
You will want to create a Lab8 folder in your local directory, to store the files you create in this
lab.

Processing Data
We will perform a number of processes on the data that we have, mostly using the GeoProcessing
Wizard and the Buffer Wizard, both of which are available through the Tools menu. The GeoProcessing
Wizard contains a number of tools for processing vector data, from merging layers together, to clipping
layers. There is extensive help available for each function, from within the wizard. The Buffer Wizard
is a tool for creating buffers (lines or polygons) around the features of any vector data file. It gives you
the option to specify which features, as well as how far the buffer should be, among many other details.

Merging Files
The first thing we need to do is combine the two landuse files and the two zoning files, to simplify
further processing.

Lab 7 - Site Selection with Vector Data

From the Tools menu, open the GeoProcessing Wizard, and select "Merge layers together".

Click Next, and on the following screen, select the two zoning shapefiles. For the output, select your
Lab8 directory and call the file "zoning_merge.shp".
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Click Finish and wait for the Wizard to process your data. The new file will be added to your layers
list.
Remove the two separate zoning layers, as you will not need them anymore.
Repeat the above steps with the Land Use layers, and call the new file "lus_merged.shp". And repeat it
once more for the two road layers, calling the new file "roads_merge.shp". Don't forget to remove the
separate land use and roads layers when you have finished.

Selecting data to create a new data layer
The railroads (trains) dataset contains the railroads for all of Massachusetts. Since we will need to do
buffering operations on this dataset later, we want to clip it down, so that we only have to process those
features in the dataset which are in our area of interest (otherwise the buffering would take a very long
time). There are several ways to do this. One is to use the GeoProcessing Wizard to clip the trains layer
to one of the combined landuse or zoning layers. This effectively snips off everything from one layer
that does not fall within the area covered by the other, and would therefore clip out only those railroad
tracks within Cambridge and Somerville. You can try that if you like, but for this lab, we will show you

Lab 7 - Site Selection with Vector Data

another method.
Make only your landuse, zoning, and trains layers visible. Move the landuse and zoning to the bottom
of the list, so that you can see the other objects on top of them. Make sure you are zoomed in so that
you can see all of Cambridge and Somerville, but not much more.
In the Selection menu, go to "Set selectable layer". Set is so that the trains layer is the only one
selectable.

Click Close, and then select the "Selection Tool"

from your toolbar.

Click in the upper left corner of the map and, keeping the left mouse button depressed, drag a box that
completely surrounds the towns, so that all the train tracks within them are selected.
Now right click on trains in the table of contents and then click on Selection then Create Layer From
Selected Features. This will add the selected set of railroads to the map as a layer, i.e., as a view of the
data that you already added. This layer uses the original datafile, but only displays those features that
you selected. If you wanted to create a new dataset (shapefile) that contained only those features, you
would export the layer, but for this lab, that won't be necessary.
If there are still selected (highlighted) features on your map, you can remove the selections by clicking
on the Selection menu then clicking on "Clear Selected Features".
Remove the original trains layer from your layers list. Edit the symbology of the new trains layer, using
the Railroad symbol from the pre-made symbols list.
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Creating Buffers
Buffers require defined map units, which you haven't done yet. Click on the View menu the on Data
Frame Properties. Click on the General tab. Change the Map Units to meters as shown:

Open the Buffer Wizard by clicking on the Tools Menu then on Buffer Wizard. You should see the
dialog below.
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Make sure your new trains layer is selected from the drop-down menu, and click Next.
For locating our warehouse, we will define "close to a railroad track" as within 100 meters. In the next
window, change the defaults to match those shown in the image below (distance = 100 and units =
meters).
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Click Next. The output from a buffer operation can be a shapefile or a graphic on the map. We want to
create a shapefile. In the next window (below), select "In a new layer...", and define the output location
as your Lab8 folder. Name the file "trains_buffer", as shown below.
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Click on Finish. Your new shapefile is added to the map.

Select By Theme
To speed processing and to clarify what your results will be, you will want to first select the areas that
have the appropriate zoning then select only those that intersect with the buffers you created for the
railroads. Recall that the two zonings that we are interested in are Light Industrial (LI) and General
Industrial (GI). These codes are in the Primary Uses (Prim_Use) field in the zoning dataset. Open the
attribute table of the zoning layer and look at the fields. Find the Prim_Use field and note all the codes
it contains. Close the Attribute table.
First, you will use the "Select By Attributes" tool to select only those areas that are zoned LI and GI.
Click on the Selection menu and then click on "Select By Attributes". You should see the Select by
Attributes dialog below. Change the selections to match those in the image below.
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Click on Apply to make the selections, then click on Close to close the dialog. You will see the areas
with the appropriate zoning highlighted on your map.

Select by Location
Now you will need to find all of the areas with appropriate zoning that intersect the buffer of the
railroads (areas within 100 meters of the railroads). You will do this with the Select By Location dialog.
This will allow you to use the geography of the map layers to decide if there is an intersection. An
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intersection is defined as the polygons touching or crossing the zone polygons that you have selected.
To open the Select by Location dialog, click on the Selection menu then click on "Select By Location".
You will see the window below. Change the selections to match those in the image below.

Click on Apply to make the selections, then click on Close to close the dialog. You will notice that a
few of the selected areas (such as those in East Cambridge, which are not near any railroad tracks) are
no longer selected.
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Save these selections to a new layer as you did before: right click on the zoning_merge layer, click on
Selection, and then on "Create Layer From Selected Features". The features which meet the criteria are
added as a new layer.

Processing - clipping a shapefile using another shapefile
You now need to see what the current land uses are in the areas that are near the railroads and have the
desired zoning.
Before you do this, add the pre-made symbology to the landuse file. Go to the symboloby editor for
your landuse layer. Click the import button, and use the browse button to find the Landuse.lyr file in the
lab8data directory. Use this to symbolize your landuse, (use the LU21_CODE field).
Now you will want to clip the land use layer using the select areas in the zoning layer. The clip operation
creates a new polygon shapefile that is entirely contained within the set of polygons representing the
selected zones. The clip operation is like a cookie cutter, and is part of the Geoprocessing Wizard. Start
the wizard by clicking on the Tools menu then clicking on GeoProcessing Wizard. You should see this
dialog:
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Choose the "Clip One Layer Based On Another" Option then click Next to see the window below.

As shown above, select your merged landuse layer as the layer to clip, select your zoning selection as
the clip layer, and send the output to your Lab8 folder. Call the file "lus_clip.shp".
When you are ready, click Finish. This will add the new layer to your map. You can make the old land
use and zoning invisible by clicking on the checkbox next to their names in the Table of Contents.
Change the symbology for this new clipped landuse layer the same way you did before, by importing the
symbology information from "landuse.lyr".

Looking at the clipped Land Use layer
You now need to look at the land use of the selected layers to see what the current land use is. While the
zoning may be Light Industrial, the actual current use may be residential. You may not be able to build
because of community concerns. Turn on the bike routes layer. Are any of these areas near a bike trail?
How about schools? Are any of the potential sites within 150 meters of a school? Would you want to

Lab 7 - Site Selection with Vector Data

build a warehouse that close to a school?
As part of the assignment, please use the "buffer tool", or the "select by location tool" (probably simpler)
to count how many of your potential sites are within 150 meters of a school.

Homework - To Hand In
For this assignment, create a map of Cambridge and Somerville, showing the potential sites you have
identified. Please display your sites with the landuse symbology, the roads, and the train tracks. Make a
layout that would go into a company report on siting your new warehouse. Include a box on the map
that indicates how many of the sites are within 150 meters of schools.

NOTE:
There are many ways to make spatial selections in ArcGIS. Use of the Select by Attribute and Select by
Location are perhaps better than the Clip GeoProcessing tool since the former methods preserves the
complete polygon whereas the Clip saves only the area that intersects with the polygon layer you are
using to clip with (the buffer, in our case).
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